Advertisement:

Author Topic: TinyPortal  (Read 758642 times)

Offline IchBin™

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 11,115
  • Gender: Male
  • I don't speak German.
Re: TinyPortal
« Reply #1000 on: January 11, 2011, 02:17:27 PM »
Thanks for reporting the bug.

In Sources/TPmodules.php find:
Code: [Select]
            // insert the comment
            tp_query("INSERT INTO " . $tp_prefix . "variables (value1,value2,value3,type,value4,value5)
                            VALUES('". $title. "','". $comment. "','$ID_MEMBER','article_comment','$time',$article)", __FILE__, __LINE__);

Replace with this:
Code: [Select]
            // insert the comment
            tp_query("INSERT INTO " . $tp_prefix . "variables (value1,value2,value3,type,value4,value5)
                            VALUES('". mysql_real_escape_string($title). "','". mysql_real_escape_string($comment). "','$ID_MEMBER','article_comment','$time',$article)", __FILE__, __LINE__);
IchBin™        TinyPortal
Coding Guidelines       

Offline Average Mom

  • Semi-Newbie
  • *
  • Posts: 27
    • Average Mom
Re: TinyPortal
« Reply #1001 on: January 11, 2011, 05:27:12 PM »
That fixed it! Thank you very much! :)

Offline Average Mom

  • Semi-Newbie
  • *
  • Posts: 27
    • Average Mom
Re: TinyPortal
« Reply #1002 on: January 11, 2011, 10:03:43 PM »
Got another one for ya LOL

...forum/index.php?/page,12.html
8: Undefined variable: avatar_height
File: /..../forum/Sources/TPortal.php
Line: 742

I get it only when someone views an article, though I'm not sure if it's the article itself or viewing it on the frontpage or both, I get the same error for avatar width also. I didn't realize I was getting that error also because there were so many errors from the other bug.

Offline IchBin™

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 11,115
  • Gender: Male
  • I don't speak German.
Re: TinyPortal
« Reply #1003 on: January 12, 2011, 11:20:27 AM »
What are your frontpage settings and what are your category settings? I need to try the same setup as you so I can figure it out.
IchBin™        TinyPortal
Coding Guidelines       

Offline Average Mom

  • Semi-Newbie
  • *
  • Posts: 27
    • Average Mom
Re: TinyPortal
« Reply #1004 on: January 12, 2011, 11:43:40 AM »
This is what you are asking to see right?

Offline IchBin™

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 11,115
  • Gender: Male
  • I don't speak German.
Re: TinyPortal
« Reply #1005 on: January 12, 2011, 12:11:49 PM »
Ah thank you. That helps. It would appear it only errors like this if someone is using an external avatar and it tries to load that avatar as the author of an article. Let me take a look and see what the proper fix would be here in a bit.
IchBin™        TinyPortal
Coding Guidelines       

Offline Average Mom

  • Semi-Newbie
  • *
  • Posts: 27
    • Average Mom
Re: TinyPortal
« Reply #1006 on: January 12, 2011, 12:41:09 PM »
Thanks, I appreciate it :)

Offline IchBin™

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 11,115
  • Gender: Male
  • I don't speak German.
Re: TinyPortal
« Reply #1007 on: January 12, 2011, 01:10:35 PM »
In TPortal.php find this code about line #725
Code: [Select]
$ccount=0; $newcount=0;
if(tpdb_num_rows($request)>0)
{

Add this code before it.
Code: [Select]
// setup the avatar code
if ($modSettings['avatar_action_too_large'] == 'option_html_resize' || $modSettings['avatar_action_too_large'] == 'option_js_resize')
{
$avatar_width = !empty($modSettings['avatar_max_width_external']) ? ' width="' . $modSettings['avatar_max_width_external'] . '"' : '';
$avatar_height = !empty($modSettings['avatar_max_height_external']) ? ' height="' . $modSettings['avatar_max_height_external'] . '"' : '';
}
else
{
$avatar_width = '';
$avatar_height = '';
}
IchBin™        TinyPortal
Coding Guidelines       

Offline Average Mom

  • Semi-Newbie
  • *
  • Posts: 27
    • Average Mom
Re: TinyPortal
« Reply #1008 on: January 12, 2011, 01:17:43 PM »
Thanks so much! That fixed it!  I appreciate the help and all the work you put into this.  :-*

Offline anomaly

  • Newbie
  • *
  • Posts: 2
Re: TinyPortal
« Reply #1009 on: January 14, 2011, 12:54:44 AM »
FYI I found the bug with the online box only showing avatars instead of names.  On line 2407 of Sources/TPortal.php, change

                               if($block['var1']=='')
                                        $context['TPortal']['useavataronline'] = 0;
                                else
                                        $context['TPortal']['useavataronline'] = 1;

To:


                               if($block['var1']=='0')
                                        $context['TPortal']['useavataronline'] = 0;
                                else
                                        $context['TPortal']['useavataronline'] = 1;


(note, only the first line is changed, I provided the rest for context)

Cheers,

Anomaly

Offline IchBin™

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 11,115
  • Gender: Male
  • I don't speak German.
Re: TinyPortal
« Reply #1010 on: January 14, 2011, 10:44:46 AM »
Thank you! I'll add this in for the next release.
IchBin™        TinyPortal
Coding Guidelines       

Offline TeaTephi

  • Jr. Member
  • **
  • Posts: 195
    • The Shepherd's Disciples
Re: TinyPortal
« Reply #1011 on: January 14, 2011, 02:05:01 PM »
I upgraded successfully to smf 2.0 and tp 1.0.    However my shoutbox and other panels are visible to guests,  I don't have them checked off for access.  What am I missing?   


The screen shot shows that guests are unchecked yet they still see the shoutbox
« Last Edit: January 14, 2011, 02:32:27 PM by TeaTephi »
SMF 2.0.2 | TinyPortal 1.107 Veterans day theme Opera 11.50
Mods:Profile Comments.....AEVA Media 2.10.....Activity in profile.....join-reason....Bookmarks 2.3.....SA Chat    Beta 4-1 Rev43....Tapatalk SMF 2.0 RC4/RC5/Final Plugin    3.0.1.....SMFPacks Likes Lite Mod

Thank you guys for all your support and development that you do.  I love my forum, and am so thankful to have a place to ask my questions.  I do love SMF 2.0 it's smoother and all my members love it!

Touti

  • Guest
Re: TinyPortal
« Reply #1012 on: January 14, 2011, 02:07:35 PM »
Is there a known issue that would prevent the Rhino theme to work properly with TP RC1 ?  I just upgraded to RC1 from 1.0 Beta4 and now my site is all messed up.

The Front Page and Forum




Strangely, if I disable support for TP in the theme the front page looks better, although the line spacing in the top blocks are wrong, and the forum looks ok but I loose the "Forum" button in my menu.







Offline IchBin™

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 11,115
  • Gender: Male
  • I don't speak German.
Re: TinyPortal
« Reply #1013 on: January 14, 2011, 02:35:46 PM »
I upgraded successfully to smf 2.0 and tp 1.0.    However my shoutbox and other panels are visible to guests,  I don't have them checked off for access.  What am I missing?   


The screen shot shows that guests are unchecked yet they still see the shoutbox

Yep that is a bug in TP1rc1. It's fixed in the next version of TP yet to be released.
http://www.tinyportal.co.uk/index.php?issue=42.0
IchBin™        TinyPortal
Coding Guidelines       

Offline IchBin™

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 11,115
  • Gender: Male
  • I don't speak German.
Re: TinyPortal
« Reply #1014 on: January 14, 2011, 02:37:17 PM »
Touti,

I don't remember which version it happened in, but Bloc made changes to TP quite some time ago so that it didn't require custom template options for TP to work. There should be no reason to turn the option on for TP to work properly. Make sure TP works in the default theme properly. If it does, then you know it's a theme issue.
IchBin™        TinyPortal
Coding Guidelines       

Touti

  • Guest
Re: TinyPortal
« Reply #1015 on: January 14, 2011, 02:54:01 PM »
Thanks Ichbin.  I do have the small "line spacing" issue in the default theme as well but that's something I can fix easily in the style sheets.

Besides that, the only problem I can see so far when disabling TP support in the theme is that I lose the "Forum" button that's no big deal either, I'll just edit the code and fix that.

Thanks again.

Offline IchBin™

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 11,115
  • Gender: Male
  • I don't speak German.
Re: TinyPortal
« Reply #1016 on: January 14, 2011, 02:54:49 PM »
Yes, that is pretty much the only template edit that has to be done in SMF1.x.
IchBin™        TinyPortal
Coding Guidelines       

Touti

  • Guest
Re: TinyPortal
« Reply #1017 on: January 14, 2011, 07:02:07 PM »
I'm afraid I'm gonna help with this.  I've spent the last few hours looking at code and stylesheets but I just can find where the styles for this are.  What I'm trying to do is reduce the spacing between the lines in the Recent Topics block.  I know it's currently at 1.5em but I just can't find where that is in the code and change it to a lower value.

Any help would be appreciated.




Offline IchBin™

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 11,115
  • Gender: Male
  • I don't speak German.
Re: TinyPortal
« Reply #1018 on: January 14, 2011, 07:12:06 PM »
Need to see a link to your site. If you don't want it public feel free to PM it to me.
IchBin™        TinyPortal
Coding Guidelines       

Touti

  • Guest
Re: TinyPortal
« Reply #1019 on: January 14, 2011, 07:19:09 PM »
I should have thought of that.

http://www.totalexpedition.com