• Welcome to Simple Machines Community Forum. Please login or sign up.
October 19, 2021, 03:00:11 PM

News:

Bored?  Looking to kill some time?  Want to chat with other SMF users?  Join us in IRC chat or Discord


SMF 2B4

Started by quiz_modder, November 29, 2008, 06:37:59 PM

Previous topic - Next topic

metallica48423

I have root access :P  I'll check tonight for any new ones and run gdb and then backtrace them
Justin O'Leary
Ex-Project Manager
Ex-Lead Support Specialist

QuoteMicrosoft wants us to "Imagine life without walls"...
I say, "If there are no walls, who needs Windows?"


Useful Links:
Online Manual!
How to Help us Help you   
Search
Settings Repair Tool
     

SlammedDime

SlammedDime
Former Lead Customizer
BitBucket Projects
GeekStorage.com Hosting
                      My Mods
SimpleSEF
Ajax Quick Reply
Sitemap
more...
                     

quiz_modder

OK, got my error loggin back on as I was getting core dumps regardless. Just another one for your information in case it is of any use.

Program terminated with signal 11, Segmentation fault.
#0  0x080b403c in match (eptr=Cannot access memory at address 0xbf751edc
)
    at /usr/src/php-5.2.8/ext/pcre/pcrelib/pcre_exec.c:609
609   /usr/src/php-5.2.8/ext/pcre/pcrelib/pcre_exec.c: No such file or directory.
   in /usr/src/php-5.2.8/ext/pcre/pcrelib/pcre_exec.c
(gdb) bt
#0  0x080b403c in match (eptr=Cannot access memory at address 0xbf751edc
)
    at /usr/src/php-5.2.8/ext/pcre/pcrelib/pcre_exec.c:609
#1  0x080b6554 in match (eptr=<value optimized out>,
    ecode=<value optimized out>, mstart=<value optimized out>, offset_top=2,
    md=0xbf75254c, ims=0, eptrb=0x0, flags=0, rdepth=0)
    at /usr/src/php-5.2.8/ext/pcre/pcrelib/pcre_exec.c:718
#2  0x080be056 in php_pcre_exec (argument_re=0x92237d0, extra_data=0xbf7526d0,
    subject=0x9bdf65c "({int:id_member}, {int:log_time}, SUBSTRING({string:ip}, 1, 16), SUBSTRING({string:url}, 1, 65534), SUBSTRING({string:message}, 1, 65534), {string:session}, {string:error_type}, SUBSTRING({string:file"...,
    length=223, start_offset=0, options=0, offsets=0x9bdf758, offsetcount=9)
    at /usr/src/php-5.2.8/ext/pcre/pcrelib/pcre_exec.c:4937
#3  0x080c17f1 in php_pcre_replace_impl (pce=0x9222208,
    subject=0x9bdf65c "({int:id_member}, {int:log_time}, SUBSTRING({string:ip}, 1, 16), SUBSTRING({string:url}, 1, 65534), SUBSTRING({string:message}, 1, 65534), {string:session}, {string:error_type}, SUBSTRING({string:file"...,
    subject_len=223, replace_val=0x9bdf5c4, is_callable_replace=1,
    result_len=0xbf7527f0, limit=-1, replace_count=0x0, tsrm_ls=0x8f36458)
    at /usr/src/php-5.2.8/ext/pcre/php_pcre.c:1047
#4  0x080c2958 in php_replace_in_subject (regex=0x9bdf580, replace=0x9bdf5c4,
    subject=0x9bf23a4, result_len=0xbf7527f0, limit=-1,
    is_callable_replace=1 '\001', replace_count=0x0, tsrm_ls=0x8f36458)
    at /usr/src/php-5.2.8/ext/pcre/php_pcre.c:1199
---Type <return> to continue, or q <return> to quit---
#5  0x080c2f79 in preg_replace_impl (ht=3, return_value=0x9bdf5dc,
    return_value_ptr=<value optimized out>, this_ptr=0x0, return_value_used=1,
    tsrm_ls=0x8f36458, is_callable_replace=1 '\001')
    at /usr/src/php-5.2.8/ext/pcre/php_pcre.c:1364
#6  0xb6c597ed in ?? ()
#7  0x00000000 in ?? ()

quiz_modder

Did anyone look into this further? Is there anything else you want me to check? I am still getting quite regular core dumps.

SlammedDime

We're still waiting for justin to get another core dump to see if it's similar.  I haven't had any on my live site or my test sites using a combination of 1.1.7 or 2.0B4 or 2.0RC1 and a combination of PHP versions.  I do have to wonder if it's something to do with PHP 5.2.8 though.
SlammedDime
Former Lead Customizer
BitBucket Projects
GeekStorage.com Hosting
                      My Mods
SimpleSEF
Ajax Quick Reply
Sitemap
more...
                     

metallica48423

i do believe im running 5.2.6...  i will check again when i get home.
Justin O'Leary
Ex-Project Manager
Ex-Lead Support Specialist

QuoteMicrosoft wants us to "Imagine life without walls"...
I say, "If there are no walls, who needs Windows?"


Useful Links:
Online Manual!
How to Help us Help you   
Search
Settings Repair Tool
     

metallica48423

I have had ZERO core dumps since i installed the latest beta of the AEVAC mod, which leads me to believe that the mod was still causing it prior to the upgrade.

I am running 5.2.6.  I can upgrade my php version tomorrow if you'd like, to see if they happen then
Justin O'Leary
Ex-Project Manager
Ex-Lead Support Specialist

QuoteMicrosoft wants us to "Imagine life without walls"...
I say, "If there are no walls, who needs Windows?"


Useful Links:
Online Manual!
How to Help us Help you   
Search
Settings Repair Tool
     

quiz_modder

Is there anything else I can do that would provide any clues?

Thanks

quiz_modder

Really weird thing is that these core dumps suddenly stopped without me making any changes about 2 weeks ago. Now today I suddenly got three more even though I haven't made any changes again.  :(

SlammedDime

You could ask your host if they've made ANY server changes to PHP and Apache in the last 3 weeks.
SlammedDime
Former Lead Customizer
BitBucket Projects
GeekStorage.com Hosting
                      My Mods
SimpleSEF
Ajax Quick Reply
Sitemap
more...
                     

quiz_modder

Quote from: SlammedDime on January 10, 2009, 12:38:09 PM
You could ask your host if they've made ANY server changes to PHP and Apache in the last 3 weeks.

Just did and they (Hostgator) replied with the following

"There have been some changes with PCRE in the more recent versions of PHP, and it appears that your forum is creating core dumps when using some of the functions.  I would check to see if there are any recent updates to your forum software to address this, or any suggestions from the support for the software that you are using.  If you have any more questions, or need more information, please let us know."

greyknight17

m4tthall, was this issue resolved? Are you still getting any core dump files?

quiz_modder

Quote from: greyknight17 on January 20, 2009, 08:34:44 PM
m4tthall, was this issue resolved? Are you still getting any core dump files?

Yes, I am still getting core dumps. I am resigned to the fact that I just need to keep removing them for the moment, as I have run out of ideas.

greyknight17

This happened to me before and eventually after constant pestering, they figured out that it was indeed some PHP/Apache problem. They had to recompile them to fix the problem.

quiz_modder

Quote from: greyknight17 on January 30, 2009, 12:07:49 AM
This happened to me before and eventually after constant pestering, they figured out that it was indeed some PHP/Apache problem. They had to recompile them to fix the problem.

I got in contact with them once again and their response was:

"Can you ask them if the forum is updated to work with the new version of PHP and the update to PCRE functions. Since you are on shared server we would not be able to downgrade this for you. "

metallica48423

assuming yo9u are speaking of php5,  yes, smf is 100% php5 compatible
Justin O'Leary
Ex-Project Manager
Ex-Lead Support Specialist

QuoteMicrosoft wants us to "Imagine life without walls"...
I say, "If there are no walls, who needs Windows?"


Useful Links:
Online Manual!
How to Help us Help you   
Search
Settings Repair Tool
     

Skhilled

January 31, 2009, 05:27:37 AM #56 Last Edit: January 31, 2009, 05:29:15 AM by Skhilled
I moved my site to a new hosting and had the same issues after moving. The former hosting had 777 permissions and the new had 755...don't know if that is related or not.

They told me it was something with Tinyportal that was causing it. TP has worked on the other server without a problem so it should have worked on the new one. since my hosting was unable to help and was blaming TP, my solution was to upload the smf upgrade for my version (was 1.1.5 or 1.1.6 at the time) and reinstall my mods. I haven't had the problem since and am with the same hosting.

So, I doubt it is a SMf 2 issue alone. I've also seen this on other hosting services while helping others but never knew why or how it happened. I hope that helps.

greyknight17

S_M_F_Modding, any update on this issue? Maybe try the suggestion by Skhilled (make a backup first).

quiz_modder

Quote from: greyknight17 on February 08, 2009, 07:29:38 PM
S_M_F_Modding, any update on this issue? Maybe try the suggestion by Skhilled (make a backup first).

I upgraded to RC1 two days ago and have not had a core dump since. Fingers crossed this has resolved the issue, but I will keep you posted.

Thanks

Advertisement: