Advertisement:

Author Topic: SMF Problem.  (Read 2665 times)

Offline arxlan

  • Newbie
  • *
  • Posts: 4
SMF Problem.
« on: December 02, 2008, 02:38:34 AM »
1st of all i am glad to join th SMF community. I hope i will have a great stay here.

2ndly coming to my problem regarding smf.

Well.
1). I have installed or you can say i am running "ApacheFriends XAMPP (Basispaket) version 1.6.8".
2). I installed SMF.
3). I have enabled the Member activation. which means when ever a new member registers at my site. He will be sent an email containing a link to activate his account.
4). The problem that i am facing is that when ever a new member registers.. the process goes fine and when he completes the registeration he is taken to a page which says:

Register
Thank you for registering. You will receive an email soon with a link to activate your account. If you don't receive an email after some time, check your spam folder.

The problem here is that he does not recieves any email containing the link to activate his account.

5). I tried  to register a new account as well and i too am having the same problem.

Kindly solve my problem.

Regards,
Arslaan Shaikh

Offline Joey Smith™

  • SMF Friend
  • SMF Hero
  • *
  • Posts: 6,356
  • Gender: Male
Re: SMF Problem.
« Reply #1 on: December 02, 2008, 02:45:05 AM »
I may be wrong here but most XAMPP configurations are set for development purposes and most likely its going to be because the Php.ini is not set to allow for the emails to be sent.

Offline arxlan

  • Newbie
  • *
  • Posts: 4
Re: SMF Problem.
« Reply #2 on: December 02, 2008, 02:47:05 AM »
how to confirm it.? and if it is so.. then kindly tell ho to fix it?

Offline Joey Smith™

  • SMF Friend
  • SMF Hero
  • *
  • Posts: 6,356
  • Gender: Male
Re: SMF Problem.
« Reply #3 on: December 02, 2008, 03:24:04 AM »
First follow this link and make sure you read the parts of the XAMPP documentation about the security issues with running this type of server with a production forum.

http://www.apachefriends.org/winxampp/readme_en.txt

(There is also a way to do this through PHP script but I will have to find that script because I cannot write it.)

Next make sure the settings are correct for the mercury mail server and set the forum to use SMTP to send forum mail. This can be found here:

Admin Control Panel>Mail>Mail Settings (In 2.0 Beta 4)
You will see this in the middle box:
Help     Mail type     
   SMTP server    
   SMTP port    
   SMTP username    
   SMTP password
(confirm)

Fill in the correct information etc. from the drop down select SMTP.

Most likely the port will be 25. However, you must remember that if you are behind a firewall you will need to open that port.

Also, open the Php.ini file and look for this: If on windows* and make sure it is set correctly for your configuration.

[mail function]
; For Win32 only.
SMTP = localhost
smtp_port = 25

I would also like to add that I have run a forum in this manner but I did not do it through XAMPP. In this case it would be better to install the Apache, Php and MysQL etc individually and run them as system services, but that is just my opinion.

ABOVE ALL ELSE make sure you secure your server!!

Offline arxlan

  • Newbie
  • *
  • Posts: 4
Re: SMF Problem.
« Reply #4 on: December 02, 2008, 03:54:14 AM »

(There is also a way to do this through PHP script but I will have to find that script because I cannot write it.)

Next make sure the settings are correct for the mercury mail server and set the forum to use SMTP to send forum mail. This can be found here:

Admin Control Panel>Mail>Mail Settings (In 2.0 Beta 4)
You will see this in the middle box:
Help     Mail type     
   SMTP server    
   SMTP port    
   SMTP username    
   SMTP password
(confirm)

Fill in the correct information etc. from the drop down select SMTP.

Most likely the port will be 25. However, you must remember that if you are behind a firewall you will need to open that port.

Also, open the Php.ini file and look for this: If on windows* and make sure it is set correctly for your configuration.

[mail function]
; For Win32 only.
SMTP = localhost
smtp_port = 25

I would also like to add that I have run a forum in this manner but I did not do it through XAMPP. In this case it would be better to install the Apache, Php and MysQL etc individually and run them as system services, but that is just my opinion.

ABOVE ALL ELSE make sure you secure your server!!

how can i configure mercury mail settings.. i dont know what settings do i need to put in in mercury mail server, also you said that (There is also a way to do this through PHP script but I will have to find that script because I cannot write it.)
can you get that script.?
also
what settings do i need to enter here
Admin Control Panel>Mail>Mail Settings (In 2.0 Beta 4)
You will see this in the middle box:
Help     Mail type     
   SMTP server    
   SMTP port    
   SMTP username    
   SMTP password
(confirm)
?

Offline Joey Smith™

  • SMF Friend
  • SMF Hero
  • *
  • Posts: 6,356
  • Gender: Male
Re: SMF Problem.
« Reply #5 on: December 02, 2008, 04:26:07 AM »
My best advice would be for you to get paid hosting. Everything you need to edit is going to be in a different place in the XAMPP installation. It has been a long time since I used XAMPP and to be honest I did not like it very much. In trying to do what you are doing there could be one of about 20-30 things that could prevent this from working the way it should. Such as (this is a short list)

Wrong setting in Php.ini (this is already a problem I am sure)

Wrong config settings for Mercury (because its set to a local host more than likely)

Could be a problem with a firewall or improperly forwarded port if your wireless.

Also I meant there was a script to test to see if this was the problem. Sorry for the way I put that. SMF has the script to send Php included in the core distribution and it works as long as the Php.ini is set right. Since XAMPP is configured for a development environment this more than likely will not be the case. Furthermore, if you happen to get the Mercury up and running without securing the mail server there will be a high amount of spam running through your server (more than likely) that you are not aware of (which is not good). Also there is no way I can explain how to set all those things in your environment without knowing the setup (I am not a pro at this as you can tell).

If you must do this as you are now trying my best advice is to read the documentation on XAMPP, which will include the documentation on the mail server and it will tell you which files needs to be edited to make this work. The default port is set to 25 but you will need the password, username, and host name.

You must remember that XAMPP is setup to run as a localhost which is not meant to serve files to the net, which means that this may not even work due to where it was installed in the local directory. For it work properly all the installations must be in a certain level in the drive of the system that is serving the files and the file paths must be set correctly in relation to one another. I can do this on my system, but I cannot explain how you should do it since I do not know where you installed this.

There are several members here that use XAMPP a lot and may be able to give you more information than I can, but again I must stress that running XAMPP in this way is not a good idea.

Offline swtdivalove

  • Full Member
  • ***
  • Posts: 652
Re: SMF Problem.
« Reply #6 on: December 02, 2008, 10:24:20 AM »
XAMPP is also not that secure and as Tyrsson said, it's mostly meant for development and intranet, not internet, usage.

It's good if you want to test out PHP scripts, learn MySQL and Apache.  But other than that, it is not meant to handle a load from the internet.

Offline arxlan

  • Newbie
  • *
  • Posts: 4
Re: SMF Problem.
« Reply #7 on: December 03, 2008, 03:25:27 AM »
bro i cant find Admin Control Panel>Mail>Mail Settings (In 2.0 Beta 4)

can you help me out...???

ThorstenE

  • Guest
Re: SMF Problem.
« Reply #8 on: December 05, 2008, 03:55:48 PM »
Try Admin - Maintenance - Mail - Mail Settings instead..