• Welcome to Simple Machines Community Forum. Please login or sign up.
November 29, 2021, 12:38:04 PM

News:

SMF 2.0.18 has been released! Please update. Read more.


SMF 1.0.2

Started by Meriadoc, February 14, 2005, 02:54:45 AM

Previous topic - Next topic

Ben_S

You could have used the package manager to upgrade, that would have been a simple less than five click operation that would not have affected any installed mods or your themes.
Liverpool FC Forum with 14 million+ posts.

Redeye

That sounds like a better idea.

I can find the download files but the update/upgrade package doesn't show up when I search for new downloads in PM?
Am I looking in the right place?

Ben_S

If you are on 1.0.1, it should show something in the package manager about an update being available.
Liverpool FC Forum with 14 million+ posts.

Redeye


Daniel Lundie

Quote from: Daniel Lundie on February 22, 2005, 05:38:29 AM
Quote from: [Unknown] on February 22, 2005, 03:36:48 AM
Quote from: Daniel Lundie on February 21, 2005, 04:22:13 PM
I put Setting_Bak and Settings.php on the server and it returned to giving me a blank white screen again, as well as redirecting me to install.php. So I deleted install.php and now when I go to upgrade.php I get:

Sounds like you used the INSTALL package when you should have used the UPGRADE or UPDATE package.  I'm afraid this caused a few problems... you can fix them by using repair_settings.php....

What is repair_settings.php?

I gave that a shot and it didn't seem to change anything.

I then tried repair_paths/php and that didn't do anything either.

My forum still isn't showing up. :(

As an extra to this:

Is there a way I can save my member list and transfer it over to a different forum until my SMF forum is working again? I don't want to make my forum members go through the sign-up process on a new board again. Is there a way?

alpinestaRR

Quote from: [Unknown] on February 22, 2005, 03:36:48 AM
Quote from: Winters on February 21, 2005, 04:40:57 PM
Hello,

I will admit that for once I haven't read the whole thread... sorry, still just 2 questions:

Can we update/ upgrade from 1.0 (templates still RC 2) and how? (Our pckage manager is NOT working) Or do we have to go via 1.0.1?

Thx in advance.

Yes, both upgrade and update should be fine.

-[Unknown]

I have never upgraded SMF and am using 1.0 RC2. I downloaded the upgrade to 1.0.2, but am unsure what to do now. I have alot of modded default templates... so when I upload the files to my server, do I overwrite my modded templates? How does it retain my mods? The package manager isn't available, so i'm not sure what to do.

I apologize in advance.

Josh

Daniel D.

All your problems are answered in this thread already.

alpinestaRR

Quote from: Daniel D. on February 26, 2005, 01:54:47 PM
All your problems are answered in this thread already.

I read the whole thread, and my impression is that I upload all the files, overwriting them....EXCEPT for any templates that I have made changes too. OR I overwrite them and remake the code changes.

I'm simply looking for clarification - as I really can't afford for my forum to go down.
Thanks.

Mark_Breznay

Very easy.  Like putting a hot knife through butter.
Mark
http://www.americandragracing.com
http://www.sundayniagara.com
http://www.yorkus30.com
BE THERE!!!!!!!!!!!!!!!!!!

Errors of omission create dumb questions.

curmudgeon

Ah, If only I'd just left things the way the Package Manager set them up for me, I would have had no worries. :-[ But I changed "localhost" to my VSP's IP and I changed Port 21 to Port 8888 'cuz that's the way I was told to FTP to my VSP. Trouble is -- Port 8888 expects SFTP, so no dice.  Finally tried localhost and Port 21 and everything sailed through smoothly.

What an insanely great piece of work is this SMF!
---
Look at everything as though you were seeing it either for the first or
last time. Then your time on earth will be filled with glory. -- Betty Smith

[Unknown]

Quote from: Daniel Lundie on February 23, 2005, 10:49:58 PM
Is there a way I can save my member list and transfer it over to a different forum until my SMF forum is working again? I don't want to make my forum members go through the sign-up process on a new board again. Is there a way?

Here's the low down:

Your database is fine.  The only part that is broken is the part that tells SMF where your database is, because you deleted that.  Fixing it is as simple as putting the information back in Settings.php.  This means your database connection information.

The repair_settings.php is a tool that will help you do this, but it cannot do it for you.  You will need to set up your database information again, whatever you do, so that is what you have to do.  There is no getting around that.

Quote from: alpinestarr on February 26, 2005, 02:53:28 PM
Quote from: Daniel D. on February 26, 2005, 01:54:47 PM
All your problems are answered in this thread already.

I read the whole thread, and my impression is that I upload all the files, overwriting them....EXCEPT for any templates that I have made changes too. OR I overwrite them and remake the code changes.

I'm simply looking for clarification - as I really can't afford for my forum to go down.
Thanks.

Theoretically, you shouldn't have changed a single file under Themes/default, so this shouldn't be a problem.  If you changed any of said files, you'll either need to redo them, or better yet make them to a new - and separate - theme.

That said, most of the RC2 templates should work fine with 1.0.2.

Heh, curmudgeon.. sorry, we were both over complicating it.  Glad you got it solved!

-[Unknown]

quake101

I upgraded to 1.0.2 today using the package manager. Everything looks fine. ;D Great work!

Advertisement: