Advertisement:

Author Topic: No Captcha - Members can\'t register  (Read 3140 times)

Offline KahneFan

  • SMF Hero
  • ******
  • Posts: 1,850
  • Gender: Male
    • I Post You Post
No Captcha - Members can\'t register
« on: December 05, 2008, 03:01:01 AM »
For some reason my captcha isn't showing up on the registration page for FireFox users. Please help, it prevents FF users from being able to register  :o

Offline Joey Smithâ„¢

  • SMF Friend
  • SMF Hero
  • *
  • Posts: 6,356
  • Gender: Male
Re: No Captcha - Members can't register
« Reply #1 on: December 05, 2008, 03:29:31 AM »
Well since I guess I am the one that brought this to your attention I could add to this by saying that sometimes they do not show up.

I went to register and once they didn't and the next time they did.

It may have been on my end but rarely does this happen to me.

Offline KahneFan

  • SMF Hero
  • ******
  • Posts: 1,850
  • Gender: Male
    • I Post You Post
Re: No Captcha - Members can't register
« Reply #2 on: December 05, 2008, 03:54:13 AM »
Not just you, as you can see from my screenshot from FF, I saw the same thing.

ThorstenE

  • Guest
Re: No Captcha - Members can't register
« Reply #3 on: December 05, 2008, 03:38:20 PM »
the captcha is "invisible" in Firefox but can be found in html sourcecode.. I think it's a CSS issue.. can you attach  styles.css from your theme here please?

Offline KahneFan

  • SMF Hero
  • ******
  • Posts: 1,850
  • Gender: Male
    • I Post You Post
Re: No Captcha - Members can't register
« Reply #4 on: December 05, 2008, 04:10:24 PM »
It's attached  :)

Offline Oldiesmann

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 24,868
  • Gender: Male
  • Ask me about the function DB :)
    • oldiesmann on Facebook
    • Oldiesmann on GitHub
    • https://www.linkedin.com/in/michaeleshom on LinkedIn
    • @oldiesmann on Twitter
    • Archie Comics Fan Forum
Re: No Captcha - Members can't register
« Reply #5 on: December 05, 2008, 04:41:23 PM »
It appears to be a server problem. When I try to access the verification image directly, I get a "Connection Interrupted" error (meaning the connection was killed unexpectedly before the page finished loading).

Try adding this code to the beginning of index.php to see if it makes any difference - this will set the maximum execution time to 60 seconds and allow PHP to use up to 32MB of memory (which should be more than enough for that):

Code: [Select]
@ini_set('max_execution_time', 60);
@ini_set('memory_limit', '32M');

The "@" will prevent errors if your host has disabled ini_set (which isn't all that common among paid hosts, but you never know).
Michael Eshom
Cincy Space - now open!

Offline glennk

  • Sr. Member
  • ****
  • Posts: 899
Re: No Captcha - Members can't register
« Reply #6 on: December 05, 2008, 04:51:41 PM »
Just a long shot but you havn't been messing with any 301's have you ? I redirected /forum/index.php to /forum/ and I lost a lot of things including my captcha image.

Offline KahneFan

  • SMF Hero
  • ******
  • Posts: 1,850
  • Gender: Male
    • I Post You Post
Re: No Captcha - Members can't register
« Reply #7 on: December 06, 2008, 01:06:10 AM »
@ Oldiesmann, I added the code as such...

Code: (index.php) [Select]
@ini_set('max_execution_time', 60);
@ini_set('memory_limit', '32M');

$forum_version = 'SMF 2.0 Beta 4';

Testing FF on my laptop it seems to work now. Please also test the direct way you were speaking of and let me know if it gets killed again.

ThorstenE

  • Guest
Re: No Captcha - Members can't register
« Reply #8 on: December 06, 2008, 02:01:17 AM »
Testing FF on my laptop it seems to work now. Please also test the direct way you were speaking of and let me know if it gets killed again.
yes, both work now :) Interesting: I tested yesterday before your changes and was able to see the captcha with FF (direct way). So I thought it could be an CSS issue..

Offline KahneFan

  • SMF Hero
  • ******
  • Posts: 1,850
  • Gender: Male
    • I Post You Post
Re: No Captcha - Members can't register
« Reply #9 on: December 06, 2008, 02:20:45 AM »
Strange. Glad it works now :D