News:

SMF 2.1.4 has been released! Take it for a spin! Read more.

Main Menu

Audible PM

Started by brianjw, December 05, 2008, 03:41:56 PM

Previous topic - Next topic

brianjw

Here is the new idea:
QuoteFor every time the user logs into the site, the sound ping goes off and it never pings again until their session is reset. Their session is reset if they are inactive for the allotted session-break time or if they logout and log back in.
(courtesy of ccbtimewiz)

Basically if you log out and log back in, it will play the message ONCE or if you navigate away from the page for a period of time (maybe 30 minutes) and come back, then it will play the message.

mrtrc266

Great Mod, but I installed it and it only played the sound 1 time when I first uploaded the index.template. I'm not sure if this has anything to do with it but I'm not sure if I put it in the right place cuz my theme didn't have ...

// If the user is logged in, display stuff like their name, new messages, etc.

So I just added in the proximity of where it is in the default index.template.

I have sent messages back and forth from user to user and it wont play, even after logging out and  clearing cache.

Any ideas?

Here's my template if anyone can help I'd greatly appreciate it. Thanks in advance.


brianjw

Hmmm, you're using 1.5 I am assuming...

Have you cleared absolutely ALL of your cache: cookies, history, temporary internet files

I recommend you download CCleaner which will clear all temporary type files involving your internet. Another plus is it fixes errors in the registry but that has nothing to do with this.

Sabre™

lol
I dont see the problem with the first version.
I consider not reading a persons PM to you as rude, and that one makes sure they do!! lol

When you send someone a PM, would an option to choose which "gotmail.swf" they hear be possible at some stage?

Like if an Admin sends them a PM, it would have the admins "youve got mail" for them.
Or when a mate sends them one, they can choose to either use the Mr T swf, or the Austin Powers one.
Making any sense? lol

Cheers
Do NOT give admin and/or ftp details to just anybody, see if they are trust worthy first!!  Do your homework ;)


brianjw

It does, that sounds about 1000 times more complicated but it might be done some day. I will probably need help coding it though since it's user preference.

Sabre™

Yeah, it isnt a requirement of the mod, as it executes its primary function.
Just a little  *PAZOOW*  to play with, not worth the bother mate.
Looking forward to your next release with the admin options though.

Good Job as always Brian :)
Do NOT give admin and/or ftp details to just anybody, see if they are trust worthy first!!  Do your homework ;)


Rattler

I have installed the mod on 1.1.7 and it works as advertised, like it a lot.

Now, something has come up that makes sense, some of my members read through the forum at work and a sound on receiving PM´s for them is a no-go.

Any chance we could get a version where users are allowed to turn audible PM OFF as an option?

TIA,

Rattler
You can discuss with people, and sometimes it even makes sense to do so. Forget that when confronted with the cruel facts of life... (inspired by SiGnature™).

brianjw

Yep, I am working on that for the next version.

Manu.G

Hi,
I have install the mod in our forum and it works perfect, now I have a question.
We have a lot of languages added to our forum and I want to ask something.
Atm it doesn't matter what language a member is having in use, he/she hears it in
English, is there a way to add other languages to this mod?
For example has a member the German language in use he/she will hear "Sie haben Post"
instead of "You've got mail"?  :)
Version SMF 2.0.8
SimplePortal 2.3.5

brianjw

Manu0372, I could make something up.

But you will have to provide the language sounds for your members. I do not make the sounds. ;)

Manu.G

Quote from: brianjw on January 20, 2009, 03:56:09 PM
Manu0372, I could make something up.

But you will have to provide the language sounds for your members. I do not make the sounds. ;)
I think/hope the sound in different languages won't be that big problem.
It would be great when you can help me with the codes and when you tell me what I have to do. :D
Version SMF 2.0.8
SimplePortal 2.3.5

HR

I prefer the female voice myself.. a bit of edit here and there...

I can explain this as simply as possible.. If I do it & implement I guarantee it.
If I do it and you implement it its a crap shoot.

brianjw

Quote from: HR on January 24, 2009, 03:38:36 PM
I prefer the female voice myself.. a bit of edit here and there...
Not too much editing in the next version though. The next version will have an admin panel with settings where you can set almost all of the options possible without manually modifying the code.

HR

lol my reference was to the alternate file I posted ;)

I can explain this as simply as possible.. If I do it & implement I guarantee it.
If I do it and you implement it its a crap shoot.

[unplugged]

Quote from: HR on January 24, 2009, 03:38:36 PM
I prefer the female voice myself...

That was the only thing that I felt needed to be changed.  :P
« Next Edit: Tomorrow at 08:34:45 PM by SunKing »   <---- « someone stole my sig... :o »



societyofrobots

Hmmm so I can't seem to install it. I don't have problems installing any other mod, just this one.

I get this error:
"Some of the files the package manager needs to modify are not writable. This needs to be changed by logging into FTP and using it to chmod or create the files and folders. Your FTP information may be temporarily cached for proper operation of the package manager."

The majority of my forum is CHMOD 777 already (I verified). This includes the AudiblePm15.zip and both index.template.php in default and modified Theme folders. And all folders are 777.

I then attempted to manually modify my forum with the mod . . . but the sound doesn't play. Where exactly do I upload the unzipped .swf sound file?

brianjw

Ok, I've gotten this before with other mods. It's an easy fix for your entire forum.

1.) In admin, go to the package manager and browse to Options.
    a.) Just for this install select all files are writable (unless you're comfortable doing it for a permanent amount of time)
2.) Go to another page in the package manager and come back to Options. Is it the same options as what you set before? Let me know.

3.) Try installing. If you have problems other than test fails, keep following the numbers.

4.) Create a /temp/ directory in your /Packages/ folder in the SMF root.

5.) Install this mod: http://custom.simplemachines.org/mods/index.php?mod=724
     a.) CHMOD/Set permissions of the /temp/ directory to 777.

6.) Go into options, attempt setting all files writable again.

7.) Try installing the mod again. If you still have issues post up. Although, I'd like to here if it worked as well. ;)

Also, the swf file for the mod should be placed in the root of smf. Which for this site is /community/

societyofrobots

Quote1.) In admin, go to the package manager and browse to Options.
    a.) Just for this install select all files are writable (unless you're comfortable doing it for a permanent amount of time)
Doesn't work. It just gives me this error:
Some of the files the package manager needs to modify are not writable. This needs to be changed by logging into FTP and using it to chmod or create the files and folders. Your FTP information may be temporarily cached for proper operation of the package manager.
550 /vhosts/societyofrobots.com/httpdocs/robotforum: No such file or directory

I tried every permutation of the directory name with no luck.

Quote3.) Try installing. If you have problems other than test fails, keep following the numbers.

4.) Create a /temp/ directory in your /Packages/ folder in the SMF root.

5.) Install this mod: http://custom.simplemachines.org/mods/index.php?mod=724
     a.) CHMOD/Set permissions of the /temp/ directory to 777.
This mod installed fine, no problems at all.

Quote6.) Go into options, attempt setting all files writable again.

7.) Try installing the mod again.
Both of these steps fail, giving that same error as above.

If only SMF was more descriptive than 'Some of the files' . . . :D

brianjw

Lol. Not sure if I can help you there then. This is an SMF issue not a mod issue, so you might just want to post this in the SMF Support category on this site. This issue happens with any mod because it's happened to me.

societyofrobots

Ok I figured it out. The .swf file gets saved in the main directory - the only directory I didn't CHMOD 777 apparently. I'm a moron . . . That will explain why all other mods work, because the others don't use that directory.

And perhaps a bug with the Audible PM . . . it doesn't play a sound when I'm listening to mp3's using WinAmp. The manual install worked, but I never heard anything because of this . . .

Advertisement: