News:

Want to get involved in developing SMF, then why not lend a hand on our github!

Main Menu

SMF 2.0B4 - Database error preventing access to any board or post

Started by kromey, November 17, 2008, 11:17:57 AM

Previous topic - Next topic

kromey

First off, let me apologize if this has been asked and answered already - I tried to search for it but got a "Search daemon cannot be reached" error. I even waited 12 hours and tried again, same result.

I installed SMF 2.0B4 yesterday with PostgreSQL back-end. There were plenty of complications, but searches here yielded results that eventually got me up and running beautifully. At least for an hour.

I created my first two boards, the second being a child of the first and both being in a new category. I posted the first topic into that parent board. Then I moved on to configuring the rest of my board, adding 4 more boards, a new user group, and going through literally every administration screen configuring the entire setup just how I wanted it.

Unfortunately, I now have a database error every time I try to view a board or a post, which seems odd considering that it work fine literally an hour before.

ERROR: function instr(text, "unknown") does not exist
HINT: No function matches the given name and argument types. You may need to add explicit type casts.
File: /var/www/forum/htdocs/Sources/MessageIndex.php
Line: 248


Again, this is on SMF 2.0B4 with PostgreSQL 8.1 back-end and PHP 5.1 running on a CentOS 5 server.

My initial theory after looking at the line in question was that it was related to my user account being in two user groups (both Administrator and the new one I created), but removing myself from the new user group has not changed anything.

Please help! I've used SMF before and love it, and want to use it with PostgreSQL as I have other applications running that use it and do not want to have to manage both a PostgreSQL server and a MySQL server.

Thanks in advance for any help or advice.

IchBin™

IchBin™        TinyPortal

kromey

Thanks for the super-speedy reply! As I'd mentioned in my post, the search was not working for me, otherwise I would have done just that.

Turning off the "Who's viewing" feature indeed works for me! Tonight I'll try the fixes from that post that will allow me to turn it back on - I'm not afraid to hack at PHP code (I'm a PHP developer in my professional life) nor am I afraid to hack at PostgreSQL (I'm a MySQL developer in my professional life, so naturally I use Postgres at home! ;) ).

On a somewhat related note:
Poking at the search box here has revealed my failure at the search: strings containing a close parenthesis ")" return a "Unable to access the search daemon" error. Since I was trying to search for "instr(text, "unknown")", I was unable to find anything. A quick search indicates, however, that this is a feature, not a bug, although I would point out that it would be more useful to frustrated SMF users like myself to be told that certain characters are forbidden in searches.

Advertisement: