Mods reading as installed, but aren't

Started by waterrat, December 21, 2008, 01:40:07 AM

Previous topic - Next topic

waterrat

I encountered the Verification Error problem when installing mods and followed the directions to fix that error. 

I was able to install one mod, then on the next mod installs, I got an error saying my files were not writeable in the th Packages folder.  Again, I found an answer and put a temp folder in Packages with 777 attributes. 

Now, the modes "install" (and they show as installed), but in fact they don't actually make any changes.  I have to go in and do manual changes to get the functionality of the mods.  Any advice.  The problem is not specific to any one mod--all the one's I've tried have the same result.  I'm running 1.1.7.

NHWD


waterrat

Quote from: Tyrsson on December 21, 2008, 04:00:09 AM
Maybe this will help.

Session verification failed

Followed that fix, as I said, but then the "Packages folder not writable" error arose and I did the fix on that too.  Mods show as installed, but have no effect.

I am using the default theme.

Tyrsson

Make sure all these files have the correct permission set.

The following files should be CHMOD'ed to 777*:

    * attachments
    * avatars
    * Packages
    * Packages/installed.list
    * Smileys
    * Themes
    * Themes/default/languages/Install.english.php
    * agreement.txt
    * Settings.php
    * Settings_bak.php
    * install.php
PM at your own risk, some I answer, if they are interesting, some I ignore.

waterrat

Quote from: Tyrsson on December 21, 2008, 12:11:28 PM
Make sure all these files have the correct permission set.

The following files should be CHMOD'ed to 777*:

    * attachments
    * avatars
    * Packages
    * Packages/installed.list
    * Smileys
    * Themes
    * Themes/default/languages/Install.english.php
    * agreement.txt
    * Settings.php
    * Settings_bak.php
    * install.php

I don't seem to have an install.php file in the home directory.  Is it elsewhere?  I have a install_1-1.sql file.

All the other files had the correct settings.

waterrat

I think I deleted the install.php to improve security.  I'll upload and retry.

Tyrsson

No do not upload the install.php


Just make sure the files and folders that are there now has the right permissions.
PM at your own risk, some I answer, if they are interesting, some I ignore.

waterrat

All files/folders have the right permissions, but the problem is the same.

greyknight17

Create a folder called temp in your Packages directory and CHMOD it to 777. Then try installing the mod again.

Tyrsson

Knight I think they have done that already....

I am kinda at a loss??
PM at your own risk, some I answer, if they are interesting, some I ignore.

waterrat

Quote from: Tyrsson on December 21, 2008, 05:23:40 PM
Knight I think they have done that already....

I am kinda at a loss??

Yes, as I said at the beginning, the temp folder I created has 777 attributes.  When I install a mod, it tells me the mod installs fine and it shows as installed, but no change actually occurs.  It's as if the mod is writing to the temp file just fine, but then not writing to the files it is supposed to modify.  This happens with any mod I install.  I'll keep working on it.  Thanks for the help.

Bulakbol

Check the permission of your template files and source files. CHMOD them to 777.
Please do not PM me for support · My Mods and Theme · SMF Coding Guidelines · Modifications Approval Guidelines

waterrat

Quote from: Bulakbol on December 21, 2008, 09:00:54 PM
Check the permission of your template files and source files. CHMOD them to 777.

I think I've said this before--all files are set to 777.  Every one of them.

Tyrsson

Contact your host and ask if they have changed anything in the configuration... Its worth a shot.
PM at your own risk, some I answer, if they are interesting, some I ignore.

gtowntalk

waterrat! I feel your pain. You have explained yourself perfectly. I too must manually add the temp folder to the Package folder and manually give it 777 and then and only then will the mod install. BUT! Like waterrat it says it is install but it is not true. As a matter of fact it does nothing.

Please, we need a Server expert or coder to help us. I don't mean to speak for waterrat but i think that we have tried all the fixes such as trying to install the "mod" to make the temp dir and make it 777 and reset 777 all over the place but this is something in our server configurations, PHP.INI or sessions. I have checked all of my settings against the required settings and all apprear to be correct.

We need high level help.....thank everyone for your attention and hey, I've gotten great help here in the past and i am a great support of smf. Love it and don't want to use the others...just need to get past this. You guys are why free is better! :)
Thanks, gt


Relyana

#15
I had the exact same problem yesterday .. "Change all file permissions throughout the forum" didn't work out at all, the mod I was trying to install was listed as installed but none of the edits were actually done.
In my case the fix_ownership.php file helped a lot in fixing the problem. I can now install mods without that temp folder. After fixing that issue 2 older mods were still half way installed and I couldn't uninstall them using the package manager. I finished their installation manually and I'm aware of the fact that one day I will have to uninstall them the same way ... I'll be wiser that day anyway.  :P

Are you sure that you have the right path for the Packages folder ? Mine had an extra "/" added.

gtowntalk

Hey, thanks for the tip. Where exactly did you find the extra "/"?

Relyana

#17
Quote from: gtowntalk on December 26, 2008, 09:26:10 PM
Hey, thanks for the tip. Where exactly did you find the extra "/"?

The ftp path in package manager must be your forum's path, the one you can also see in the FTP client (/public_html/yourforum or /public_html without a trailing slash). You might have httpdocs instead of public_html or something else (dunno)

I found public_html/ instead of public_html for the Local path to SMF and I had to fix the database related table in order to be able to install mods again (things must've gone wrong when I moved my forum from the subdomain to the domain root)

Sarge's post might help you fix the issues you're having with the package manager
Having problems with the package manager?

aw22sr

when i  run the fix_ownership.php ask me fron the same information

FTP Server:     
Port:
Username:    
Password:    
Local path to SMF:

put the information and again and again and again

greyknight17

Is this issue resolved now?

When you run fix_ownership.php it will ask you for the FTP details again, but I think it lists the FTP Path there for you. Confirm that it's the same path you are using in the package manager when it prompts you to enter your FTP details.

If none of those still work, give the following a try:

Go to Admin->Packages->Options and uncheck Create Backup versions of replaced files with a tilde (~) on the end of their names. Try installing a mod now.

xtremecruiser

#20
Since I updated to 1.8 I get the
"Session verification failed. Please try logging out and back in again, and then try again."
error
This thread has been no help
http://www.simplemachines.org/community/index.php?topic=278824.0

On a side note, packages install fine on a fresh install of smf 1.1.8

And if I use the 1.1.6 packages.php I can get mods to install but some work and others dont dude to it saying the db is Software Version:           SMF 1.1.2


xtremecruiser

How about a update with this error that many have

Bulakbol

@xtremecruiser

Try deleting your cookie.
Please do not PM me for support · My Mods and Theme · SMF Coding Guidelines · Modifications Approval Guidelines

tatoon

I have a similar problem to what was described before.

I install mods and in the package section they all look successful, the green dot is next to the mod name (I guess it means it's running).

But when I go back to post a new topic (these mods im trying modify the behavior of adding attachments when posting), everything looks the same. But in the screenshots of the mod I see there should be a few more options.
So basically, the mod is not working.
I tried to stop/start apache, delete all my cache, cookies, etc. Try different browser and different computer.
So it's something to do with my installation of smf.

Any idea?

Tyrsson

@tatoon

Smf version?

Theme you are using?

MOd you are trying to install?

Any other info that would help to point us in the right direction.
PM at your own risk, some I answer, if they are interesting, some I ignore.

JBlaze

Quote from: tatoon on April 24, 2009, 05:28:31 AM
I have a similar problem to what was described before.

I install mods and in the package section they all look successful, the green dot is next to the mod name (I guess it means it's running).

But when I go back to post a new topic (these mods im trying modify the behavior of adding attachments when posting), everything looks the same. But in the screenshots of the mod I see there should be a few more options.
So basically, the mod is not working.
I tried to stop/start apache, delete all my cache, cookies, etc. Try different browser and different computer.
So it's something to do with my installation of smf.

Any idea?

The green dot next to a mod means that you are currently using the most recent version of that mod.

As for your mods not working, are you using a custom theme? When you install a mod, it only installs on the default theme. You must then manually edit the custom theme's template files for the mod to work on a custom theme.

To find the manual install instructions, go to the mods page and parse the instructions for your forum version.
Jason Clemons
Former Team Member 2009 - 2012

tatoon

I havent installed any additional theme.
Im using the default one from smf.

I'll check those parse entries you mentioned.

Dragooon

Is mod_security or php safe_mode enabled? Are you sure the permissions for files are correct?

tatoon

Perfect!

It was the mod_security.
Never heard about that before. But I disabled it and the mods are now running as they should.

Thanks a lot!!!

Dragooon


Advertisement: