• Welcome to Simple Machines Community Forum. Please login or sign up.
January 26, 2022, 11:44:09 AM

News:

SMF 2.0.19 has been released! Please update. Read more.


Stop Spammer

Started by M-DVD, December 31, 2008, 07:31:43 AM

Previous topic - Next topic

snoopy_virtual

I have seen this question somewhere else:

Quote from: dubob4432 on January 28, 2011, 06:52:04 PM
been using 1.1.12 and stop spammer 2.3.7 for quit some time and all has been working well.  the last couple days, there is no longer a 'check this user' option when you click on a user when in the admin area, there is no text next to the magnifying glass next to the blue, yellow and red icons.

i see there is a 2.3.9 available, does this fix this and do i need to uninstall 2.3.7 before 2.3.9 and also will the info be transferred from 2.3.7 to 2.3.9 for those that have been found on our forum to be spammer?  would like to keep the data and not have to go through the members again as there are nearly 5000...

thanks in advance,
bob

Yes, you need to uninstall 2.3.7 and install the new version 2.3.9 as soon as possible.

That will sort all your problems.

And don't worry about all the old data, as all will be still there. Uninstalling a version and installing a new one doesn't erase any data at all if you use the automatic system with the "Packages Manager".

The only thing you need to check after doing it, is the folder of the Theme you are using (if you are not using the default one).

Let's suppose you are using a Them called yourtheme.

Go to the folder /Themes/yourtheme/

Check if inside it you have any of those files:


  • Register.template.php
  • ManageMembers.template.php

If you have any of them there, you will need to edit them to do the required changes manually.

If you don't know how to do that let me know.

=============================

I have answered it here because it's better to leave everything concerning this mod in just one topic.

This way, if anybody else has the same problem and comes here searching this topic they will see it has already been answered.

El verdadero sabio es aquel que lo ve todo, lo estudia todo, lo analiza todo y molesta poco.
A true wise man is he who sees everything, studies everything, analyses everything and hardly ever annoys.

WasdMan

Enclose a translation of the Hungarian language version 2.3.9.

snoopy_virtual

Thanks WasdMan

I will add it to the languages package when I have some time.

El verdadero sabio es aquel que lo ve todo, lo estudia todo, lo analiza todo y molesta poco.
A true wise man is he who sees everything, studies everything, analyses everything and hardly ever annoys.

dubob4432

snoopy,

it has happend again after the 2.3.9 install.  it worked ok for a few hours, but now back to the same situation.  is there anything on my end that could be causing this?

i uninstalled the 2.3.9, deleted it and then re-installed it from the zip and back to where i was with the 2.3.7 of things not showing up correctly....

please advise,

thanks in advance,
bob

snoopy_virtual

@dubob4432

Go to the mod settings page (Admin=>Members=>Registration=>Settings) and check what it says underneath "MOD Stop Spammer settings".

Can you see a green sign saying "Mod Stop Spammer is ON, it is up-to-date and the connection with Stop Forum Spam is perfect."?

If not, What colour is it and what it says?

El verdadero sabio es aquel que lo ve todo, lo estudia todo, lo analiza todo y molesta poco.
A true wise man is he who sees everything, studies everything, analyses everything and hardly ever annoys.

dubob4432

it did originally when i first changed it - green connection, all text present, but now when i look at it, there is no text and the 1st, 3rd & 4th checkboxes are checked and the api code is there, but no text in the dropdown where it is suppose to ask what to do if the server can't connect to the db.

dubob4432

what is interesting is on my home test server, it is working fine - all text is present, just the main commercial server is having the issue.  i believe the main commercial server is hosted by godaddy if that matters.

snoopy_virtual

It looks like a language problem.

What languages have you installed in your forum?

Which one are you using?

El verdadero sabio es aquel que lo ve todo, lo estudia todo, lo analiza todo y molesta poco.
A true wise man is he who sees everything, studies everything, analyses everything and hardly ever annoys.

dubob4432

January 31, 2011, 06:29:20 AM #1128 Last Edit: January 31, 2011, 06:32:22 AM by dubob4432
they are both english forums, could it be the db encoding like utf-8?  the commercial server use to be on a win machine, but now i see it is running apache, not sure when that changed happend but i will see if i can get the owner to get me permission to talk to godaddy and see if it was in the last few days to week and see if that had something to do w/ it.

also, it only installed the english file and skipped the others.  i will upate the home test server and see if the process is the same....

dubob4432

there was a difference - on the commercial server i got an error when uninstalling both 2.3.7 and 2.3.9, and it was to this file - Themes/default/languages/Modifications.english.php
not so on the home test server.  i will see what the commercial server db is encoded is hopefully tomorrow.

thanks for all the help and hope this makes sense.

snoopy_virtual

If you are using only the "english" package the only language file modified by this mod is Modifications.english.php

Check inside your /Themes/default/languages/ folder, look for that file and check if you have the language strings for this mod.

You need to have all these lines:


// MOD Stop Spammer - START
$txt['stopspammer_error'] = 'Error with Anti SPAM DB. Connection Failed.<br />
Please try again later, or Contact with the WebMaster';
$txt['stopspammer_count'] = 'Spammers blocked up until today';
$txt['stopspammer_title'] = 'Search more info in `Stop Forum Spam`';

$txt['stopspammer_enable'] = 'Enable/Disable MOD Stop Spammer';
$txt['stopspammer_show01'] = 'Show Link "More Info" for All Members';
$txt['stopspammer_show01_sub'] = 'You can check any member at any time with one simple click';

$txt['stopspammer_faildb'] = 'If the Connection Fail with Anti SPAM DB...';
$txt['stopspammer_fail01'] = 'Show Error and Stop Registration';
$txt['stopspammer_fail02'] = 'Allow Immediate Registration';
$txt['stopspammer_fail03'] = 'Member Approval and show yellow icon to check later';
$txt['stopspammer_faildb1_sub'] = 'Your host can make remote connection with the DB';
$txt['stopspammer_faildb2_sub'] = 'Your host couldn\'t make connection with the DB. Try again later.<br />
If this error continues see Support Topic and search ';
$txt['stopspammer_not_translate'] = '<a href="http://www.simplemachines.org/community/index.php?topic=283309.msg1920848#post_issues"><span class="error"><b>Known Issues</b></span></a>';

$txt['stopspammer_leyd01'] = 'Not Spammer: This data wasn\'t in a DB. But you can check';
$txt['stopspammer_leyd02'] = 'Suspect: This member couldn\'t be checked. Check now';
$txt['stopspammer_leyd03'] = 'Spammer: See more info of activity of this spammer';

$txt['stopspammer_profilecheck'] = 'Check this member';
$txt['stopspammer_limitexceded'] = 'You have exceded the check limit (5000 API queries per day).<br />You should wait until tomorrow to check again.';

$txt['in_stop_forum_spam'] = 'In Stop Forum Spam Web:';
$txt['spammers_checks'] = 'Check these Members';
$txt['spammers_report'] = 'Report these Members';
$txt['confirm_spammers_checks'] = 'Are you sure you want to check the selected members?';
$txt['confirm_spammers_report'] = 'Are you sure you want to report the selected members?\n\nThink that when you report a member to SFS they are marked as spammer all over the world\nand they won\\\'t be able to use any of the forums connected to SFS around the world.\n\nDo it only if you are completely sure they are spammers and if by any chance you make a mistake\ntell as soon as possible the mod\\\'s creator to correct the mistake inside the SFS database.';

$txt['stopspammer_api_key'] = 'Your API key';

$txt['stopspammer_check_name'] = 'Check their username';
$txt['stopspammer_check_mail'] = 'Check their email';
$txt['stopspammer_check_ip'] = 'Check their IP';
$txt['stopspammer_check_sub2'] = 'By default, every time you check a member with MOD Stop Spammer it will check their username, email and IP. If you are getting too many false positives because of their usernames you can turn that option off. We wouldn\'t recomend you to turn off the another 2 options (to check their email and IP) unless you know what you are doing.';

// Changed from 2.3.8 to 2.3.9
$txt['stopspammer_check_sub1'] = 'If MOD Stop Spammer is enabled, every time we check a member:';
$txt['stopspammer_api_key_sub'] = 'If you want to use your own API key you must go first to <a href="http://www.stopforumspam.com/signup" target="_blank">www.stopforumspam.com</a> to sign up for one and write it here. If you haven\'t got one you cannot report spammers with this mod.<br /><br />If you need help with this configuration or with anything else about Mod Stop Spammer, apart from the support forums, you can also ask for online help. If you have already installed Mod httpBL you can see how to ask for online help going to Admin => MOD httpBL => Help. If you haven\'t got it you can <a href="http://www.snoopyvirtualstudio.com/contact.php?language=english" target="_blank">see more info here</a>.';

// New in version 2.3.9
$txt['stopspammer_settings'] = 'MOD Stop Spammer settings';
$txt['stopspammer_enable_sub'] = 'With this check-box checked the mod is ON. With the check-box unchecked the mod is OFF.';
$txt['stopspammer_error_no_api_key'] = 'You cannot report a spammer without an API key from www.stopforumspam.com<br /><br />You need to register on their site first, ask them for an API key and then navigate inside your forum to:<br />Admin => Members => Registration => Settings<br />Scroll down to Stop Spammer settings, write your API key there and save your settings.';
$txt['stopspammer_no_connect_1'] = 'Mod Stop Spammer is ON but there is no connection just now with Stop Forum Spam. Please try later.';
$txt['stopspammer_no_connect_2'] = 'If the problem persists ask for help in the <a href="http://www.snoopyvirtualstudio.com/foro/index.php?board=31.0" target="_blank">official support forum</a>.';
$txt['stopspammer_new_version_1'] = 'Mod Stop Spammer is ON but it is not up-to-date.';
$txt['stopspammer_new_version_2'] = 'There is a new version of this mod. The version you have is: ';
$txt['stopspammer_new_version_3'] = '<a href="http://www.snoopyvirtualstudio.com/foro/index.php?board=31.0" target="_blank">Please update it here whenever you can</a> to the new version: ';
$txt['stopspammer_all_ok'] = 'Mod Stop Spammer is ON, it is up-to-date and the connection with Stop Forum Spam is perfect.';
$txt['stopspammer_is_off'] = 'Mod Stop Spammer is OFF.';
// MOD Stop Spammer - END

El verdadero sabio es aquel que lo ve todo, lo estudia todo, lo analiza todo y molesta poco.
A true wise man is he who sees everything, studies everything, analyses everything and hardly ever annoys.

GJSchaller

Howdy!

First all, thank you SO much for all of the effort you've put into this - between this mod, and httpBL, my forums are a lot safer than they used to be...

With the install of 2.3.9, I've noticed that when I report an account as a Spammer, it no longer automatically flags that account after reporting it - I need to go back and re-check it, at which point it will flag it.  This was not the case in 2.3.8 or earlier - when I reported someone, it would automatically mark the account as a spammer.

I looked in the list of posts since 2.3.9 came out, but didn't see this reported - sorry if I missed this somewhere.
Geoffrey J. Schaller
Knight Realms - Technical Officer
http://www.knightrealms.com/

snoopy_virtual

February 02, 2011, 09:54:27 AM #1132 Last Edit: February 02, 2011, 10:47:13 AM by snoopy_virtual
Hi Geoffrey

Yes, I have noticed that mistake. I will sort it in the next update.

El verdadero sabio es aquel que lo ve todo, lo estudia todo, lo analiza todo y molesta poco.
A true wise man is he who sees everything, studies everything, analyses everything and hardly ever annoys.

SulevFan

Hi, I have a few questions on whether I'm fully understanding how this mod works and how I should be using it.

When I first installed it, I had to run every page of mmy memberlist with a "Check this Member" to get suspect memebers highlighted. It also highlighted a knows nad respected member's IP address. :(

Now that I have the mod in place a few days, I have seen a few spammers register (they have links in their signatures) that are not highlighted and are not in the DB.  I then click on "Report this user." In my member list, nothing happens. I have to "Check this Member" again to get it flagged and moved to the Pending registration queue.  Am I missing something here?

Also, I assume this mod will not prevent deleted userids from attempting to register again in the future, so should I still keep ban lists in place and add the spammers to ban lists?

Thank you.

fr3aker

read two posts above yours, there the bug was reported ;)

when submitting the spambots to stopforumspam through this mod (or manually if you like too :D ), the IPs, usernames and email-addresses will get blacklisted and prevent future registrations of these bots. so you get them permanently blocked.
If you always do a "Report this user", they will be banned permanently.


greez fr3aker

SulevFan

Quote from: fr3aker on February 03, 2011, 03:46:16 PM
read two posts above yours, there the bug was reported ;)

when submitting the spambots to stopforumspam through this mod (or manually if you like too :D ), the IPs, usernames and email-addresses will get blacklisted and prevent future registrations of these bots. so you get them permanently blocked.
If you always do a "Report this user", they will be banned permanently.


greez fr3aker

OK, so I missed the bug report, thanks!  :)

Is there an "automatic" as well as manual method to submit reports?

snoopy_virtual

@SulevFan

I would only add one more thing to what fr3aker have already answered:

Reporting spammers with this mod is a lot better than banning them in your forum, because when you report them you are adding their IP, username and email address to the "database of known spammers", so they are banned not only from your forum, but also from all the forums using this mod, so we all benefit from that.

I am sorry about that bug you (and GJSchaller before you) reported. I know it's a nuisance having to click on them twice (one to report them and another one to check them again), but if you want to have it easier, I will recommend you to install as well mod httpBL.

With that mod the spammers report themselves (as you can see in this tutorial).  ;)

Anyway, as I already told GJSchaller, that bug will be sorted in the next version of this mod.

El verdadero sabio es aquel que lo ve todo, lo estudia todo, lo analiza todo y molesta poco.
A true wise man is he who sees everything, studies everything, analyses everything and hardly ever annoys.

snoopy_virtual

Quote from: SulevFan on February 03, 2011, 04:52:09 PM
Is there an "automatic" as well as manual method to submit reports?

As you can see if you search this topic, we have talked a few times about what we call "false positives". People flagged as spammers but when you study them more carefully you find out they are honest people.

If one day we don't get any false positives at all we will implement some kind of automatic method to submit reports, but in the mean time every admin should check all the spammers caught by the mod to see if they are really spammers or not.

El verdadero sabio es aquel que lo ve todo, lo estudia todo, lo analiza todo y molesta poco.
A true wise man is he who sees everything, studies everything, analyses everything and hardly ever annoys.

Angie on Dialysis

Quote from: snoopy_virtual on February 03, 2011, 04:58:09 PM
Quote from: SulevFan on February 03, 2011, 04:52:09 PM
Is there an "automatic" as well as manual method to submit reports?

As you can see if you search this topic, we have talked a few times about what we call "false positives". People flagged as spammers but when you study them more carefully you find out they are honest people.

If one day we don't get any false positives at all we will implement some kind of automatic method to submit reports, but in the mean time every admin should check all the spammers caught by the mod to see if they are really spammers or not.

I agree. I have gotten a guy to start using Stop Spammer on his forums and when he screwed up something in the implementation on his forum it was not showing up and couldn't see who was being flagged. I explained to him that sometimes people can be flagged but are innocent. After he fixed it he had a real member register that I investigated and it was a real person who needed the support and help his forum offers.

Some people just don't want to take the time to fight spammers but it is the responsibility of any forum owner to do so. As it is I use both httpBL and Stop Spammer and I get so few problems it is a breeze in the park. I am thankful to these Mods as I have seen them work well for the last year I have used them.  (And medical forums are a HUGE target for spam if you don't know - Not you Snoopy .. I know you know. I mean everyone who reads this. I only quoted you because I agree 100% and felt I wanted to add to it)

LeYoyo

Hi all,

I have a problem with this mod.

If a "detected" spammer try to register, I have to approve it. That's fine.
When I log-in, I got the information that a user is waiting approval.
I go to the admin section, reject the user and it's OK. It works (in this case) and the user is not registered.


But... if, the "spammer" validates the email confirmation he received by registering before I reject his registration, then:
1. The rejected user still appears in the user list (probably because he confirmes the email)
2. The alert that a user is waiting approval is still there
3. When I delete the user, I still get the information that a user is waiting approval. But in reallity there is none, because he was rejected and deleted.

It looks like if when the user confirm his email before he's rejected by admins, then the information 'user is waiting for approval" will not disapear :/

Any help is welcome.

I'm on SMF 1.1.12
Sous SMF 2.0.8

Advertisement: