• Welcome to Simple Machines Community Forum. Please login or sign up.
November 27, 2021, 10:27:27 PM

News:

Join the Facebook Fan Page.


Stop Spammer

Started by M-DVD, December 31, 2008, 07:31:43 AM

Previous topic - Next topic

Leemy

My install on 2.0 RC2 failed on the ManageMembers.php entry. Couldnt find the text. I have a pretty standard 2.0, it doesnt say floatclass it says floatstyle... what should i do?

snoopy_virtual

Are you sure you are installing the latest 2.3.7 version of the mod ?

That was one of the things I changed when SMF went from RC1.2 to RC2 and that's also why the mod is not compatible any more with RC1.2

El verdadero sabio es aquel que lo ve todo, lo estudia todo, lo analiza todo y molesta poco.
A true wise man is he who sees everything, studies everything, analyses everything and hardly ever annoys.

snoopy_virtual

I have just checked the original files from SMF of their version 2.0 RC2 and inside the ManageMembers.php on line number 1040 it says:


<div class="floatleft">


Check if you file ManageMembers.php have this at the top:


/**********************************************************************************
* ManageMembers.php                                                               *
***********************************************************************************
* SMF: Simple Machines Forum                                                      *
* Open-Source Project Inspired by Zef Hemel (zef@zefhemel.com)                    *
* =============================================================================== *
* Software Version:           SMF 2.0 RC2                                         *


If it is not the original file from version SMF 2.0 RC2 you did something wrong when installing SMF or updating it to this version.

El verdadero sabio es aquel que lo ve todo, lo estudia todo, lo analiza todo y molesta poco.
A true wise man is he who sees everything, studies everything, analyses everything and hardly ever annoys.

giveaway365.com

Sir,
This error come often in my error log.
8: Undefined index: types
File: /home/content/g/i/v/giveaway365/html/Sources/ManageMembers.php
Line: 381
Line 381 = if (empty($range_trans[$_POST['types'][$param_name]]))

Also I have lots of spammers ... like 33 error pages filled with this error every day:
Your account is still awaiting admin approval.


kizer

I'm by no means saying this mod did it, but I seem to be having a problem with Subscriptions. I know subscriptions worked before I installed a few mods so I'm trying to eliminate mods that might of caused it. When I get a Subscription it now just gets stuck on Sending Payment.

Is anybody else having that issue with this Mod? If nobody is then I'll have to keep working my list. ;)
Own a Jeep? Links4Jeeps.com

kizer

My problem what ever is wasn't this. I basically loaded up a fresh install and this is not breaking my subscriptions.
Own a Jeep? Links4Jeeps.com

MultiformeIngegno

Has someone tested this with RC3..?
Thanks! ;)
RockCiclopedia (wiki - forum), Tutta la storia del rock, scritta da voi ...
Rimanere aggiornati sul mondo della musica grazie al nuovo feed "RockCiclopedia Music News"!

snoopy_virtual

Quote from: giveaway365.com on March 05, 2010, 10:52:56 PM
Sir,
This error come often in my error log.
8: Undefined index: types
File: /home/content/g/i/v/giveaway365/html/Sources/ManageMembers.php
Line: 381
Line 381 = if (empty($range_trans[$_POST['types'][$param_name]]))

You have already reported that error many times and it's already in the cue to be sorted as soon as I have time (check the road map) but is not an important one, you can ignore it.

Quote from: giveaway365.com on March 05, 2010, 10:52:56 PM
Also I have lots of spammers ... like 33 error pages filled with this error every day:
Your account is still awaiting admin approval.

I also get a lot of spammers on my sites. That's why I started working with M-DVD almost 2 years ago in this mod and last August did as well mod httpBL.

At least now I see them but they cannot do any harm.

Anyway mod httpBL always catch them before mod Stop Spammer because it works as a first filter, so if you are getting too many with mod Stop Spammer maybe you have not configured properly mod httpBL.

Check the diagram Wizzle did yesterday about how both mods work together and you would understand what I mean.

El verdadero sabio es aquel que lo ve todo, lo estudia todo, lo analiza todo y molesta poco.
A true wise man is he who sees everything, studies everything, analyses everything and hardly ever annoys.

snoopy_virtual

Quote from: kizer on March 06, 2010, 11:02:44 PM
I'm by no means saying this mod did it, but I seem to be having a problem with Subscriptions. I know subscriptions worked before I installed a few mods so I'm trying to eliminate mods that might of caused it. When I get a Subscription it now just gets stuck on Sending Payment.

Is anybody else having that issue with this Mod? If nobody is then I'll have to keep working my list. ;)

You are talking about the new Subscription system in SMF 2.0?

As all my forums are 1.1.11 and only have a SMF 2 RC2 for testing purposes I haven't use that option yet.

I will write on the road map that I need to check that, to be sure this mod is not interfering with Subscriptions, as I forgot to check it.

Anyway if you find out this mod is the one doing it before I have time to check it tell me and I will sort it ASAP.

El verdadero sabio es aquel que lo ve todo, lo estudia todo, lo analiza todo y molesta poco.
A true wise man is he who sees everything, studies everything, analyses everything and hardly ever annoys.

snoopy_virtual

Quote from: MultiformeIngegno on March 09, 2010, 08:52:32 AM
Has someone tested this with RC3..?
Thanks! ;)

That's another thing I need to check.

If anyone do it before I have time to do it myself, please tell me to save me some time.

Thanks.

El verdadero sabio es aquel que lo ve todo, lo estudia todo, lo analiza todo y molesta poco.
A true wise man is he who sees everything, studies everything, analyses everything and hardly ever annoys.

MultiformeIngegno

Quote from: snoopy_virtual on March 09, 2010, 09:16:24 AM
If anyone do it before I have time to do it myself, please tell me to save me some time.
Tested on RC3, all seems to work properly (no errors during installation)! ;)
RockCiclopedia (wiki - forum), Tutta la storia del rock, scritta da voi ...
Rimanere aggiornati sul mondo della musica grazie al nuovo feed "RockCiclopedia Music News"!

snoopy_virtual

Quote from: MultiformeIngegno on March 09, 2010, 11:13:07 AM
Quote from: snoopy_virtual on March 09, 2010, 09:16:24 AM
If anyone do it before I have time to do it myself, please tell me to save me some time.
Tested on RC3, all seems to work properly (no errors during installation)! ;)

That's great. It means I don't need to do a new version again.  ;D

When SMF went from RC1.2 to RC2 the changes were so much that I needed to make it compatible with one or the other. Impossible to make a version compatible with both.

El verdadero sabio es aquel que lo ve todo, lo estudia todo, lo analiza todo y molesta poco.
A true wise man is he who sees everything, studies everything, analyses everything and hardly ever annoys.

smartdeviceresource

Quote from: MultiformeIngegno on March 09, 2010, 11:13:07 AM
Quote from: snoopy_virtual on March 09, 2010, 09:16:24 AM
If anyone do it before I have time to do it myself, please tell me to save me some time.
Tested on RC3, all seems to work properly (no errors during installation)! ;)
Thank you for testing this :) WOO HOO RC3 I'm coming :)
after some thought, i've learned to be humble and leave the answering to the experts, until i too am an expert.  sorry to anyone who I've confused, with my answers

kizer

Quote from: snoopy_virtual on March 09, 2010, 09:14:34 AM
Quote from: kizer on March 06, 2010, 11:02:44 PM
I'm by no means saying this mod did it, but I seem to be having a problem with Subscriptions. I know subscriptions worked before I installed a few mods so I'm trying to eliminate mods that might of caused it. When I get a Subscription it now just gets stuck on Sending Payment.

Is anybody else having that issue with this Mod? If nobody is then I'll have to keep working my list. ;)

You are talking about the new Subscription system in SMF 2.0?

As all my forums are 1.1.11 and only have a SMF 2 RC2 for testing purposes I haven't use that option yet.

I will write on the road map that I need to check that, to be sure this mod is not interfering with Subscriptions, as I forgot to check it.

Anyway if you find out this mod is the one doing it before I have time to check it tell me and I will sort it ASAP.

Please do not spend anytime on looking into Subscription in 2.0. I apparently had something wrong on my end. ;)
Own a Jeep? Links4Jeeps.com

adamluz

I'm trying to install this mod and my package manager keeps asking me to download index.php everytime I click apply mod. This is the only mod that is doing it. All others install fine. I'm on SMF 1.1.11

Any ideas whats going on?
Screen Cap:

giveaway365.com

i m also on 1.1.11 and not faced any such problem....

snoopy_virtual

Quote from: adamluz on March 10, 2010, 09:25:33 PM
I'm trying to install this mod and my package manager keeps asking me to download index.php everytime I click apply mod. This is the only mod that is doing it. All others install fine. I'm on SMF 1.1.11

Any ideas whats going on?

I get sometimes this problem too, but not only when trying to install a new mod, but also sometimes when trying to open any PHP page. Doesn't matter if that page belongs to a forum or not.

I have discovered this always happens to me when the server is very busy. Apparently, if there are too many people at the same time using the server resources, it make a mistake and tries to open the file index.php instead of executing it.

So what I do, when this happens inside a page it's not mine, is to wait a few minutes and try again.

If it's in one of my pages, I go to my cPanel and check the server load. If it's too high, I wait until it cools down a bit and try again.

Please remember most of the mods you can find in SMF are just "cosmetic" ones, just changing one or 2 small things in your forum so you can see a new small ornament somewhere, but this one is actually a full anti-spammers program, with a lot of modifications in your forum files.

So to be able to install this mod you are going to need a lot of your server resources while installing it.

Maybe a solution will be to check at what time your site is not busy at all so you can be sure you are on your own on the server, or to leave your server in "Maintenance Mode" while installing or something like it.

Try any of them and tell me if it's any use.

El verdadero sabio es aquel que lo ve todo, lo estudia todo, lo analiza todo y molesta poco.
A true wise man is he who sees everything, studies everything, analyses everything and hardly ever annoys.

andyholt

I'm having problems since a failed install of Stopspammer. When trying to access the members list I get the following error

Call to undefined function: sprintfspamer() in /home/learning/public_html/geoforum/Sources/Load.php(1733) : eval()'d code on line 54 

I've tried re-running the upgrade package as I'm on version 1.1.11 replacing all of the files in sources including load.php but I still have the problem. Can you offer any advice to help me get my frrum back?

Any advice would be greatly appreciated.

snoopy_virtual

Quote from: andyholt on March 11, 2010, 11:01:32 AM
I'm having problems since a failed install of Stopspammer. When trying to access the members list I get the following error

Call to undefined function: sprintfspamer() in /home/learning/public_html/geoforum/Sources/Load.php(1733) : eval()'d code on line 54 

I've tried re-running the upgrade package as I'm on version 1.1.11 replacing all of the files in sources including load.php but I still have the problem. Can you offer any advice to help me get my frrum back?

Any advice would be greatly appreciated.

The function sprintfspamer() is not called from the file /Sources/Load.php but from the file:

Themes/default/ManageMembers.template.php

Get that file from the original SMF 1.1.11 package and overwrite the one you have.




Anyway, if you tried to install this mod and you had an error you should have asked here.

Everytime somebody tell me what error they have trying to install it I always tell them what to do to be able to install it properly.

El verdadero sabio es aquel que lo ve todo, lo estudia todo, lo analiza todo y molesta poco.
A true wise man is he who sees everything, studies everything, analyses everything and hardly ever annoys.

andyholt

Thanks snoopy - that's sorted the problem out.

Advertisement: