Advertisement:

Author Topic: Turned on Maintenance Mode now can not turn it off.. PLease help  (Read 7327 times)

Offline Prowler9

  • Semi-Newbie
  • *
  • Posts: 35
I turned on Maintenance Mode on my site tonight to make a few changes.  Now I can't even get to the login page to get back in to turn it off. 

My settings.php says this
Code: [Select]
$maintenance = 1;
When I change it to
Code: [Select]
$maintenance = 0;
I get this

Connection Problems

Sorry, SMF was unable to connect to the database. This may be caused by the server being busy. Please try again later.

Any help on getting my site working again would be great... Thanks for your time.

Offline Prowler9

  • Semi-Newbie
  • *
  • Posts: 35
Re: Turned on Maintenance Mode now can not turn it off.. PLease help
« Reply #1 on: January 03, 2009, 01:16:35 AM »
FYI I have this bridged with coppermine

Offline Joey Smith™

  • SMF Friend
  • SMF Hero
  • *
  • Posts: 6,356
  • Gender: Male
Re: Turned on Maintenance Mode now can not turn it off.. PLease help
« Reply #2 on: January 03, 2009, 01:28:27 AM »
This must be set to zero as far as I know... Sometimes you will get that message one minute and when you reload the page it will load. I would try to set it to zero and give it some time to see if its the server.

Also if you are admin then you should still be able to login with the value set to 1.

P.S. make sure you uploaded the file into the correct directory.

Offline Prowler9

  • Semi-Newbie
  • *
  • Posts: 35
Re: Turned on Maintenance Mode now can not turn it off.. PLease help
« Reply #3 on: January 03, 2009, 01:31:08 AM »
Alright I will set it to 0 for a few..

I am admin and have done it in the past but just goes to a text page saying my reason for maintenance..

Will let ya know if that worked.

Offline Prowler9

  • Semi-Newbie
  • *
  • Posts: 35
Re: Turned on Maintenance Mode now can not turn it off.. PLease help
« Reply #4 on: January 03, 2009, 01:39:19 AM »
Ok still no dice. 

www.grandwoodsrc.com/forum/  get this error

Connection Problems
Sorry, SMF was unable to connect to the database. This may be caused by the server being busy. Please try again later.

www.grandwoodsrc.com/gallery/ gets this error

Coppermine critical error:
Unable to connect to UDB database !

MySQL said:

Offline Prowler9

  • Semi-Newbie
  • *
  • Posts: 35
Re: Turned on Maintenance Mode now can not turn it off.. PLease help
« Reply #5 on: January 03, 2009, 01:45:48 AM »
Alright Unbridged coppermine from smf for now and the gallery works fine.  Set value back to 0 for the forum but still has the same problem.


Sorry for so many posts..

Offline Joey Smith™

  • SMF Friend
  • SMF Hero
  • *
  • Posts: 6,356
  • Gender: Male
Re: Turned on Maintenance Mode now can not turn it off.. PLease help
« Reply #6 on: January 03, 2009, 01:55:09 AM »
Are you sure nothing else was changed in the settings.php file?

Have you changed anything in the server settings area of the adminCP?

Offline Prowler9

  • Semi-Newbie
  • *
  • Posts: 35
Re: Turned on Maintenance Mode now can not turn it off.. PLease help
« Reply #7 on: January 03, 2009, 01:56:10 AM »
nope just turned the forum to maintenance mode that was it..

Offline Prowler9

  • Semi-Newbie
  • *
  • Posts: 35
Re: Turned on Maintenance Mode now can not turn it off.. PLease help
« Reply #8 on: January 03, 2009, 01:59:09 AM »
ok i figured it out...  Some how the db username got changed when it was put in maintenance mode.. I dont understand it at all but it seems to be working now.. I am going to try and rebridge it back up and see how it goes.. Thanks again for all your help!!

Offline Joey Smith™

  • SMF Friend
  • SMF Hero
  • *
  • Posts: 6,356
  • Gender: Male
Re: Turned on Maintenance Mode now can not turn it off.. PLease help
« Reply #9 on: January 03, 2009, 02:14:48 AM »
No problem, anytime :)

I had the same thing happen to me once.

If this solves your topic please mark this topic as solved by changing the post icon in your original post or clicking the button at the bottom of the thread.

Thanks :)