• Welcome to Simple Machines Community Forum. Please login or sign up.
January 17, 2022, 09:02:18 PM

News:

Join the Facebook Fan Page.


Additional Polls

Started by Windy, January 06, 2009, 08:12:57 AM

Previous topic - Next topic

Windy

Link to Mod

Additional Polls


Removes the restriction that prevents you from having more than one poll in a topic.
All unsolicited PM's will be ignored.  Any support requests should go in their topics.

My Mods


Image Zoom Tag
Image Quote Removal
Color Picker
Additional Polls
Simple Awards System

Mods are only updated to the latest same major version of smf on request.

shadow82x

This will be a very useful modification. Thanks! :D
Colin B
Former Spammer, Customize, & Support Team Member

lakechurch

I installed the mod, it is very simple and works perfect, thanks!


Smitten

Excelent, but... if have the Who Voted What installed it doesn´t work.

Any idea? I give you my display.template

Thanks!!

nosferatu

January 07, 2009, 02:02:33 PM #5 Last Edit: January 07, 2009, 03:31:47 PM by nosferatu
I'm afraid I can't see any difference. I am using a theme (BlueSkies) but it doesn't work in the SMF default theme either. It stated that it had been installed successfully so is there something else I should be looking at?

Actually I've now had to uninstall the theme as it interfered with a poll I was currently running. Where I had given an option to change a vote, after installing the mod, when a user attempted to change a cast vote, it was returning an error to the effect that the Board did not exist. Even when I as the admin tried to edit the poll, it came back with the same error. When I uninstalled the mod, the poll worked fine again.

Cheers

Nos
There's a certain joy in being mad that only madmen know

gemigene

I installed this package and it fouled up my polls function when I uninstalled it, I lost my "remove poll" function.

The reason I uninstalled it was that I got the following error (error log) after making 1 test poll only (without making a 2nd poll):

2: mysql_free_result(): 370 is not a valid MySQL result resource
File: /home/mysite/public_html/forum/Packages/temp/code.php
Line: 61


And "You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '' at line 2 File: /home/mysite/public_html/forum/Sources/Poll.php Line: 773" when trying to edit a poll.

So, how do I restore my "remove poll" function?

Wonder if it should be reported as an unsafe Mod...

Gene
"Religion is metaphysical statism. I will be ruled by no man on earth, nor by any god in heaven"

nosferatu

Now that you say that, I've noticed my 'remove poll' option has also disappeared.
There's a certain joy in being mad that only madmen know

gemigene

January 07, 2009, 04:17:28 PM #8 Last Edit: January 07, 2009, 05:55:39 PM by gemigene
Quote from: nosferatu on January 07, 2009, 04:10:50 PM
Now that you say that, I've noticed my 'remove poll' option has also disappeared.

Hmm, that makes two of us, I sure hope the Mod author will come up with a solution...

Cheers,
Gene
"Religion is metaphysical statism. I will be ruled by no man on earth, nor by any god in heaven"

blondeamon

Everything works great here.

This is one of the most useful mods around , thanks man
Always looking for the best

www.kamenos.gr  Greek Gaming Community

Windy

January 08, 2009, 06:41:28 AM #10 Last Edit: January 08, 2009, 06:44:59 AM by Windy
Fixed a minor installation bug that would cause the some pre-existing polls to not function properly when performing actions related to them.  Also made a few minor template changes to ensure greater compatibility with pre-existing mods.

Quote from: Smitten on January 07, 2009, 01:59:00 AM
Excelent, but... if have the Who Voted What installed it doesn´t work.

Any idea? I give you my display.template

Thanks!!
If you install the latest version with the changes I've made, when trying to install that mod over the top of mine it should report that all tests are successful (I tried this myself with just these two mods, so if you're getting any errors, this would be due to another mod), however it won't have installed properly and will fail to work as expected.  The solution is to make changes to that particular mod's modification.xml file located inside the zip file for it.  This is the change you will be required to make.
Code (Search) Select
<search position="after"><![CDATA[ }

// Calculate the fastest way to get the messages!
]]></search>

Code (Replace) Select
<search position="before"><![CDATA[ > 1 ? 'checkbox' : 'radio') . '" name="options[]" id="options-' . $i . '" value="' . $i . '" class="check" />'
);
}]]></search>

That mod will still be able to function stand alone with this change intact, so if you ever decide to uninstall my mod (you will be required to remove this one first) that package should still be able to install successfully.

Quote from: gemigene on January 07, 2009, 04:17:28 PM
Quote from: nosferatu on January 07, 2009, 04:10:50 PM
Now that you say that, I've noticed my 'remove poll' option has also disappeared.

Hmm, that makes two of us, I sure hope the Mod author will come up with a solution...

Cheers,
Gene
There is no solution, if you uninstall a package, you lose the changes it makes, simple as that.  As for the sql error, that's probably related to the error I fixed above, otherwise I can only assume that it's caused by conflicting with another mod. Also, please don't message me support related issues regarding mods, this is what these topics are for, trying to rush me will only irritate me and make me less likely to assist you.

Quote from: nosferatu on January 07, 2009, 02:02:33 PM
I'm afraid I can't see any difference. I am using a theme (BlueSkies) but it doesn't work in the SMF default theme either. It stated that it had been installed successfully so is there something else I should be looking at?

Actually I've now had to uninstall the theme as it interfered with a poll I was currently running. Where I had given an option to change a vote, after installing the mod, when a user attempted to change a cast vote, it was returning an error to the effect that the Board did not exist. Even when I as the admin tried to edit the poll, it came back with the same error. When I uninstalled the mod, the poll worked fine again.

Cheers

Nos
Again, probably related to the error I fixed above.  The difference you'll see when the mod is installed is rather minimal as it tries to keep template changes down to a minimum, or rather it doesn't need to make too many changes, effectively you'll only really notice it when you try to add a poll to a topic that already has one.
All unsolicited PM's will be ignored.  Any support requests should go in their topics.

My Mods


Image Zoom Tag
Image Quote Removal
Color Picker
Additional Polls
Simple Awards System

Mods are only updated to the latest same major version of smf on request.

[SiNaN]

Tested on a fresh SMF 1.1.7 forum and there doesn't seem to be any problems about removing polls.

Great mod Windy.
Former SMF Core Developer | My Mods | SimplePortal

gemigene

QuoteThere is no solution, if you uninstall a package, you lose the changes it makes, simple as that.  As for the sql error, that's probably related to the error I fixed above, otherwise I can only assume that it's caused by conflicting with another mod.

For some strange reason, if I create a new single poll and try to vote, I get the following error:
QuoteEither that poll doesn't exist, the poll has been locked, or you tried to vote twice.

I assume that there is a conflict with another mod.

Cheers,
Gene
"Religion is metaphysical statism. I will be ruled by no man on earth, nor by any god in heaven"

cubetgio

Hello windy,

Additional Polls v1.0
-----------------------------------
Removes the restriction that prevents you from having more than one poll in a topic.


How do i do this ?

Thanks you for this very usefull mod !

nosferatu

If you look on the bottom bar below the messages, you'll see 'add poll'.

This appeared to work but, when I checked a test poll, I put 2 questions up and was able to answer the second one successfully, but when I attempted to vote on the first one it returned an error stating: Either that poll doesn't exist, the poll has been locked, or you tried to vote twice.

Why would it work on the second poll of 2 but not the first?
There's a certain joy in being mad that only madmen know

Windy

Quote from: nosferatu on January 10, 2009, 08:30:03 AM
If you look on the bottom bar below the messages, you'll see 'add poll'.

This appeared to work but, when I checked a test poll, I put 2 questions up and was able to answer the second one successfully, but when I attempted to vote on the first one it returned an error stating: Either that poll doesn't exist, the poll has been locked, or you tried to vote twice.

Why would it work on the second poll of 2 but not the first?
What version are you using? as I don't experience any problems when voting, regardless of order.
All unsolicited PM's will be ignored.  Any support requests should go in their topics.

My Mods


Image Zoom Tag
Image Quote Removal
Color Picker
Additional Polls
Simple Awards System

Mods are only updated to the latest same major version of smf on request.

nosferatu

Thanks windy. I'm using the latest version, having deleted the initial and then uploading the new one. It doesn't interfere with the current poll I have (as was the case) so I can now remove my vote and vote again (referring to my original post on here). However, the added poll feature seems to throw up this strange error. It works fine and sets up the additional poll but, for some reason, allows voting on the second poll but not on the first. I do have some other mods installed so I can't rule out a conflict but it just seems a little strange.
There's a certain joy in being mad that only madmen know

nosferatu

January 11, 2009, 06:26:21 AM #17 Last Edit: January 11, 2009, 08:34:30 AM by nosferatu
I unistalled the mod and attempted to reinstall but now get the following:

QuoteYou have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'WHERE ID_POLL = 10' at line 3
File: /home/southwalesuk/public_html/forum/Packages/temp/code.php
Line: 59

This hasn't affected my forum as it hasn't installed. Any ideas?
There's a certain joy in being mad that only madmen know

Daggers

QuoteEither that poll doesn't exist, the poll has been locked, or you tried to vote twice.

I get this too ... uninstalled this one  :-\  :(

Bancherd

Same problem here, got the same error message after trying to vote in the second poll.

I am using SMF1.1.7 which was upgraded from 1.1.5/1.1.4.  Database is utf-8(not that this should matter).

The mod was uninstalled without any problems, however.

Bancherd

Quote from: nosferatu on January 10, 2009, 08:30:03 AM
If you look on the bottom bar below the messages, you'll see 'add poll'.

This appeared to work but, when I checked a test poll, I put 2 questions up and was able to answer the second one successfully, but when I attempted to vote on the first one it returned an error stating: Either that poll doesn't exist, the poll has been locked, or you tried to vote twice.

Why would it work on the second poll of 2 but not the first?

Advertisement: