Advertisement:

Author Topic: 2.4 not working with internet explorer  (Read 3902 times)

Offline cultureco

  • Semi-Newbie
  • *
  • Posts: 34
2.4 not working with internet explorer
« on: January 21, 2009, 11:00:36 AM »
he
I have a big problem. smf, fresh intallation, is not working with IE. As you can see, I have a probleme with the second menu, it is on le left, not align right
if someone can help me

I mean
theme_linktree
« Last Edit: January 21, 2009, 11:09:26 AM by cultureco »

Offline H

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 21,662
  • Gender: Male
Re: 2.4 not working with internet explorer
« Reply #1 on: January 21, 2009, 05:08:56 PM »
Welcome to SMF.
Any mods installed?
Does the problem occur with English as the language?

If possible, please post a link to your site :)
-H
Former Support Team Lead
                              I recommend:
Namecheap (domains)
Fastmail (e-mail)
Linode (VPS)
                             

Offline cultureco

  • Semi-Newbie
  • *
  • Posts: 34
Re: 2.4 not working with internet explorer
« Reply #2 on: January 22, 2009, 03:46:15 AM »
thank you for tour reply
yes, even with ennglish language, and it a new install.
I even try an othe install and it's the same probleme.

Offline cultureco

  • Semi-Newbie
  • *
  • Posts: 34
Re: 2.4 not working with internet explorer
« Reply #3 on: January 22, 2009, 05:22:23 AM »
I think the prole is comming from this

   // Show the page index... "Pages: [1]".
   echo '
<div class="clearfix margintop" id="postbuttons">
   <div class="margintop middletext floatleft">', $txt['pages'], ': ', $context['page_index'], !empty($modSettings['topbottomEnable']) ? $context['menu_separator'] . ' &nbsp;&nbsp;<a href="#lastPost"><strong>' . $txt['go_down'] . '</strong></a>' : '', '</div>
   <div class="next">', $context['previous_next'], '</div>
   <div class="nav floatright">', template_button_strip($normal_buttons, 'bottom'), '</div>
</div>';

there is no css floatright

Offline cultureco

  • Semi-Newbie
  • *
  • Posts: 34
Re: 2.4 not working with internet explorer
« Reply #4 on: January 22, 2009, 02:48:50 PM »
May be it's because of my css. Can someone send me here his forum's css et style.css of perhaps 2.2 or 2.1
thank you

Offline H

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 21,662
  • Gender: Male
Re: 2.4 not working with internet explorer
« Reply #5 on: January 22, 2009, 02:53:19 PM »
The old files can be found in the archive section on the download page. You can also compare your CSS to one in the latest download archive.

This is almost certainly something specific to your site or client configuration as this isn't normal behaviour on a 2.0b4 install
-H
Former Support Team Lead
                              I recommend:
Namecheap (domains)
Fastmail (e-mail)
Linode (VPS)
                             

Offline ɔɔɔɔɔɔuɥoɾ

  • SMF Hero
  • ******
  • Posts: 2,742
  • Gender: Male
  • Community Support Helper SMF forums ftw!
Re: 2.4 not working with internet explorer
« Reply #6 on: January 22, 2009, 02:58:14 PM »
if your talking about the text over lapping i had this problem and it was solved

i will get the link to the topic it was solved in :)

EDIT:

here is the solved topic
http://www.simplemachines.org/community/index.php?topic=280979.0
« Last Edit: January 22, 2009, 03:01:22 PM by johncccccc »

SMF 2.0 RC5

   
Webhost to New Webhost file transfer service, PM me - Fast transfers

Offline cultureco

  • Semi-Newbie
  • *
  • Posts: 34
Re: 2.4 not working with internet explorer
« Reply #7 on: January 23, 2009, 10:11:27 AM »
No, it not this probleme, i try to install it on an other probleme and it's the same probleme, under IE juste

Offline cultureco

  • Semi-Newbie
  • *
  • Posts: 34
Re: 2.4 not working with internet explorer
« Reply #8 on: January 24, 2009, 06:29:41 AM »
Up
Can someone please send me his css have probleme with floatleft and floatright with internet explorer 6

Offline greyknight17

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 14,890
  • Gender: Male
    • Kevin's Resource Center
Re: 2.4 not working with internet explorer
« Reply #9 on: January 31, 2009, 12:46:14 PM »
This is a problem with IE6 and has been reported already. Open up /Themes/default/css/ie6.css and add the following into it (if it doesn't exist already):

Code: [Select]
.modbuttons .buttonlist_bottom ul, .modbuttons .buttonlist ul, .floatright .buttonlist ul, .floatright .buttonlist_bottom ul, .readbuttons .buttonlist ul, .readbuttons .buttonlist_bottom ul
{
    float: left;
}

If a similar code exists, replace float: right; with float: left; instead.