Fatal error...

Started by Khardan, February 06, 2009, 08:55:52 PM

Previous topic - Next topic

Khardan

Hi,

I'm "trying" to upgrade from 1.1.8. to 2.0 RC1.  When it came time to run the upgrade.php file, I received the IIS Password error.  Per instructions previously posted, I deleted the .htaccess file and now receive the following error:

Warning: loadessentialdata(\xxxxxx\home\users\web\xxxxx\ipw.xxxxxxxx\forum/Sources/Subs-Compat.php) [function.loadessentialdata]: failed to open stream: No such file or directory in \\xxxx\home\users\web\xxxxx\ipw.xxxxxxxxx\forum\upgrade.php on line 792

Fatal error: loadessentialdata() [function.require]: Failed opening required '\xxxxxxxx\home\users\web\xxxx\ipw.xxxxxxxxx\forum/Sources/Subs-Compat.php' (include_path='.;c:\php\includes') in \\xxxxxxxx\home\users\web\xxxx\ipw.xxxxxxxxxx\forum\upgrade.php on line 792


The file Subs-Compat.php is where it's supposed to be :/

Any suggestions?

Thanks for whatever help you can offer - I am quickly losing my hair.

coldfusionpower

im getting the same thing !!

Kermit

It seems to be something with Settings.php file,try to download it to your desktop and check the lines regarding db informations or there should be a file with name Settings_bak.php,just download it - rename it as Settings.php and reupload it via FTP
My Mods
Please don't PM/mail me for support,unless i invite you
Formerly known as Duncan85
Quote
"Two things are infinite: the universe and human stupidity; and I'm not sure about the the universe."

A. Einstein

Khardan

Thanks.  Is there something specific I should look for?  I'm a semi-newbie...

Kermit

I'd suggest you,first to try my 2nd method,also this

Quotethere should be a file with name Settings_bak.php,just download it - rename it as Settings.php and reupload it via FTP

If that won't work,you should look at those lines in Settings.php


########## Database Info ##########
$db_server = ' ';
$db_name = ' ';
$db_user = ' ';
$db_passwd = ' ';
$db_prefix = 'smf_';
$db_persist = 0;
$db_error_send = 1;


They should be filled out with the correct db informations
My Mods
Please don't PM/mail me for support,unless i invite you
Formerly known as Duncan85
Quote
"Two things are infinite: the universe and human stupidity; and I'm not sure about the the universe."

A. Einstein

Khardan

Nope.  The info is  correct - even checked with the host provider to be sure of the db file locations.  Same error :/

greyknight17

Khardan, is this issue resolved now? If not, PM me the login credentials for your webhost, FTP and a temporary admin account for SMF. Please change your passwords before giving me access for security reasons.

Advertisement: