Advertisement:

Author Topic: 2.0RC1: Impossible to edit users profile  (Read 4020 times)

Offline Lamarck

  • Jr. Member
  • **
  • Posts: 127
2.0RC1: Impossible to edit users profile
« on: February 08, 2009, 02:38:28 PM »
I updated from 2.0beta4 to 2.0RC1.Now,If I click "Forum profile" or whatever option in someone's profile (for example,to edit the signature of one of my users) I go to my "forum profile".

Also,the forum profile string was missed in the profile language file.However,the most important problem is the first: now I can't edit my forum member's profile.

Please,help!.

PD:sorry for my bad english,I asked this is the spanish support forum but no one helped me.

Offline karlbenson

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 15,630
  • Gender: Male
    • Lifeproof
Re: 2.0RC1: Impossible to edit users profile
« Reply #1 on: February 08, 2009, 03:14:17 PM »
Is the u=1234 in the url of the profile?
without that part, it will go to your profile
Are you using the SMF Default Core Theme?

What error are you getting in your error log?

Offline aldo

  • Sophist Member
  • *****
  • Posts: 1,356
  • Gender: Male
Re: 2.0RC1: Impossible to edit users profile
« Reply #2 on: February 08, 2009, 03:21:20 PM »
Have you cleared the file cache in the Admin CP? (Admin CP > Maintenance > Forum Maintenance > Routine then Click "Run Task Now" under Empty the file cache)

Offline Lamarck

  • Jr. Member
  • **
  • Posts: 127
Re: 2.0RC1: Impossible to edit users profile
« Reply #3 on: February 08, 2009, 04:35:03 PM »
I tried clearing the cache,but still the same problem.

No,I don't see u=1234.All URLs are like this:

http://silvanost.byethost31.com/foro/index.php?action=profile;area=forumprofile;sesc=0dc5f5ed9d0b62099308c1d1e0adbf30

I have the same problem in SMF Default Theme and in my custom themes.

Also,I have this error in the error log:

Quote
8:Undefined index: forumprofile
File: /home/vol3/byethost9.com/b9_222711/silvanost.byethost31.com/htdocs/foro/Sources/Subs.php
                               Línea: 3996                            

PD:the problem is not only with the forum profile link,also with look and layout,account settings,etc all redirect to my profile.

Offline CraftyLion

  • Jr. Member
  • **
  • Posts: 222
Re: 2.0RC1: Impossible to edit users profile
« Reply #4 on: February 08, 2009, 05:25:47 PM »
I'm having the same problem. The options I see under in the "Modify Profile" heading are:

Account Settings
Look and Layout
Notifications
Personal Messaging

The only difference is it only appears in the Energy Final theme which I'm using. The default theme is fine.
« Last Edit: February 08, 2009, 05:36:21 PM by kimba »

Offline Lamarck

  • Jr. Member
  • **
  • Posts: 127
Re: 2.0RC1: Impossible to edit users profile
« Reply #5 on: February 10, 2009, 11:58:56 AM »
Help please >__<.

Offline nathan89

  • Semi-Newbie
  • *
  • Posts: 88
Re: 2.0RC1: Impossible to edit users profile
« Reply #6 on: February 10, 2009, 04:18:12 PM »
Same problem here, it works if I manually add in the user id of the profile, but when viewing another persons profile if I click on for example account settings I have to enter the member ID to get to their settings otherwise it of course take me to mine.

Any Ideas? 

Offline Yağız...

  • SMF Super Hero
  • *******
  • Posts: 10,811
  • Gender: Male
    • MMO Browser
Re: 2.0RC1: Impossible to edit users profile
« Reply #7 on: February 10, 2009, 04:38:19 PM »
Replace attached file with yours(Themes/energyfinal/GenericMenu.template.php). It's just a problem with your themes.

Offline nathan89

  • Semi-Newbie
  • *
  • Posts: 88
Re: 2.0RC1: Impossible to edit users profile
« Reply #8 on: February 10, 2009, 05:40:04 PM »
Great that worked! Thank you!!

Offline Lamarck

  • Jr. Member
  • **
  • Posts: 127
Re: 2.0RC1: Impossible to edit users profile
« Reply #9 on: February 10, 2009, 07:21:23 PM »
It works.Thank you very much!!!.

Offline Re@PeR

  • Semi-Newbie
  • *
  • Posts: 11
  • Gender: Male
    • Re@PeR's Blog
Re: 2.0RC1: Impossible to edit users profile
« Reply #10 on: February 27, 2009, 01:27:02 PM »
Deleting the language folder in my custom theme and using the default language from the default core theme fixed it for me, thanks for the help  :D
[nofollow] [nofollow]