Advertisement:

Author Topic: Yet Another Global Announcements Mod (YAGAM)  (Read 210419 times)

Offline Orbit Storm

  • Semi-Newbie
  • *
  • Posts: 39
    • @Orbit_Storm on Twitter
Re: Yet Another Global Announcements Mod (YAGAM) [Supporting 2.0 Final]
« Reply #560 on: February 08, 2012, 05:01:41 AM »
Hi!

Seems I'm having a bit of trouble with this mod, and truthfully, it's a darn shame considering how badly I've needed this, and finally found it just a bit ago.

The mod installs seamlessly (provided that I set my Emulate Version to 2.0.0 (my actual version is 2.0.2.

Upon attempting to convert a thread into an announcement, I receive the following error:

Code: [Select]
Unable to load the 'main' template.
I've done some extensive searching, but nothing seems to be related to this mod. Any help offered, would be greatly appreciated.  :)

Offline fullmoonya

  • Jr. Member
  • **
  • Posts: 189
    • my forum
Re: Yet Another Global Announcements Mod (YAGAM) [Supporting 2.0 Final]
« Reply #561 on: February 08, 2012, 10:16:02 PM »
Hi!

Seems I'm having a bit of trouble with this mod, and truthfully, it's a darn shame considering how badly I've needed this, and finally found it just a bit ago.

The mod installs seamlessly (provided that I set my Emulate Version to 2.0.0 (my actual version is 2.0.2.

Upon attempting to convert a thread into an announcement, I receive the following error:

Code: [Select]
Unable to load the 'main' template.
I've done some extensive searching, but nothing seems to be related to this mod. Any help offered, would be greatly appreciated.  :)

that was our problem too with this mod. the problem is that it cant call the function because it was missing in the code. i dont know when will they do something about this. i hope it to be fix asap.
do not mark my topic solve unless it is REALLY SOLVED.
my forum

Visit My Blog:
Google SEO Share

Offline Orbit Storm

  • Semi-Newbie
  • *
  • Posts: 39
    • @Orbit_Storm on Twitter
Re: Yet Another Global Announcements Mod (YAGAM) [Supporting 2.0 Final]
« Reply #562 on: February 09, 2012, 01:13:23 AM »
I've found that the temporary solution is to just add a new announcement via the Admin panel. It's a real pain (especially if you want to make previously posted content an announcement), but copy/pasting the content into a new announcement worked fine for me. I agree though - I hope this is updated.

Offline fullmoonya

  • Jr. Member
  • **
  • Posts: 189
    • my forum
Re: Yet Another Global Announcements Mod (YAGAM) [Supporting 2.0 Final]
« Reply #563 on: March 14, 2012, 12:28:48 AM »
i hope somebody fix the problem in converting topics to announcements. Just really need that function.
do not mark my topic solve unless it is REALLY SOLVED.
my forum

Visit My Blog:
Google SEO Share

Offline drroot

  • Jr. Member
  • **
  • Posts: 108
Re: Yet Another Global Announcements Mod (YAGAM) [Supporting 2.0 Final]
« Reply #564 on: May 10, 2012, 09:43:24 PM »
How to give Global Moderator the permission to post an announcement?
« Last Edit: May 11, 2012, 06:29:50 AM by Kindred »

Offline lttung

  • Jr. Member
  • **
  • Posts: 134
Re: Yet Another Global Announcements Mod (YAGAM) [Supporting 2.0 Final]
« Reply #565 on: June 07, 2012, 12:44:46 PM »
Hi!

Seems I'm having a bit of trouble with this mod, and truthfully, it's a darn shame considering how badly I've needed this, and finally found it just a bit ago.

The mod installs seamlessly (provided that I set my Emulate Version to 2.0.0 (my actual version is 2.0.2.

Upon attempting to convert a thread into an announcement, I receive the following error:

Code: [Select]
Unable to load the 'main' template.
I've done some extensive searching, but nothing seems to be related to this mod. Any help offered, would be greatly appreciated.  :)

Same me error. Pls help to fix, thanks

Offline nephire

  • Newbie
  • *
  • Posts: 9
Re: Yet Another Global Announcements Mod (YAGAM) [Supporting 2.0 Final]
« Reply #566 on: July 03, 2012, 04:06:42 PM »
it wont let me install it..
it only shows list files and delete

Offline Kindred

  • The Mean One
  • Support Specialist
  • SMF Legend
  • *
  • Posts: 58,430
  • Gender: Male
    • Kindred-999 on GitHub
Re: Yet Another Global Announcements Mod (YAGAM) [Supporting 2.0 Final]
« Reply #567 on: July 03, 2012, 05:44:21 PM »
look up "emulate version" in the wiki
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.


Offline FruitLoop

  • Newbie
  • *
  • Posts: 2
Re: Yet Another Global Announcements Mod (YAGAM) [Supporting 2.0 Final]
« Reply #569 on: August 30, 2012, 03:51:26 PM »
Hello.  I tried installing this mod with the Enterprise theme and it did not work.  Tried installing it with the default theme and I got the same error.

The error was immediately after install.  It said it was successfully installed, however when I went to go to the admin panel for it, it gave me a blank white screen.  Is it the Admin.php file or something else?

Offline cieplutki

  • Jr. Member
  • **
  • Posts: 107
  • Gender: Male
    • http://www.facebook.com/pages/ewmapapl/27284179607 on Facebook
    • @https://twitter.com/ on Twitter
    • .:: ewmapa ::.
Re: Yet Another Global Announcements Mod (YAGAM) [Supporting 2.0 Final]
« Reply #570 on: September 27, 2012, 02:53:35 PM »
How to fix


this bug its on some theme - like officebox by logooff

Code: [Select]
echo '
<tr>
<td class="windowbg2 icon1 yagam">
<img src="', $settings['images_url'], '/topic/normal_post.gif" alt="" />
</td>
<td class="windowbg2 icon2 yagam">
<img src="', $settings['images_url'], '/post/exclamation.gif" alt="" />
</td>
<td  class="subject windowbg yagam">
    <a href="',$scripturl,'?action=announcements;aid=',$announcement['id_announcement'],'"><strong>',$announcement['title'], '</strong></a>
    <p class="smalltext">', $txt['started_by'], ' <a href="'.$scripturl.'?action=profile;u=',$announcement['author'], '" ', (!empty($modSettings['MemberColorLinkInstalled'])) ? 'style="color: '.$announcement['online_color'].';"' : '', '>',$announcement['real_name'], '</a></p>
</td>
<td class="stats yagam">
    ', ($announcement['can_comment'] == '1') ? ''.$announcement['comment_total'].' ' . $txt['replies'] : '--', '<br />
',$announcement['views'], ' ' . $txt['views']. '
    </td>
<td class="windowbg2 lastpost yagam">
'.$txt['yagam_created'].' : ',timeformat($announcement['date']), '
</td>';
if (allowedTo('yagam_manage') && !empty($options['display_quick_mod']))
echo '<td class="windowbg2 moderate yagam" width="5%"><a href="',$scripturl,'?action=announcements;sa=edit;aid=',$announcement['id_announcement'],'" title="'.$txt['yagam_edit'].'"><img src="'.$settings['images_url'].'/buttons/modify.gif" alt="',$txt['yagam_edit2'], '"></a>
<a href="',$scripturl,'?action=announcements;sa=deleteverify;aid=',$announcement['id_announcement'],'" title="'.$txt['yagam_remove'].'" onclick="return confirm(\''.$txt['yagam_remove_verify'].'\')"><img src="'.$settings['images_url'].'/buttons/delete.gif" alt="',$txt['yagam_remove2'], '"></a>
</td>';
echo'</tr>';      

Offline Mstcool

  • Sr. Member
  • ****
  • Posts: 911
Re: Yet Another Global Announcements Mod (YAGAM) [Supporting 2.0 Final]
« Reply #571 on: November 23, 2012, 12:45:52 AM »
It says its compatible with 2.0.2 but doesnt work. Please help. It says its not compatible.

Offline Road Rash Jr.

  • Sr. Member
  • ****
  • Posts: 765
Re: Yet Another Global Announcements Mod (YAGAM) [Supporting 2.0 Final]
« Reply #572 on: January 11, 2013, 09:16:27 AM »
Will not install on SMF 2.0.3 says the files is corrupt or incompatible with this version of SMF
Never argue with an Idiot like myself, they just drag you down to their level then beat you with experience.

Offline NanoSector

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 10,499
  • Gender: Male
  • VC321xb47@aperture:~#
    • Yoshi2889 on GitHub
My Mods / Mod Builder - A tool to easily create mods / Blog
"I've heard from a reliable source that the Answer is 42. But, still no word on what the question is."

Offline JTVaughn

  • Jr. Member
  • **
  • Posts: 177
Re: Yet Another Global Announcements Mod (YAGAM) [Supporting 2.0 Final]
« Reply #574 on: January 18, 2013, 05:34:56 AM »
Hi!

Seems I'm having a bit of trouble with this mod, and truthfully, it's a darn shame considering how badly I've needed this, and finally found it just a bit ago.

The mod installs seamlessly (provided that I set my Emulate Version to 2.0.0 (my actual version is 2.0.2.

Upon attempting to convert a thread into an announcement, I receive the following error:

Code: [Select]
Unable to load the 'main' template.
I've done some extensive searching, but nothing seems to be related to this mod. Any help offered, would be greatly appreciated.  :)

Same me error. Pls help to fix, thanks

Same error for me.

Any fix coming?

Offline 4LP3RUZ1

  • SMF Hero
  • ******
  • Posts: 3,438
  • Gender: Male
  • Frozen frogs are gone!
Re: Yet Another Global Announcements Mod (YAGAM) [Supporting 2.0 Final]
« Reply #575 on: February 08, 2013, 03:26:52 AM »
Love this mod,

Got a question.

I want to display a specific announcement for one of my post count membergroups.

However, I cannot choose these groups from the add announcement screen. Only regular membergroups are there. Any way to add the post count groups?
Frozen frogs are back :(


Offline 4LP3RUZ1

  • SMF Hero
  • ******
  • Posts: 3,438
  • Gender: Male
  • Frozen frogs are gone!
Re: Yet Another Global Announcements Mod (YAGAM) [Supporting 2.0 Final]
« Reply #577 on: February 10, 2013, 04:36:04 AM »
Well, I haven't checked what the repercussions will be yet, however I tracked the membergroups to this query:

Code: [Select]
$dbresult = $smcFunc['db_query']('', '
        SELECT id_group, group_name
        FROM {db_prefix}membergroups
        WHERE min_posts = {int:primary_group}
        AND id_group <> {int:moderator}
        ORDER BY group_name',
        array(
          'primary_group' => -1,
          'moderator' => 3,
        )
        );

and changing it to:
Code: [Select]
$dbresult = $smcFunc['db_query']('', '
        SELECT id_group, group_name
        FROM {db_prefix}membergroups
        WHERE id_group <> {int:moderator}
        ORDER BY group_name',
        array(
          'primary_group' => -1,
          'moderator' => 3,
        )
        );
seems to work. I'm guessing though there is a good reason you are filtering out post count groups...
Frozen frogs are back :(

Offline dubq

  • Newbie
  • *
  • Posts: 2
Re: Yet Another Global Announcements Mod (YAGAM) [Supporting 2.0 Final]
« Reply #578 on: March 19, 2013, 04:40:13 PM »
There is no option to install this when you upload to 2.0.4 either. :( Will this be updated soon?