• Welcome to Simple Machines Community Forum. Please login or sign up.
September 21, 2021, 01:33:30 PM

News:

Wondering if this will always be free?  See why free is better.


Problemi con smf media gallery

Started by gregxxiii, February 28, 2009, 12:46:27 PM

Previous topic - Next topic

gregxxiii

February 28, 2009, 12:46:27 PM Last Edit: March 02, 2009, 12:13:22 PM by gregxxiii
ciao a tutti e scusate

sto cercando di installare la galleria nel mio forum

ho scaricato il file zip,
modificato tutti i files nella guida manual installazion per il mio forum (1.1.8 )

Inserito i files come descritto nel manuale
alla fine quando aggiorno il forum, mi appare il seguente messaggio

Quote
You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'FROM smf_members AS mem LEFT JOIN smf_attachments AS a ON

ho ripetiuto le oprazioni piu' volte, con il dubbio che avevo sbagliato a copiare una modifica,...

dove sbaglio??
o mi dimentico qualcosa?

Help please
grazie

Darknico

Italian SMF - Supporto Italiano per la board SMF - Ci trovate tutti li!! :)


gregxxiii

February 28, 2009, 02:02:21 PM #2 Last Edit: February 28, 2009, 02:08:41 PM by gregxxiii
in questa mod intendi? o precedentemente?

in questa mod ho seguito passo passo la manual installation per 1.1.8 del file smfMediaGallery 1.5.5
che si trova qui
http://custom.simplemachines.org/mods/index.php?mod=1365


precedentemente ho installato


  • ALLCAPS NOTIFY
  • FontandSizeDropdown_1.3
  • Images On Board 2.0 


sempre seguendo l'installazioen manuale delle varie guide,.. senza problemi



EDIT: ora che ci penso, ho eliminato il file  MGallery.french.php e creato un file MGallery.italian.php  nella directory : Themes\ default\ languages

E' possibile che va in errore perche nn trova il file french?

Darknico

no non centra...
ma hai lanciato il file db_mgallery.php?
Italian SMF - Supporto Italiano per la board SMF - Ci trovate tutti li!! :)


gregxxiii

lanciarlo come?

Appena carico i files in ftp, mi appare quell'errore del mio primo post, e non riesco a fare nulla
ho solo una pagina bianca con in alto quell'errore, ( che non riesco a decifrare)
per poter utilizzare i files, devo ricaricare i files dalla cartella backup, e il forum continua a funzionare,

come potrei lanciare il file db_mgallery.php senza avere gli altri php modificati?


P.s.: mi sono avvicinato al simple machine da pochissimo,.. e, anche se ho qualche nozione,.. mi considero comunque un newbe

Darknico

Italian SMF - Supporto Italiano per la board SMF - Ci trovate tutti li!! :)


gregxxiii

February 28, 2009, 04:25:55 PM #6 Last Edit: February 28, 2009, 07:40:20 PM by gregxxiii
si, fatto una prova anche con packages manager, ma stesso errore

domanda,.. piccolo dubbio,...
ma con package maneger, devo editare i files lo stesso, oppure fa tutto in automatico?

a proposito,.. ora che mi ricordo,.. installando con package manager, mi dice di modificare il file .htaccess

Purtroppo tutto in inglese, dove ho qualche lacuna


EDIT: ho rifatto la prova con package manager,
ha installato con successo dice,...
ora riesco a muovermi nel forum, ma la galleria, non la vedo nè nel forum,.. nè nella sez admin

pero' mi dice che il packetto è installato


EDIT2:  ho dovuto disinstallare, perche ni andava in syntax error se si cliccava su un profilo utente

Scusa se ti rompo,... potresti elencarmi i passaggi precisi da eseguire, partendo da zero?
Con calma, senza fretta

é possibile che ci sia un errore nella mod?
cosa mi consigli di fare?

Una gallery alternativa?

attendo tue risposte, anche perche ho riprovato varie volte, e con l'installazioen manuale, va tutto in crask, e con il package mamager, installa, ma non si vede nulla, ma non si possono visualizzare i profili utenti

Un ultima info,... il forum è hostato su altervista, non so se ti puo' essere utile

buonanotte e grazie per la pazienza

gregxxiii

ci rinuncio

ho provato lite gallery, e sembra che funziona bene,.. solo che non mi fa creare un album per ogni utente, ma da la possibilita' ad ogni utente di inserire le proprie immagini in qualsiasi categoria

quello che sto cercando è,
un semplice album fotografico, dove posso destinare ad ogni utente il suo album, dove lui puo' inserire e descrivere i propri files, privati o pubbliche

esiste qualcosa per SMF?


Darknico

stai facendo tutto da solo, cmq è domenica, non potevo esserci per te....

SMG gallery, funziona, sbaglierai qualcosa te...
ma hai messo la traduzione??
Italian SMF - Supporto Italiano per la board SMF - Ci trovate tutti li!! :)


gregxxiii

so che era domenica, e il mio "ci rinuncio" non era dovuto ad una mancata risposta da parte tua, ma alle infinite prove che ho fatto

Ho messo traduzione, ho rimesso i vecchi files, ho installato tramite il package manager
ho letto tutti i siti possibili
niente, ad ogni isntallazione, appare il messaggio di errore del primo post

ora ho installato il lite,
in pratica avrei risolto,.. se c'è un modo di fare inserire le immagini agli utenti sono nelle loro cartelle

oppure se conosci un "album fotografico" alternativo, che ha le cartelle personale per gli utenti

Ci tengo a precisare, dark, non era una lamentela, la mia, ma , anzi,
ti rigrazio per la disponibilita', e vi devo fare i complimenti

Darknico

quale versione di SMG hai installato? mi sembra strano sto errore e non  mi sembra neanche centri...
sicuro che non si altro che da conflitto?
Italian SMF - Supporto Italiano per la board SMF - Ci trovate tutti li!! :)


gregxxiii

avevo installato la 1.5.5
il mio forum è versione 1.1.8


comunque, per quello che serve a me, SMG è sprecata

sto provando la lite, e sto valutando di fare l'upgrade a pro, in modo che gli utentu hanno la loro cartella personale

per il mio tipo di forum, serve solo album fotografico,
le tools come mp3, o videos, che sono presenti nella SMG, non li utilezzero' mai

Una domanda sulla versione gallery pro

se compro la licenza, ho letto che ho diritto agli upgrates di 1 anno, ma la licenza, è valida sempre, o ha scadenza?

Ho letto nel forum ufficiale, ma non sono sicuro di aver capito bene

Darknico

ma perchè spendere quando puoi avere tutto free? SMG anche io lo uso solo per immagini e quindi?
è molto piu potente di smf gallery, fidati di me, che sono un betatester da tempo e la conosco bene...


la gallery pro non l'ho mai provata e non so dirti comè, cmq se dice che è per un anno è per un anno, quindi si, scadenza c'è
Italian SMF - Supporto Italiano per la board SMF - Ci trovate tutti li!! :)


gregxxiii

allora non saprei,....

forse è altervista che crea problemi (ho avuto una cosa analoga con il forum precedente)

se vuoi, quando hai tempo, e senza fretta,  ti posso creare un account admin,.. cosi provi te

Mi dispiace solo che ti sto facendo perdere un casino di tempo

Darknico

secondo me è qualcos'altro..
è un forum nuovo? gai possibilità di cancellare tutto e rifare?
Italian SMF - Supporto Italiano per la board SMF - Ci trovate tutti li!! :)


gregxxiii

forse ho risolto aspe

parlandoti di altervista, mi è venuto un dubbio,
avevo caricato un forum pphb e c'era rimasta traccia in phpMyadmin

ho tirato via quello, e SMG ora va (in inglese
provvedo a fare la traduzione e ti faro' sapere

Darknico

oltre a essere un betatester sono anche il traduttore ufficiale ;)

ecco  te
http://www.italiansmfmods.net/index.php?topic=357.0

Italian SMF - Supporto Italiano per la board SMF - Ci trovate tutti li!! :)


gregxxiii

sei un mito  :)

inserisco e ti faccio sapere


ultima domanda, e poi prometto che nn ti rompo piu

se faccio installazioen dal package maneger, devo cmq modificare dei files a mano?
o fa tutto in automatico e devo modificare solo la lingua?


grazie per la traduzione

Darknico

se usi un tema di default, l'unica cosa da fare a mano e la traduzione
se usi un tema no di default devi modificare 1 o piu file per adattare il tutto

prego per la traduzione, mi sono preso un impegno con i creatori della galllery e la tengo aggiornata ;)
Italian SMF - Supporto Italiano per la board SMF - Ci trovate tutti li!! :)


gregxxiii

ok, risolto,....
si devo  aggiornare qualche files, tra le quali  Mgallery.italian.php  e altri
ma qs nn è un problema

vedo 2 pulsanti galleria nel menu, ma credo sia dovuto al continuo installare e deinstallare,.. trovero' l'inghippo

non so come ringraziarti, veramente

grazie 1000,.. sei gentilissimo , e se ti serve una mano per fare qualche traduzione ti passo il mio indirizzo email
per te, sempre a disposizione  ;)

Darknico

Prego, son qua per questo ;)

ho un progetto per le traduzioni delle mod, se ti interessa mandami un PM ;)
Italian SMF - Supporto Italiano per la board SMF - Ci trovate tutti li!! :)


fotografo74

Quote from: gregxxiii on March 02, 2009, 12:13:03 PM
..........
vedo 2 pulsanti galleria nel menu, ma credo sia dovuto al continuo installare e deinstallare,.. trovero' l'inghippo

...........

Se hai due pulsanti prova a vedere in index.template.php questo codice


// [SMF Media Gallery]
if (allowedTo('mgallery_access'))
echo ($current_action == 'mgallery' || $context['browser']['is_ie4']) ? '<td class="maintab_active_' . $first . '">&nbsp;</td>' : '' , '
<td valign="top" class="maintab_' , $current_action == 'mgallery' ? 'active_back' : 'back' , '">
<a href="', $scripturl, '?action=mgallery">' , $txt['mgallery_gallery'] , '</a>
</td>' , $current_action == 'mgallery' ? '<td class="maintab_active_' . $last . '">&nbsp;</td>' : '';



e questo

if ($context['current_action']=='mgallery')
$current_action = 'mgallery';


e vedi se è ripetuto due volte, in caso lascia una sola istanza.
Potrebbe essere questo il problema.
Anto

gregxxiii

si grazie 1000 fotografo,.. avevo risolto e scritto  :)
ty ty

Advertisement: