SMF Arcade

Started by niko, October 01, 2004, 02:45:55 PM

Previous topic - Next topic

jack001

is it possible to have this mod?
https://www.edufor.xyz Edutainment forum - Education with Entertainment!

nofapturkiye

can i write my own game and make users play with it  via arcade mode?

vbgamer45

Yes you could the system currently supports flash based games.
Community Suite for SMF - Take your forum to the next level built for SMF, Gallery,Store,Classifieds,Downloads,more!

SMFHacks.com -  Paid Modifications for SMF

Mods:
EzPortal - Portal System for SMF
SMF Gallery Pro
SMF Store SMF Classifieds Ad Seller Pro

Steve

If you're using the latest arcade beta then keep in mind that:

QuoteGeneral flash games are supported without score support
Please do not PM me for support.

landyvlad

OK so the mod states that it was last updated 2010, and is compatible with SMF  2.0 RC3

I have seen it running on 2.1 beta4 so I assume that it's more or less a stand-alone thing so the mod, while dated, hasn't required any changes and remains compatible?

The link in the OP of the mod www.smfarcade.info doesn't seem to work any longer.

So any tips/info re installing this mod nowadays would be welcomed, including where to obtain the games.

Ta. 


Please do not PM, IM or Email me with questions on astrophysics or theology.  You will get better and faster responses by asking homeless people in the street. Thank you.

The funniest thing about this particular signature is that by the time you realise it doesn't say anything it's too late to stop reading it

Bigguy

You can get an updated version here:

https://web-develop.ca/

Same one I run.

Biology Forums

Quote from: Bigguy on June 27, 2018, 10:26:52 PM
You can get an updated version here:

https://web-develop.ca/

Same one I run.

Does it support HTML5?

landyvlad

Thanks bigguy just saw your response on the WUB forum as well :)
Please do not PM, IM or Email me with questions on astrophysics or theology.  You will get better and faster responses by asking homeless people in the street. Thank you.

The funniest thing about this particular signature is that by the time you realise it doesn't say anything it's too late to stop reading it

Bigguy

Quote from: Study Force on June 27, 2018, 11:48:19 PM
Quote from: Bigguy on June 27, 2018, 10:26:52 PM
You can get an updated version here:

https://web-develop.ca/

Same one I run.

Does it support HTML5?

I think so yes. But you can ask there to be sure.

PANIC!

I downloaded games, but when I go to play them, I get a blank page. I downloaded the version that bigguy shared.

Ronald_1938

Quote from: Study Force on June 27, 2018, 11:48:19 PM
Quote from: Bigguy on June 27, 2018, 10:26:52 PM
You can get an updated version here:

https://web-develop.ca/

Same one I run.

Does it support HTML5?

Yes it does. I gave some HTML5 games..

addlife

I installed the mod that bigguy posted from web-develop.ca

When clicking on the arcade admin settings to edit games, manage installations, and manage uploads it gives me this error

"Too few arguments to function mb_substr(), 2 passed in /home/xyz1/public_html/Sources/Subs-ArcadeAdmin.php on line 2244 and exactly 3 expected"

my site is 001002.xyz
and I attached the file mentioned

Any ideas how I can fix it?
Thanks.

Ronald_1938

Quote from: addlife on March 17, 2019, 01:05:53 AM
I installed the mod that bigguy posted from web-develop.ca

When clicking on the arcade admin settings to edit games, manage installations, and manage uploads it gives me this error

"Too few arguments to function mb_substr(), 2 passed in /home/xyz1/public_html/Sources/Subs-ArcadeAdmin.php on line 2244 and exactly 3 expected"

my site is 001002.xyz
and I attached the file mentioned

Any ideas how I can fix it?
Thanks.

With out getting myself in trouble on this forum, I'd advise to to go to https://web-develop.ca/ register for an account, and post there. Chen is the person who is working this arcade..Chen has the answers, and will work with you and getting it up and going.

addlife

Quote from: Oldcrow on March 17, 2019, 12:04:25 PM
Quote from: addlife on March 17, 2019, 01:05:53 AM
I installed the mod that bigguy posted from web-develop.ca

When clicking on the arcade admin settings to edit games, manage installations, and manage uploads it gives me this error

"Too few arguments to function mb_substr(), 2 passed in /home/xyz1/public_html/Sources/Subs-ArcadeAdmin.php on line 2244 and exactly 3 expected"

my site is 001002.xyz
and I attached the file mentioned

Any ideas how I can fix it?
Thanks.

With out getting myself in trouble on this forum, I'd advise to to go to https://web-develop.ca/ register for an account, and post there. Chen is the person who is working this arcade..Chen has the answers, and will work with you and getting it up and going.
ok thanks

4everBlue

I'm having a prob, with 1.0.3- dl'd it with the package manager, but the arcade won't install, I just get a page of errors... what do I do?

Ronald_1938

Quote from: 4everBlue on March 21, 2019, 07:52:03 AM
I'm having a prob, with 1.0.3- dl'd it with the package manager, but the arcade won't install, I just get a page of errors... what do I do?

Here is the latest version: https://web-develop.ca/index.php?action=downloads;area=stable_smf_arcade

4everBlue

Quote from: Oldcrow on March 21, 2019, 08:45:53 AM
Quote from: 4everBlue on March 21, 2019, 07:52:03 AM
I'm having a prob, with 1.0.3- dl'd it with the package manager, but the arcade won't install, I just get a page of errors... what do I do?

Here is the latest version: https://web-develop.ca/index.php?action=downloads;area=stable_smf_arcade

Thank you.

addlife

I had a problem after installing version 2.56.12 from web-develop.ca

When clicking on the arcade admin settings to edit games, manage installations, and manage uploads it gives me this error

"Too few arguments to function mb_substr(), 2 passed in /home/xyz1/public_html/Sources/Subs-ArcadeAdmin.php on line 2244 and exactly 3 expected"

I posted this on the forums of that site and chen zen answered me with this

Quote
If I remember correctly, substr was swapped out with mb_substr a while back but the length parameter was not added.
Odd thing is that I do not get this error.

The PHP manual shows that length and char encoding have defaults if not included.
ref. https://www.php.net/manual/en/function.mb-substr.php

I attached your file with that function edited to include the length parameter.

What PHP version are you using?

So I replaced that file but now I get the same error on line 2161. (I'm using php 7.1)

I replied to chen zen there but he still didn't reply after a week or so and the post didnt get approved by a mod yet so I'm asking here again if anybody can see what the problem is.

My test site is 001002.xyz

I attached the original file version and the one chen zen modified

Thanks.

TurtleKicker

Has anyone tested this on SMF 2.1 RC2?

Ronald_1938

Quote from: TurtleKicker on April 11, 2019, 01:29:35 PM
Has anyone tested this on SMF 2.1 RC2?

I did a fresh install of RC2, install the arcade, and one game pack. I had no problems at all..Played one game. I had to install Adobe Flash and enable Javascript before I could play..

I don't really play this arcade, simply because I have a Arcade Forum, but I use the older version of IPB and a different arcade..

Advertisement: