Advertisement:

Author Topic: posts missing after converting Yabb 2.3.1 to SMF 1.1.8  (Read 17696 times)

Offline ozzyfan

  • Newbie
  • *
  • Posts: 5
posts missing after converting Yabb 2.3.1 to SMF 1.1.8
« on: March 12, 2009, 01:40:13 AM »
When I try to convert Yabb 2.3.1 to SMF 1.1.8 I get this message:
Converting...
Successful.
Converting membergroups... Successful.
Converting members... Successful.
Converting settings...
Notice: Undefined index: userpic_width in /is/htdocs/43139/www.***/smf/yabb22_to_smf.php on line 441

Notice: Undefined index: userpic_height in /is/htdocs/43139/www.***/smf/yabb22_to_smf.php on line 442

Notice: Undefined index: userpic_width in /is/htdocs/43139/www.***/smf/yabb22_to_smf.php on line 443

Notice: Undefined index: userpic_height in /is/htdocs/43139/www.***/smf/yabb22_to_smf.php on line 444
Successful.
Converting posts (part 1 - this may take some time)... Successful.
Converting posts (part 2)... Successful.
Converting attachments (if the mod is installed)... Successful.
Cleaning up... Successful.
Converting polls and poll choices (part 1)... Successful.
Converting polls and poll choices (part 2)... Successful.
Converting poll votes... Successful.
Recalculating forum statistics... Successful.

Conversion Complete

Seems the conversion was successful (except the values of the userpic width and height), but some topics and posts have vanished into thin air.
In my YaBB:
Our users have made 68944 Posts within 1366 Topics.
We have 1153 registered members.

In my SMF:
67090 Posts in 1175 Topics by 1153 Members.

As you can see there are missing 1954 posts and 191 topics, where they're disappeared?
Next thing, I'm looking into some topics and some of the message counts are showing there are all 0 (zero). For example in YaBB is a topic with 1595 views and 590 replies, the same topic in SMF after conversion has 0 views and 590 replies. Some topics have the correct views but 0 replies although there are the right posts in the topic. I haven't a clue what's going wrong during the conversion.

Then I was looking at the memberlist and some profiles. Great surprise, all members have the same age (39) because the date of birth was set to 1. Jan. 1970 :D

I used the yabb22_to_smf.php from here:
http://www.simplemachines.org/community/index.php?topic=249777.0
and the convert.php from here:
http://www.simplemachines.org/community/index.php?topic=140741.0

So what should I do? Any help would be much appreciated.

ThorstenE

  • Guest
Re: posts missing after converting Yabb 2.3.1 to SMF 1.1.8
« Reply #1 on: March 12, 2009, 03:02:17 AM »
Our converter is for YaBB 2.2, your YaBB is 2.3... I've never tested the converter with a YaBB 2.3, maybe there is a difference in the topics / messages structure.. Do you know which posts are missing? (maybe only stickies, announcements, messages with polls?)

for the birthdates: can you attach one of the members files? I think row has changed from YaBB 2.2 to YaBB 2.3 and our converter will take the content from the wrong row.

Offline ozzyfan

  • Newbie
  • *
  • Posts: 5
Re: posts missing after converting Yabb 2.3.1 to SMF 1.1.8
« Reply #2 on: March 12, 2009, 07:41:26 PM »
I know that the converter is for YaBB 2.2, but some guys tried this one for YaBB 2.3 and it worked. We have only the backup from our YaBB 2.3.1 and I can't install any earlier version of  YaBB 2.3 with this backup.

The missing posts are not stickies, announcements, messages with polls. We have a public area for guests and one for members. the guest area seems  ok, but the member area missing some posts/topics. Did you think that's because some topics can only viewed by special members?

The birthday thing is not so important for me, only a little cosmetically problem. Attached zip is the test.var I've created in YaBB 2.3.1.

Can you move this topic into the german subforum? Maybe I can then explain the problem better  :)

Ozzyfan

ThorstenE

  • Guest
Re: posts missing after converting Yabb 2.3.1 to SMF 1.1.8
« Reply #3 on: March 13, 2009, 02:19:37 AM »
Feel free to PM me in german (my native language).. ;)

Offline ozzyfan

  • Newbie
  • *
  • Posts: 5
Re: posts missing after converting Yabb 2.3.1 to SMF 1.1.8
« Reply #4 on: March 13, 2009, 02:01:00 PM »
OK, I just got a new backup and try it again with this one.

Ozzyfan

Offline ozzyfan

  • Newbie
  • *
  • Posts: 5
Re: posts missing after converting Yabb 2.3.1 to SMF 1.1.8
« Reply #5 on: March 14, 2009, 11:10:05 PM »
I installed now a fresh YaBB 2.2 with my new backup (YaBB 1.4) and converted the 1.4 to 2.2. Then I tried the conversion with the converter from your download area, after a while got these errors:
Code: [Select]
Converting...
Successful.
Converting membergroups... Successful.
Converting members... Successful.
Converting settings... Successful.
Converting personal messages (part 1)... Successful.
Successful.
Converting boards and categories...<br />
<b>Notice</b>:  Undefined index:  10 in <b>/is/htdocs/43139/www.***/smf/yabb22_to_smf.php</b> on line <b>782</b><br />
<br />
<b>Notice</b>:  Undefined index:  10 in <b>/is/htdocs/43139/www.***/smf/yabb22_to_smf.php</b> on line <b>784</b><br />
<br />
<b>Notice</b>:  Undefined index:  10 in <b>/is/htdocs/43139/www.***/smf/yabb22_to_smf.php</b> on line <b>782</b><br />
<br />
<b>Notice</b>:  Undefined index:  10 in <b>/is/htdocs/43139/www.***/smf/yabb22_to_smf.php</b> on line <b>784</b><br />
<br />
<b>Notice</b>:  Undefined index:  2 in <b>/is/htdocs/43139/www.***/smf/yabb22_to_smf.php</b> on line <b>782</b><br />
<br />
<b>Notice</b>:  Undefined index:  2 in <b>/is/htdocs/43139/www.***/smf/yabb22_to_smf.php</b> on line <b>784</b><br />
<br />
<b>Notice</b>:  Undefined index:  3 in <b>/is/htdocs/43139/www.***/smf/yabb22_to_smf.php</b> on line <b>782</b><br />
<br />
<b>Notice</b>:  Undefined index:  3 in <b>/is/htdocs/43139/www.***/smf/yabb22_to_smf.php</b> on line <b>784</b><br />
<br />
<b>Notice</b>:  Undefined index:  6 in <b>/is/htdocs/43139/www.***/smf/yabb22_to_smf.php</b> on line <b>782</b><br />
<br />
<b>Notice</b>:  Undefined index:  6 in <b>/is/htdocs/43139/www.***/smf/yabb22_to_smf.php</b> on line <b>784</b><br />
 Successful.<br />

OK, not so bad, but then:
Code: [Select]
Converting topics (part 1)...<br />
<b>Notice</b>:  Undefined variable:  userData in <b>/is/htdocs/43139/www.***/smf/yabb22_to_smf.php</b> on line <b>863</b><br />
<br />
<b>Notice</b>:  Undefined variable:  i in <b>/is/htdocs/43139/www.***/smf/yabb22_to_smf.php</b> on line <b>863</b><br />
<br />
<b>Notice</b>:  Undefined variable:  userData in <b>/is/htdocs/43139/www.***e/smf/yabb22_to_smf.php</b> on line <b>863</b><br />
<br />
<b>Notice</b>:  Undefined variable:  i in <b>/is/htdocs/43139/www.***/smf/yabb22_to_smf.php</b> on line <b>863</b><br />
<br />
<b>Notice</b>:  Undefined variable:  userData in <b>/is/htdocs/43139/www.***/smf/yabb22_to_smf.php</b> on line <b>863</b><br />
<br />
<b>Notice</b>:  Undefined variable:  i in <b>/is/htdocs/43139/www.***/smf/yabb22_to_smf.php</b> on line <b>863</b><br />
... and so on, I think more than 300 lines.
After the conversion was complete (with any other errors):
Code: [Select]
Successful.
Converting posts (part 1 - this may take some time)... Successful.
Converting posts (part 2)... Successful.
Converting attachments (if the mod is installed)... Successful.
Cleaning up... Successful.
Converting polls and poll choices (part 1)... Successful.
Converting polls and poll choices (part 2)... Successful.
Converting poll votes... Successful.
Recalculating forum statistics... Successful.

Conversion Complete
I logged in and take a look into my converted SMF. There was still missing some topics and posts in the memberarea, e.g.:
YaBB 2.2
Foto-Kiste(Zutritt erst ab dem 10. Beitrag)
4862 posts / 48 topics
SMF
Foto-Kiste(Zutritt erst ab dem 10. Beitrag)
3402 posts / 27 topics

YaBB 2.2
Ratgeber-Ecke
4045 posts / 219 topics
SMF
Ratgeber-Ecke
4038 posts / 219 topics

YaBB 2.2
Ratgeber-Gesundheit
2443 posts / 593 topics
SMF
Ratgeber-Gesundheit
2049 posts / 423 topics

Most topics (in all categrories) have the correct views but 0 replies, some have 0 views and 0 replies. I clicked in "Forum Maintenance - General Maintenance" at "Find and repair any errors." and almost all topics have the correct replies but still 0 views.
The converter has also dig up some old deleted post/topics, I thought LMAA :D
If I do the conversion online or at my local machine, that doesn't make any difference, both with the same errors. Anybody with any suggestions?

Ozzyfan

Offline SleePy

  • Site Team Lead
  • SMF Master
  • *
  • Posts: 30,341
  • Gender: Male
  • Thats his happy face.
    • jdarwood007 on GitHub
    • @jdarwood on Twitter
    • SleePy Code - My personal site
Re: posts missing after converting Yabb 2.3.1 to SMF 1.1.8
« Reply #6 on: March 20, 2009, 06:00:13 PM »
In Yabb 2.2,
The views for a topic was held in a xxx.ctb file in the messages foler. the xxx pertained to the messages id.

Is this still true for Yabb 2.3?

Those errors you got don't make sense. What File do you have? userData isn't used at all in that converter setp you got the error on.
Jeremy D — Site Team / SMF Developer
Support the SMF Support team!
Profiles:
GitHub

Offline ozzyfan

  • Newbie
  • *
  • Posts: 5
Re: posts missing after converting Yabb 2.3.1 to SMF 1.1.8
« Reply #7 on: March 25, 2009, 02:51:55 AM »
Is this still true for Yabb 2.3?
I think so, here is an exemple:
YaBB 2.0 - 1133440095.ctb:
Code: [Select]
401
868
871
admin
1230250453

YaBB 2.2 - 1133440095.ctb:
Code: [Select]
### ThreadID: 1133440095, LastModified: Fri, 13 Mar 2009 23:10:02 +0000 ###

'board',"401"
'replies',"868"
'views',"871"
'lastposter',"admin"
'lastpostdate',"1230246853"
'threadstatus',""
'repliers',""

YaBB 2.3.1 - 1133440095.ctb:
Code: [Select]
### ThreadID: 1133440095, LastModified: Sun, 08 Mar 2009 09:26:26 +0000 ###

'board',"401"
'replies',"868"
'views',"871"
'lastposter',"admin"
'lastpostdate',"1230246853"
'threadstatus',""
'repliers',""

First I tried the converter from your downloads
http://download.simplemachines.org/index.php?thanks;filename=smf_1-1-8_yabb22_converter.zip
then I used the yabb22_to_smf.php from here:
http://www.simplemachines.org/community/index.php?topic=249777.0
and the convert.php from here:
http://www.simplemachines.org/community/index.php?topic=140741.0

ThorstenE

  • Guest
Re: posts missing after converting Yabb 2.3.1 to SMF 1.1.8
« Reply #8 on: March 25, 2009, 07:36:17 AM »
the main issue: the missing posts have names with 12 characters  (e.g. 113344009501.ctb) and our converter can only handle files with 10 characters in the name (1133440095.ctb), I have an idea how to solve this but I'm currently very busy and cannot work on the converter in the next days ..