Advertisement:

Author Topic: RC1 forum slow  (Read 30787 times)

Offline DirtRider

  • SMF Hero
  • ******
  • Posts: 1,415
  • Gender: Male
  • Just Looking
    • TriumphTalk
RC1 forum slow
« on: May 05, 2009, 09:48:03 AM »
Ever since we have upgraded to RC1 I have some of my member complaining that the forum is so slow compared to what it was. These member are using Firefox  ??? I am at a total loss as what I can do about this issue as the page load time seems to be ok but the actual load time in FF is slow
« Last Edit: May 30, 2009, 03:21:20 AM by DirtRider »
http://www.triumphtalk.com

"The real question is not whether machines think but whether men do. "

Offline DirtRider

  • SMF Hero
  • ******
  • Posts: 1,415
  • Gender: Male
  • Just Looking
    • TriumphTalk
Re: RC1 forum slow
« Reply #1 on: May 06, 2009, 11:59:57 PM »
Any ideas on this anyone  :'(
http://www.triumphtalk.com

"The real question is not whether machines think but whether men do. "

Offline Something like that

  • SMF Friend
  • SMF Hero
  • *
  • Posts: 2,496
  • Gender: Male
  • ]
Re: RC1 forum slow
« Reply #2 on: May 07, 2009, 12:57:54 AM »
What version did you upgrade from? So the page generation time is good? (Sub 300 ms?)

What pages are slow? All of them? Or just some?

Offline DirtRider

  • SMF Hero
  • ******
  • Posts: 1,415
  • Gender: Male
  • Just Looking
    • TriumphTalk
Re: RC1 forum slow
« Reply #3 on: May 07, 2009, 01:32:51 AM »
Upgraded from 1.1.8 the page creation time is around "Page created in 0.233 seconds with 34 queries.". The whole forum is being reported as slow but only by some members using FireFox. This only started when FF upgraded together with this popup issue http://www.simplemachines.org/community/index.php?topic=293422.0. SO this is an issue with FF and SMF. We have tried disabling all add ons in FF with no difference in speed. This member finds that IE is loading the pages faster than FF  :-[

He is also reporting that this is an issue on any SMF RC1 forum but has not problems on other forums. 
« Last Edit: May 07, 2009, 01:46:44 AM by DirtRider »
http://www.triumphtalk.com

"The real question is not whether machines think but whether men do. "

Offline Hell Raiser

  • Jr. Member
  • **
  • Posts: 384
  • Gender: Male
Re: RC1 forum slow
« Reply #4 on: May 07, 2009, 01:40:13 AM »
Bro have you asked about this to your host abd which host you are using?
Need Help with SMF ? Ask me may be i can help you out




Offline DirtRider

  • SMF Hero
  • ******
  • Posts: 1,415
  • Gender: Male
  • Just Looking
    • TriumphTalk
Re: RC1 forum slow
« Reply #5 on: May 07, 2009, 01:47:53 AM »
No it is not a host issue as it is only affecting some members see my reply above
http://www.triumphtalk.com

"The real question is not whether machines think but whether men do. "

Offline 青山 素子

  • Server Team
  • SMF Super Hero
  • *
  • Posts: 17,073
  • 戦場ヶ原、蕩れ!
    • srvrguy on GitHub
    • @motokochan on Twitter
    • Nekomusume Moe
Re: RC1 forum slow
« Reply #6 on: May 07, 2009, 10:23:32 AM »
34 queries is a lot. What kind of modifications are you using?
Motoko-chan
Director, Simple Machines

Note: Unless otherwise stated, my posts are not representative of any official position or opinion of Simple Machines.


Offline DirtRider

  • SMF Hero
  • ******
  • Posts: 1,415
  • Gender: Male
  • Just Looking
    • TriumphTalk
Re: RC1 forum slow
« Reply #7 on: May 07, 2009, 11:50:47 AM »
Here are my mods these are the same I was using with 1.1.8 and it was fast. As I say this is not all members and only those using the latest version of Firefox/3.0.10. that same member is having the slow issue here as well  ???.

    Mod Name     Version     
1.    Latest Members RC1    1.1    [ Uninstall ] [ List Files ] [ Delete ]
2.    Share this topic SMF Mod    1.1    [ Uninstall ] [ List Files ] [ Delete ]
3.    PM Readed    1.0    [ Uninstall ] [ List Files ] [ Delete ]
4.    Heading to Category    1.0    [ Apply Mod ] [ List Files ] [ Delete ]
5.    RSS Feeder    1.1.1    [ Uninstall ] [ List Files ] [ Delete ]
6.    Welcome Topic Mod    2.0.2    [ Uninstall ] [ List Files ] [ Delete ]
7.    BBC [you]    1.2    [ Uninstall ] [ List Files ] [ Delete ]
8.    Global Topics    1.0    [ Uninstall ] [ List Files ] [ Delete ]
9.    Downloads System    1.2.1    [ Uninstall ] [ List Files ] [ Delete ]
10.    Add IP2Location to Track IP    1.0    [ Uninstall ] [ List Files ] [ Delete ]
11.    Aligned and Bilateral Child Boards    1.4    [ Uninstall ] [ List Files ] [ Delete ]
12.    SMF Gallery Pro    1.4.5    [ Uninstall ] [ List Files ] [ Delete ]
13.    PortaMx v0.957    0.957    [ List Files ] [ Delete ]
14.    Aeva ~ Auto-Embed Video & Audio    5.2.56    [ Uninstall ] [ List Files ] [ Delete ]
15.    Users Online Today    1.5.4    [ Uninstall ] [ List Files ] [ Delete ]
16.    SMF Affiliates    v2    [ Uninstall ] [ List Files ] [ Delete ]
17.    SMF Gallery Pro Upgrade    2.0.5.2    [ List Files ] [ Delete ]
18.    Stop Spammer    2.2    [ Apply Mod ] [ List Files ] [ Delete ]
19.    MCLegendII RC1    3.0    [ Uninstall ] [ List Files ] [ Delete ]
20.    Choose Ignorable Boards    1    [ Uninstall ] [ List Files ] [ Delete ]
21.    PortaMx v0.957 Rev1    0.957r1    [ List Files ] [ Delete ]
22.    TextSizer    1.0    [ Uninstall ] [ List Files ] [ Delete ]
23.    PortaMx v0.957 Rev2    0.957r2    [ Uninstall ] [ List Files ] [ Delete ]
24.    Advanced Contact Form    1.1    [ Uninstall ] [ List Files ] [ Delete ]
25.    Last Active On MemberList    1.01    [ Uninstall ] [ List Files ] [ Delete ]
26.    Ad Managment    2.3.4    [ Uninstall ] [ List Files ] [ Delete ]
27.    Auto Email Inactive Users    1.7    [ Uninstall ] [ List Files ] [ Delete ]
28.    PM to New Members    1.0    [ Uninstall ] [ List Files ] [ Delete ]
29.    MessagePreviewOnHover    1.7    [ Uninstall ] [ List Files ] [ Delete ]
30.    EmailFlash    2.0    [ Uninstall ] [ List Files ] [ Delete ]
31.    PortaMx v0.956    0.956    
http://www.triumphtalk.com

"The real question is not whether machines think but whether men do. "

Offline CarlT100

  • Semi-Newbie
  • *
  • Posts: 54
  • Gender: Male
    • Triumph Talk
Re: RC1 forum slow
« Reply #8 on: May 07, 2009, 01:09:02 PM »
I am not a programmer; so I don't have a clue as to what the causes are.   I am running Firefox 3.0.30 on XP Professional SP2.  When our forum upgraded to to RC1 was running the first release of Firefox 3.0.  I noticed immediately that my page loading times which ran around 3 to 7 seconds per page increased to 17 - 14 seconds per page.  If a PM pop up notification kicks in, the loading times will go to the 30 to 45 second range.  I experience the same on any SM RC1 forum including this one. Other forums which I visit regularly do not have this slow down.  I can be on another forum at the same time I am on an SMF forum and the SMF forum is slow whaile the other forum is not.

When I first log in to the SMF forum, it is relatively fast - 3 to 7 seconds per page.  The longer I am logged in, the slower the page loading.  IE6 is faster loading SMF pages than Firefox.  I have disabled all Firefox addons and disabled Adblock aand added them back one at a time.  there was only a second or two difference in page loading times and that was caused by YSlow.

It is not just Firefox, my ISP, or connection speed as other forum software do not experience a slow down.  Even the NOAA weather site with all of its graphics is much faster loading than any RC1 page.
CarlT100


Offline DirtRider

  • SMF Hero
  • ******
  • Posts: 1,415
  • Gender: Male
  • Just Looking
    • TriumphTalk
Re: RC1 forum slow
« Reply #9 on: May 22, 2009, 10:45:56 AM »
This issue is still outstanding  :'(
http://www.triumphtalk.com

"The real question is not whether machines think but whether men do. "

Offline Vekseid

  • Full Member
  • ***
  • Posts: 548
  • Gender: Male
    • Elliquiy Adult Role Playing Forums
Re: RC1 forum slow
« Reply #10 on: May 22, 2009, 11:46:19 AM »
Some of those mods are outdated, you may wish to see if any of them are updated, and remove ones that you find you don't really need or are redundant.

The firefox problem is easily solved by moving the relevant javascript to your footer in index.template.php:

Code: [Select]
function template_html_below()
{
global $context, $settings, $options, $scripturl, $txt, $modSettings;

  if ($context['show_pm_popup'])
    {
      echo '<script language="JavaScript" type="text/javascript">
  if (confirm("' . $txt['show_personal_messages'] . '"))
    window.open(smf_prepareScriptUrl(smf_scripturl) + "action=pm");
</script>';
    }
 
echo '</body></html>';
}

And remove that call from your header.

Adult Role Playing Forums - - Over five million posts - - Elliquiy's LAMP configuration (maybe NSFW)

Blog about Forums and Servers - - Twenty things to make Simple Machines Forum go faster

Private/Instant Message requests for free support will be ignored.

Offline CarlT100

  • Semi-Newbie
  • *
  • Posts: 54
  • Gender: Male
    • Triumph Talk
Re: RC1 forum slow
« Reply #11 on: May 22, 2009, 12:47:18 PM »
Thank you, Sir.  I'll make sure Dirt Rider sees this.
CarlT100


Offline DirtRider

  • SMF Hero
  • ******
  • Posts: 1,415
  • Gender: Male
  • Just Looking
    • TriumphTalk
Re: RC1 forum slow
« Reply #12 on: May 22, 2009, 02:15:59 PM »
Some of those mods are outdated, you may wish to see if any of them are updated, and remove ones that you find you don't really need or are redundant.

The firefox problem is easily solved by moving the relevant javascript to your footer in index.template.php:

Code: [Select]
function template_html_below()
{
global $context, $settings, $options, $scripturl, $txt, $modSettings;

  if ($context['show_pm_popup'])
    {
      echo '<script language="JavaScript" type="text/javascript">
  if (confirm("' . $txt['show_personal_messages'] . '"))
    window.open(smf_prepareScriptUrl(smf_scripturl) + "action=pm");
</script>';
    }
 
echo '</body></html>';
}

And remove that call from your header.

Do you mean you need to do this in all the themes index.template.php or just the default theme
http://www.triumphtalk.com

"The real question is not whether machines think but whether men do. "

Offline Vekseid

  • Full Member
  • ***
  • Posts: 548
  • Gender: Male
    • Elliquiy Adult Role Playing Forums
Re: RC1 forum slow
« Reply #13 on: May 22, 2009, 05:24:24 PM »
Whatever theme you are using. Pretty much all themes have their own index.template.php, so they will need the change in order to work properly in firefox. Don't forget to remove the relevant portion from the header.
Adult Role Playing Forums - - Over five million posts - - Elliquiy's LAMP configuration (maybe NSFW)

Blog about Forums and Servers - - Twenty things to make Simple Machines Forum go faster

Private/Instant Message requests for free support will be ignored.

Offline CarlT100

  • Semi-Newbie
  • *
  • Posts: 54
  • Gender: Male
    • Triumph Talk
Re: RC1 forum slow
« Reply #14 on: May 22, 2009, 05:41:00 PM »
DirtRider, why don't you just experiment with the theme I use?  If it doesn't work or something screws up, it will only affect those of us who use that particular theme.  If it works, you can then change the themes of folks who are having slowdowns and problems with the PM popup.
CarlT100


Offline Something like that

  • SMF Friend
  • SMF Hero
  • *
  • Posts: 2,496
  • Gender: Male
  • ]
Re: RC1 forum slow
« Reply #15 on: May 22, 2009, 05:55:17 PM »
Disable post moderation. It should improve things.

Offline DirtRider

  • SMF Hero
  • ******
  • Posts: 1,415
  • Gender: Male
  • Just Looking
    • TriumphTalk
Re: RC1 forum slow
« Reply #16 on: May 24, 2009, 05:25:42 AM »
Ok this is what I have done so far.

1. Disabled post moderation
2. Remover all unnecessary mods and updated others

However I cannot see any remarkable change in the speed. Here is a video showing how slow it actually is. When you see the red flashing circulars over the lounge this is when I click on it  ::)

http://www.youtube.com/watch?v=-RyP6YSvPlY
http://www.triumphtalk.com

"The real question is not whether machines think but whether men do. "

Offline Vekseid

  • Full Member
  • ***
  • Posts: 548
  • Gender: Male
    • Elliquiy Adult Role Playing Forums
Re: RC1 forum slow
« Reply #17 on: May 24, 2009, 10:10:39 AM »
I'm receiving no such slowdown in Firefox. Have you converted tables to InnoDB and followed my suggestions in the sticky at the top of this forum?
Adult Role Playing Forums - - Over five million posts - - Elliquiy's LAMP configuration (maybe NSFW)

Blog about Forums and Servers - - Twenty things to make Simple Machines Forum go faster

Private/Instant Message requests for free support will be ignored.

Offline DirtRider

  • SMF Hero
  • ******
  • Posts: 1,415
  • Gender: Male
  • Just Looking
    • TriumphTalk
Re: RC1 forum slow
« Reply #18 on: May 24, 2009, 10:46:02 AM »
I'm receiving no such slowdown in Firefox. Have you converted tables to InnoDB and followed my suggestions in the sticky at the top of this forum?

Um not sure about this "converted tables to InnoDB" I did try your code change but it did not improve the speed at all.

I am now starting to think that this is not just a FF issue but alos related to what security software you may be running (Norton , McAfee and so on)

In this video I have McAfee installed

http://www.youtube.com/watch?v=-RyP6YSvPlY&feature=channel_page

Here I have nothing installed

http://www.youtube.com/watch?v=d3fzUPdkktM&feature=channel_page

And Here I have Trend installed

http://www.youtube.com/watch?v=4-RCHe9wMWI&feature=channel_page

Now all the above do not seem to have any affect on the speed when tested on other forum software 
http://www.triumphtalk.com

"The real question is not whether machines think but whether men do. "

Offline CarlT100

  • Semi-Newbie
  • *
  • Posts: 54
  • Gender: Male
    • Triumph Talk
Re: RC1 forum slow
« Reply #19 on: May 24, 2009, 12:00:14 PM »
I just visited the site and tried a couple of random pages. In each case the page generation time was under half a second, with the overall page being presented in about 2-3 seconds.

If it's still persisting, what are the kinds of values for the 'Page created in 0.272 seconds with 22 queries.' bit at the bottom, and which pages do they occur on?

The speeds you are seeing for pages generated are not the real speeds in which the viewer sees the pages.  I get the same readings as you experienced; but in reality the the actual speed is are anywhere from 15 to 25 seconds - and higher.  The issue appears to between Firefox and RC1.  I belong to nine other forums that I visit regularly.  Two of these are RC1 forums and it sis the same for both.  This forum is faster than ours because we have a lot more graphics and such.  However, this one has the same type of slowdown.  No other forums, including three Delphi forums, do I have a slowdown at all.  IE6 is faster than Firefox for RC1 forums.  I had no problem until we upgraded to RC1.

From this I conclude it is not my computer nor is it just Firefox. 
CarlT100