• Welcome to Simple Machines Community Forum. Please login or sign up.
December 06, 2021, 01:33:27 AM

News:

Wondering if this will always be free?  See why free is better.


Post History

Started by niko, May 23, 2009, 01:02:36 AM

Previous topic - Next topic

MordyT

tagged. Thanks for the great mod!
Want to see SMF in action? Head over to RvOClan.info

Kolya

March 23, 2010, 03:50:57 AM #81 Last Edit: March 23, 2010, 04:06:12 AM by Kolya
Quote from: Niko on March 20, 2010, 02:01:31 PM
Quote from: Eliana Tamerin on March 14, 2010, 02:49:20 PM
Getting white pages for some comparisons. Haven't been able to pin down a reason, though. Nothing in the error logs when it happens.

Haven't had time to try to reproduce

Apparently it cannot handle posts that contain quotes in the last version.


Unrelated to this, I'm still very interested in a post-centric permission to show the history to anyone (as opposed to view history in the current user-centric permission system). Like a check-box when posting.

Eliana Tamerin

I've had it occur on posts which do not include quotes.
Do NOT PM me for support.

SimplePortal 2.3.6 is OUT!
SimplePortal Project Manager
Download | Docs
SimplePortal: Power of Simplicity!

Kolya

That might well be. All I checked was that I could reliably reproduce the error when the latest version of the post contained a quote.
There might still be other ways to trigger this bug, eg a code section or something completely different.

flapjack

any chance updating it the way so it will allow to add to custom theme?

Eliana Tamerin

You can already add it to a custom theme, that's built into SMF 2. If the mod won't install on a particular theme, then you'll have to manually install it there, or look for support on that theme's support topic.
Do NOT PM me for support.

SimplePortal 2.3.6 is OUT!
SimplePortal Project Manager
Download | Docs
SimplePortal: Power of Simplicity!

flapjack

for some reason this particular one doesn't give me that option

Kolya

Quote from: Niko on March 20, 2010, 02:01:31 PM
Quote from: Eliana Tamerin on March 18, 2010, 04:11:07 PM
Niko, miss this one? Or can't reproduce?

Quote from: Eliana Tamerin on March 14, 2010, 02:49:20 PM
Quote from: Niko on March 13, 2010, 02:52:53 PM
0.3 Released with RC3 support!

Getting white pages for some comparisons. Haven't been able to pin down a reason, though. Nothing in the error logs when it happens.

Haven't had time to try to reproduce

Any updates on this problem?

Enders

Quote from: flapjack on April 05, 2010, 08:53:45 PM
any chance updating it the way so it will allow to add to custom theme?

Definately.... Just copy and paste "PostHistory.template.php" from the themes/default to your themes folder.

Kolya

This mod still installs on SMF 2.0 RC4 with just a minor change:
In package-info.xml change the line: <install for="2.0 RC3"> to reflect the new version RC4.

If you already had the mod installed before the database tables already exist and you want to comment out the table creation in post_history/install.php like so: //doTables($tables);

So the mod still works, however the comparison bug where it just shows a white page on some comparisons also still exists. Would be really cool if you could have a look at this Niko.

dmacleo

this was one of the more important mods I used, I will try that fix to see.

Kolya

It's important for my for forum as well and I don't understand why this isn't getting more attention.
This should be an option in the core build. It's that important. Because it's about preserving the most precious thing on any forum: The content generated by the users.
vBB has this option. SMF has a mod, with patchy functionality and support.

WillyP

It seems to be working ok for me, I've tested it on rc3 and rc4, but haven't put it out on a live site yet.

Spoogs

works just fine on live sites too ;)

WillyP

After installing, then logging in... must reset password to log in again.  Any thoughts on this?  Tried on a number of different test servers, including rc3 and 4.

niko

Quote from: WillyP on December 14, 2010, 09:57:46 AM
After installing, then logging in... must reset password to log in again.  Any thoughts on this?  Tried on a number of different test servers, including rc3 and 4.

Any other mods? I can't see why this mod would cause that... it doesn't edit anything expect post/display pages.
Websites: Madjoki || (2 links retracted by team, links out of date and taken over.)
Mods: SMF Arcade, Related topics, SMF Project Tools, Post History

WIP Mods: Bittorrent Tracker || SMF Wiki

WillyP

No, clean sites I made just to test this.

PLAYBOY

Is there anyway to make it for 1.1.12?

ChaosEnergy

will there be a rc5 version?
Chaos Empire ®

f_aston



I changed the .xml file to reflect version RC5.  It's installed fine and seems to be functioning perfectly.


I'll give an update if anything goes wrong, but it all looks good!  :)

Advertisement: