• Welcome to Simple Machines Community Forum. Please login or sign up.

Upgrade database error [SMF1.1.8 TO SMF1.1.9]

Started by SFF Forum, May 25, 2009, 03:43:13 PM

Previous topic - Next topic

SFF Forum

Hello,

I was going to upgrade  my database with upgrade.php.but failed.No mods in my forum.
QuoteThe upgrader found some old or outdated language files.

Please make certain you uploaded the new versions of all the files included in the package, even the theme and language files for the default theme.


What's wrong with it?
I Love Simple Machines Forum .

kat

Have you tried to do it via Package Manager?

own3mall


SFF Forum

May 25, 2009, 04:51:38 PM #3 Last Edit: May 25, 2009, 04:56:02 PM by bosser
I creat a new forum in my PC,and also fail to upgrade database

I used smf_patch_1.0.17_1.1.9_2.0-RC1-1.zip upgrade my forum SMF1.1.8 to SMF1.1.9 and succesful.

And then i used upgrade.php upgrade database,but fail
I Love Simple Machines Forum .

SFF Forum

changed upgrade.php:363 from:


if (empty($match[1]) || $match[1] != SMF_LANG_VERSION)

replace with:

if( 0 ) // if (empty($match[1]) || $match[1] != SMF_LANG_VERSION)

and upgrade work.


http://www.simplemachines.org/community/index.php?topic=313068.msg2078121#msg2078121
I Love Simple Machines Forum .

Advertisement: