• Welcome to Simple Machines Community Forum. Please login or sign up.

SMF 1.0.3 released

Started by Owdy, March 25, 2005, 03:21:27 AM

Previous topic - Next topic

B

I'm getting this error when trying to use the Package Manager:

Quote
2: fopen(): SAFE MODE Restriction in effect. The script whose uid/gid is 10301/10001 is not allowed to access /home/httpd/vhosts/kuahale.com/httpdocs/forum/Packages/temp owned by uid/gid 48/48
File: /home/httpd/vhosts/kuahale.com/httpdocs/forum/Sources/Subs-Package.php
Line: 1454

B


Conquer Club - Free Global Domination Game
Think the board game Risk on steroids!

[Unknown]


jerm

i really dont know what to say.. it updated in half a second. im in shock  :o i really am.. i've never done an update so easily/smoothly than this...
great work smf team!!  :D

B

Quote from: [Unknown] on March 29, 2005, 07:16:10 PM
Please try this tool:

http://www.simplemachines.org/community/index.php?topic=28393.0

-[Unknown]

hmmm....ran it, and it said it was successful. However, the package still won't install, and I get the same error.

B


Conquer Club - Free Global Domination Game
Think the board game Risk on steroids!

danolie

Quote from: MikeMill on March 29, 2005, 10:53:32 AM
Using the following link
http://www.twilightavengers.com/forum/index.php?action=pgdownload;auto;package=http://mods.simplemachines.org/downloads/smf_1-0-3_package.tar.gz;sesc=... [nofollow]

I get the following error:
QuoteAn Error Has Occurred!   
The package you are trying to download or install is either corrupt or not compatible with this version of SMF.

I am experiencing the same error trying to upgrade from 1.02 to 1.03 using package manager, uploading the tar.gz file..  Please advise... and BTW, SMF ROCKS!!!!!!!!!!!!!!!!!!
My first SMF site: http://www.campusadv.com/team [nofollow] (it's a company site, so registration requires admin approval. i you want to check it out, just PM me and I'll send you a temp un/pw).

crowd

Quote from: [Unknown] on March 29, 2005, 06:56:59 PM
I'm afraid the failure means that it's not automatically updatable.  This likely means you have modified it - which is a bad idea for the default theme.

-[Unknown]


Replaced "altered" Default Theme with untouched Default files from 1.0.2

Reran... worked.


Thanks.


NOTE TO SELF... Do not touch default theme ever again.

JayBachatero

im loving SMF more and more.  the update worked fine on my test board and my public board.  and it didnt even affect my mods.  the pakage manager has really improved and its very quick.
Follow me on Twitter

"HELP!!! I've fallen and I can't get up"
This moment has been brought to you by LifeAlert

[Unknown]

Quote from: danolie on March 29, 2005, 07:28:08 PM
Quote from: MikeMill on March 29, 2005, 10:53:32 AM
Using the following link
http://www.twilightavengers.com/forum/index.php?action=pgdownload;auto;package=http://mods.simplemachines.org/downloads/smf_1-0-3_package.tar.gz;sesc=...

I get the following error:
QuoteAn Error Has Occurred!   
The package you are trying to download or install is either corrupt or not compatible with this version of SMF.

I am experiencing the same error trying to upgrade from 1.02 to 1.03 using package manager, uploading the tar.gz file..  Please advise... and BTW, SMF ROCKS!!!!!!!!!!!!!!!!!!

Please see my reply, here:

http://www.simplemachines.org/community/index.php?topic=31337.msg238202#msg238202

Quote from: B on March 29, 2005, 07:24:21 PM
hmmm....ran it, and it said it was successful. However, the package still won't install, and I get the same error.

B

You may have to delete the Packages/temp directory.

-[Unknown]

odpifounder

Hello Everyone,

Have a question actually two.  In my package manager I am getting this message:

A problem has been found in the system that sends critical database messages.  You can install this patch(click here to install) to easily up date yourself to the latest version.

Is this the place to download the new version 1.0.3?  Also if it is there is a file missing "Execute Modification ./changelog.txt"

How do I get this file?

If that message I typed is not where to get 1.0.3, how do I get it through my package manager?

Plus if that message is not the updated version how do I fix the critical database message problem?

Sorry was more than two questions.  Thanks for your help.

JayBachatero

QuoteA problem has been found in the system that sends critical database messages.  You can install this patch(click here to install) to easily up date yourself to the latest version.
yes this is the place to update to the lastest version.  only if you have 1.0 and up.
Follow me on Twitter

"HELP!!! I've fallen and I can't get up"
This moment has been brought to you by LifeAlert

[Unknown]

Quote from: odpifounder on March 29, 2005, 07:49:49 PM
Is this the place to download the new version 1.0.3?  Also if it is there is a file missing "Execute Modification ./changelog.txt"

How do I get this file?

That's the changelog.txt file from 1.0.2.  If you want the file, and want the update to go perfectly, you could copy said file from the smf_1-0-2_update archive in the archived downloads...

-[Unknown]

B

March 29, 2005, 08:29:30 PM #51 Last Edit: March 29, 2005, 08:34:48 PM by B
Quote from: [Unknown] on March 29, 2005, 07:44:25 PM
Quote from: B on March 29, 2005, 07:24:21 PM
hmmm....ran it, and it said it was successful. However, the package still won't install, and I get the same error.

B

You may have to delete the Packages/temp directory.

-[Unknown]

okay, will try that. Thanks.

B

[edit]It worked! Although, I had to turn off the renaming modified files with a ~ suffix. I was getting an error when it tried to do that for some reason. :-\ Thanks, [Unknown]![/edit]


Conquer Club - Free Global Domination Game
Think the board game Risk on steroids!

dustrho

I successfully upgraded from 1.0.2 to 1.0.3 using the Package Manager.  It was seamless and didn't receive one error message at all.  Very cool software!  SMF rocks!!

^Raven^

Woohoo new SMF.  Very excited about that.  I'm going to be updating my forum soon, I have a flu-like thing so very sick and spent last night all in the bathroom...yeah not so fun, as I get better.  But, before I do I wonder if it is possible for a complete list of changes to be made available for me.  I realize there is usually a changelog but can someone, such as Unknown or someone less busy, post the link to the list of changes or send the list to me via e-mail (webmaster@blee.biz)?

I like to show my staff what has changed and why we should upgrade.

Additionally, do we know how SMF 1.0.3 is reacting to any of the popular mods?  For example, I'm running the following mods and I realize some of them are fairly popular:

1.     Ultimate Shoutbox      1.22      
2.    Pie Chart Mod    1.2    
3.    SMF 1.0.1 Update Package    1.0.1    
4.    OnLine Users Today    1.2    
5.    SMF 1.0.2 Update Package    1.0.2b    
6.    Unreplied Topics    1.02    
7.    Thread's Bookmarks    1.1    [ Uninstall ] [ List Files ] [ Delete ]
8.    Faster Parsecode    1.07    
9.    ModSettings Textarea    1.02    
10.    Spoiler Tag    1.02    
11.    Topic Ratings    1.02    
12.    G&S_Sticky    1.0    
13.    Visual Warning / Post Moderation    1.21    
14.    The Bar Of Experience    1.1    
15.    Location Mod    1.1.1    
16.    Display Membername on Hover    1.0    
17.    Locked Boards    1.1    
18.    Membergroup Colors In Posts 1.1

I want to ensure that my forum, forum.wargamingforums.com, won't die or lock up when updating to SMF 1.0.3.  I usually uninstall all mods before doing an update and then install them again, one at a time, to see if there's any problems.  But, I just like to check beforehand.  Be prepares as they taught us in the Boy Scouts.  :)
Jon Reinhart

Owner, CWF GameCast

Public Relations Coordinator, Battlestar Galactica Wiki

Krysia

Quote from: dustrho on March 29, 2005, 08:47:56 PM
I successfully upgraded from 1.0.2 to 1.0.3 using the Package Manager.  It was seamless and didn't receive one error message at all.  Very cool software!  SMF rocks!!
ICAM. Just updated and it was a snap. Love SMF!  :-* :D



weekendclimber

I have successfully update SMF to 1.0.3 and everything is working great. One small thing that I can't figure out though, is that in the 'Admin Center' shows that I'm still using 1.0.2, but when I click on '(more detailed)' and view the comparison between all files they are all the current version. I had to manually edit a few of my template files, but they worked all just fine. Any ideas?
If you do what you have always done, you will get what you have always gotten.

WhyMan

Hey there,

I just gotta tell yah'all, over the years i've ran alot of different boards.. heh pretty much tried em all php, php/MySql and cgi/perl and the update of this board was without a doubt the simplest i've ever experienced. I'm still running a few PhpBB's on some of my sites but after this i'll be looking for a db converter. Totally Awesome SMF, thanks  :D
Two Thumb's Up!!

Cheers..  8)
MaxKombat the Gaming Cafe.
Buck-Host hosting that start's at a $1
C-F-H Complete Free Host.

megacelt

March 29, 2005, 10:37:29 PM #57 Last Edit: March 29, 2005, 11:11:14 PM by megacelt
I screwed up, and know that ignorance of best practices is no excuse.  I confess to having set up my board by modifying files that are in the default theme, as well as in my non-standard theme.  It works fine, but now, reading the upgrade posts, I realize the error of my ways.

Now I have two questions on mitigating the damage. 

1.  I have a backup of my current board under public_html/smfbackup/smf while my live version is under public_html/smf.  I am thinking that logging into the backup, applying the backup to it as a test and fix would be the way to go.  But when I try to do this, I wind up being logged into the live directory version instead.  Suggestions?

2.  What is the best approach to cleaning my errors in altering default theme files mixed up with alterations to the non-standard files?

Last, just to make sure I have rehabilitated my thinking, I should, when needing to modify a file that is not currently in my working theme, copy a version from the default theme, modify it, and put it in my working theme. Correct?

Oh, and I have not applied the upgrade yet.  Wanted to not compound things before getting input.

waddebye

Thank you SMF, it was a nice upgrade. But i still have two worries:

1. my footer "powered by SMF 1.02" not changed;

2."A problem has been found in the system that sends critical database messages. You can install this patch (click here to install) to easily update yourself to the latest version." still appears when get into the Package Manager, what should i do about it?

many thanks for your wonderful work of SMF, just like it !!!

Jazhawk

Quote from: [Unknown] on March 29, 2005, 06:56:59 PM
I'm afraid the failure means that it's not automatically updatable.  This likely means you have modified it - which is a bad idea for the default theme.

-[Unknown]

I get the same display.php update failure but I didn't modify the default template.  At least not deliberately.

-Jazhawk

Advertisement: