• Welcome to Simple Machines Community Forum. Please login or sign up.

Error after Mambo/SMF bridge install

Started by SmokeyUK, June 06, 2009, 11:43:39 AM

Previous topic - Next topic

Orstio

Correct.  Bridge 2.0 is for SMF 2.0.  Bridge 1.1.x is for SMF 1.1.x.

mikeill

okay looking good after uninstalling bridge 2 and installing 1. had to save config before SQL error went away. thank you, orstio.

H

mikeill, do you require any further assistance? :)
-H
Former Support Team Lead
                              I recommend:
Namecheap (domains)
Fastmail (e-mail)
Linode (VPS)
                             

Deadfish

Hey all, I got same problem. After installing i can see in Components -> SMF Bridge this msg:

Warning: mysql_fetch_array(): supplied argument is not a valid MySQL result resource in /home/www/zatloukal.eu/subdomains/slackers/administrator/components/com_smf/admin.smf.php on line 152

So i tried to do this step ->


Quote from: Orstio on June 06, 2009, 02:13:35 PM
OK, then in the SQL tab of phpMyAdmin, paste this:

CREATE TABLE mos_smf_config (
`variable` VARCHAR( 20 ) NOT NULL ,
`value1` VARCHAR( 80 ) NOT NULL ,
`value2` VARCHAR( 50 ) ,
`value3` VARCHAR( 50 ) ,
`value4` VARCHAR( 50 ) ,
INDEX ( `variable` )
) TYPE = MYISAM ;


And click "Go".

When that's done, paste in this:

INSERT INTO #__smf_config
(`variable`, `value1`)
VALUES ('smf_path','Path Not Set')

INSERT INTO #__smf_config
(`variable`, `value1`)
VALUES ('bridge_reg', 'bridge')


INSERT INTO #__smf_config
(`variable`, `value1`)
VALUES ('wrapped', 'true')

INSERT INTO #__smf_config
(`variable`, `value1`)
VALUES ('smf_css','true')

INSERT INTO #__smf_config
(`variable`, `value1`)
VALUES ('synch_lang','true')

INSERT INTO #__smf_config
(`variable`, `value1`)
VALUES ('agreement_required','on')

INSERT INTO #__smf_config
(`variable`, `value1`)
VALUES ('im','on')

INSERT INTO #__smf_config
(`variable`, `value1`)
VALUES ('pmOnReg','on')

INSERT INTO #__smf_config
(`variable`, `value1`)
VALUES ('use_realname',false)

INSERT INTO #__smf_config
(`variable`, `value1`)
VALUES ('cb_reg', 'off')

INSERT INTO #__smf_config
(`variable`, `value1`)
VALUES ('cb_profile','off')

INSERT INTO #__smf_config
(`variable`, `value1`)
VALUES ('bridge_version','2.0')

INSERT INTO #__smf_config
(`variable`, `value1`)
VALUES ('newsboard','')


And click "Go".

Then all should work as expected.

Fist paste thing working - after click go on second one i got this error msg:

#1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '(`variable`, `value1`) VALUES ('smf_path','Path Not Set') ' at line 1


Before i tried it i deleted my mos_smf_config.

I use SMF - 1.1.11
Mambo - 4.6.2
bridge - smf_1-1_mambo_4-6_bridge_1-1-2

Thank you

Filip

Orstio

You need to change #__ to YOUR actual table prefix.

Deadfish

Quote from: Orstio on September 04, 2009, 09:13:38 AM
You need to change #__ to YOUR actual table prefix.

Hey Orstion,

ty for response....however i change code to:

               INSERT INTO mos_smf_config
               (`variable`, `value1`)
               VALUES ('smf_path','Path Not Set')

               INSERT INTO mos_smf_config
               (`variable`, `value1`)
               VALUES ('bridge_reg', 'bridge')
               

               INSERT INTO mos_smf_config
               (`variable`, `value1`)
               VALUES ('wrapped', 'true')

               INSERT INTO mos_smf_config
               (`variable`, `value1`)
               VALUES ('smf_css','true')

               INSERT INTO mos_smf_config
               (`variable`, `value1`)
               VALUES ('synch_lang','true')

               INSERT INTO mos_smf_config
               (`variable`, `value1`)
               VALUES ('agreement_required','on')

               INSERT INTO mos_smf_config
               (`variable`, `value1`)
               VALUES ('im','on')

               INSERT INTO mos_smf_config
               (`variable`, `value1`)
               VALUES ('pmOnReg','on')

               INSERT INTO mos_smf_config
               (`variable`, `value1`)
               VALUES ('use_realname',false)

               INSERT INTO mos_smf_config
               (`variable`, `value1`)
               VALUES ('cb_reg', 'off')

               INSERT INTO mos_smf_config
               (`variable`, `value1`)
               VALUES ('cb_profile','off')

               INSERT INTO mos_smf_config
               (`variable`, `value1`)
               VALUES ('bridge_version','2.0')

               INSERT INTO mos_smf_config
               (`variable`, `value1`)
               VALUES ('newsboard','')
               


Error is now:
Quote#1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'INSERT INTO mos_smf_config (`variable`, `value1`) ' at line 5

Should be mos_smf_config for me.

Filip

Orstio

What if you do this:

INSERT INTO mos_smf_config
(`variable`, `value1`,`value2`,`value3`,`value4`)
VALUES ('smf_path','Path Not Set','','','')

osnail

if you install your cms and board in seperated database you have to grant both users to both databases so the error's gone

Aleksi "Lex" Kilpinen

Hi  SmokeyUK, has your issue been solved? Do you still require assistance on this? :)
A Finnish Project Manager (Support Specialist)
 Happily running multiple SMF 2.x installations.
  Fooling around with i7-10700 @ 2,90GHz-4.80GHz / 16Gb / RTX-2070 Super / 3840x2160 / Win 10 x64


How you can help SMF

"Before you allow people access to your forum, especially in an administrative position, you must be aware that that person can seriously damage your forum. Therefore, you should only allow people that you trust, implicitly, to have such access." -Douglas

Advertisement: