Upgrade do 1.1.x para o 2.0

Started by Costa, July 15, 2009, 06:03:38 PM

Previous topic - Next topic

Nero Germânico


Duartes

#41
Olá a todos

Fiz o upgrade conforme manda a 1ª msg deste tópico. O fórum está quase funcional não fora ter várias informações nas páginas que não aparecem. Pode ser visto no link a seguir  http://www.electronica-duartes.com/index.php

Por exemplo: Ao tentar fazer o registo, a informação onde se deve escrever o login, o endereço de e-mail e a password não aparece, aparecendo sim os campos onde as escrever e outras informações que não estão visíveis também. Nas mensagens pessoais não aparece a opção responder, não é possível escrever  nem responder a um post o que será talvez o mais grave.

No admin aparecem algumas opções em inglês e outras em português é uma certa confusão.

Ao procurar por actualizações, ele não sabe qual a versão que está disponível. Ver  o ficheiro que está em anexo.

Tentei o repair settings sem resultado.

Algum colega me pode ajudar?


Obrigado.

Cumprimentos


Duartes



Já tentei fazer o upgrade de novo. Dá um erro relacionado com o pack de linguagem.

Em anexo coloquei a imagem deste erro.

Alguém me ajuda?

Obrigado.


Duartes



Afinal tive que me virar sozinho.

Parece que por aqui está um pouco abandonado, pois nem uma resposta tive.

Mas enfim, está a funcionar. Coloquei o pack de linguagem em inglês e fiz o upgrade de novo.

Agora como faço para colocar o pack de linguagem português-utf8?

Tentei mudar trocando os packs mas assim o fórum não funciona.

Haja uma alma caridosa que me ajude.

Obrigado.



Spectrum..!!

Quote from: Duartes on April 29, 2010, 02:31:56 PM

Afinal tive que me virar sozinho.

Parece que por aqui está um pouco abandonado, pois nem uma resposta tive.

Saudações ao amigo, não vejo abandono, a equipe de Moderadores está sempre no local, quando um ou outro.
Da questão de tua resposta aí depende da voluntariedade de todos, aí é caso de paciência não?

QuoteMas enfim, está a funcionar. Coloquei o pack de linguagem em inglês e fiz o upgrade de novo.

Que bom que tenha solucionado parte de teu problema.

QuoteAgora como faço para colocar o pack de linguagem português-utf8?

Não há como adicionar a linguagem pelo painel ADM do SMF?

> Admin > configuration > Languages.......na guia Add Language?

QuoteObrigado.

Por enquanto, de nada.






Existem pessoas que deixam de buscar algo que dura a vida toda, para somente conquistar algo que dura alguns momentos...
Ser humilde; não é ser menos que alguém. É saber que não somos mais que ninguém!
SMF 2.0.4 | Meu site -->
Dell Vostro 3560 + AMD Radeon™ HD 7670M 1GB| Windows 8 Pro | Fedora 18 | IE10 | Google Chrome

Não atendo PM para pedidos de suporte/ajuda

Duartes



Bem amigo

Eu apenas pretendia uma ajuda. Não quero nem pensar em entrar em polémica.

Com a ajuda de um amigo, (é muito bom ter amigos),  já tinha conseguido resolver o meu problema.

No entanto, agradeço muito a sua resposta.

Cumprimentos




Costa

Ó Duartes, desculpa lá mas, epah!
A gente faz isto por amor à camisola, o mínimo que podes fazer é esperar um pouco. A gente tem vida para viver, cão/gato para passear, filhos para cuidar, mulher para aturar, etc etc

Isto aqui, para qualquer um que o faça por gosto, é secundário.
Ficou-te muito mal essas "bocas". Enfim...

-Costa
Hugo Costa
Todas as MP's a pedir ajuda são sujeitas a radioactividade, microondas, queimadas e atiradas borda fora.

"At least someone appreciates the fact that I am doing and not thinking..."
"Laziness is counter-revolutionary."

Duartes



Amigo Costa
Não são bocas. Apenas um desabafo de que está à rasca. Pois o fórum como estava não funcionava. Para não ser mal interpretado, eu disse logo que não pretendia entrar em polémica.

Enfim, se é isso que pensam não sei mais que dizer.




Joreg@s

boas
Já agora uma ajuda para fazer upgrade para SMF 2.0 RC3 ?
tambem tem de se correr o upgrade.php?
cumpts

Spectrum..!!

Quote from: Joreg@s on May 14, 2010, 06:43:05 PM
boas
Já agora uma ajuda para fazer upgrade para SMF 2.0 RC3 ?
tambem tem de se correr o upgrade.php?
cumpts

Sempre realize um backup completo do fórum antes.


Sim, é necessário correr o upgrade.php.
Dependendo da versão:
No caso up de  1.x deverá utilizar o Large ugrade.
No caso de o sistema já ser 2.x pode utilizar o pacote small.

abçs,

Existem pessoas que deixam de buscar algo que dura a vida toda, para somente conquistar algo que dura alguns momentos...
Ser humilde; não é ser menos que alguém. É saber que não somos mais que ninguém!
SMF 2.0.4 | Meu site -->
Dell Vostro 3560 + AMD Radeon™ HD 7670M 1GB| Windows 8 Pro | Fedora 18 | IE10 | Google Chrome

Não atendo PM para pedidos de suporte/ajuda

Joreg@s

Eu já tenho o sistema em 2.0 rc2 e experimentei o Large upgrade 2.0 RC3 e correr o update.php mas assim nao deu para actualizar.
sendo assim tenho de utilizar o pacote small e depois?
é preciso correr o upgrade.php ou algo assim?

cumpts

Spectrum..!!

Quote from: Joreg@s on May 15, 2010, 08:00:13 PM
Eu já tenho o sistema em 2.0 rc2 e experimentei o Large upgrade 2.0 RC3 e correr o update.php mas assim nao deu para actualizar.

Epa, era par ter dado sim, qual erro apresentado?

Existem pessoas que deixam de buscar algo que dura a vida toda, para somente conquistar algo que dura alguns momentos...
Ser humilde; não é ser menos que alguém. É saber que não somos mais que ninguém!
SMF 2.0.4 | Meu site -->
Dell Vostro 3560 + AMD Radeon™ HD 7670M 1GB| Windows 8 Pro | Fedora 18 | IE10 | Google Chrome

Não atendo PM para pedidos de suporte/ajuda

FragaCampos

Penso que este tópico é de crucial importância agora que saiu a versão 2.0 final. Eu próprio estou-me a preparar para fazer o upgrade de 1.1.14 para 2.0. Alguém me sabe dizer (e a todos os que vierem certamente ler este tópico) se este é o melhor método e o mais aconselhável?

Spectrum..!!

Saudações amigo FragaCampos, sim, este é o mais aconselhável.

Faça um backup do BD, e, se possível do site todo, para alguma eventualidade de querer retornar, nunca se sabe. Lembre-se de que este processo é irreversível.

Tenha um cuidado especial com o arquivo Settings.php (faça uma cópia do original antes de iniciar o processo e guarde consigo)...

Existem pessoas que deixam de buscar algo que dura a vida toda, para somente conquistar algo que dura alguns momentos...
Ser humilde; não é ser menos que alguém. É saber que não somos mais que ninguém!
SMF 2.0.4 | Meu site -->
Dell Vostro 3560 + AMD Radeon™ HD 7670M 1GB| Windows 8 Pro | Fedora 18 | IE10 | Google Chrome

Não atendo PM para pedidos de suporte/ajuda

FragaCampos


FragaCampos

Estive a fazer testes com o Xampp no meu computador e o upgrade do SMF exige a presença do settings.php na directoria principal do fórum. É que a primeira mensagem do Costa diz para não substituirmos o settings.php. Além disso, na página de ajuda do SMF não fala nada acerca desse ficheiro.

É válida esta preocupação com o settings.php?

Spectrum..!!

A preocupação com o arquivo Settings.php é que o mesmo possui informações cruciais do sistema. No caso deste arquivo reposto com um novo e com informações contrárias ao fórum antigo é que preocupa.

Por isso que pedi, em mensagem anterior, sempre ter guardado consigo, ao menos nos momentos de upgrade, uma cópia do original (antigo).

Como se trata de sistema testes, desde que o amigo tenha esse arquivo em mãos, pode tentar realizar a tarefa sem se preocupar com ele, eu fiz e deu certo (em localhost). Peço que informe para que possamos enriquecer este tuto ainda mais.

*este tutorial, em breve, será reeditado.

Existem pessoas que deixam de buscar algo que dura a vida toda, para somente conquistar algo que dura alguns momentos...
Ser humilde; não é ser menos que alguém. É saber que não somos mais que ninguém!
SMF 2.0.4 | Meu site -->
Dell Vostro 3560 + AMD Radeon™ HD 7670M 1GB| Windows 8 Pro | Fedora 18 | IE10 | Google Chrome

Não atendo PM para pedidos de suporte/ajuda

FragaCampos

Pelo que eu vi, o upgrade faz automaticamente um backup desse ficheiro, além disso qualquer pessoa que faça o upgrade deve fazer um backup da base de dados e do fórum, por isso é que referi que talvez não fosse necessária essa preocupação com o ficheiro settings.php.

Spectrum..!!

Quote from: FragaCampos on June 25, 2011, 09:01:53 AM
Pelo que eu vi, o upgrade faz automaticamente um backup desse ficheiro, além disso qualquer pessoa que faça o upgrade deve fazer um backup da base de dados e do fórum, por isso é que referi que talvez não fosse necessária essa preocupação com o ficheiro settings.php.

Obrigado pela informação amigo FragaCampos, enquanto o amigo olhava para isto eu também ia em busca da informação. Realmente procede.  ;)

Existem pessoas que deixam de buscar algo que dura a vida toda, para somente conquistar algo que dura alguns momentos...
Ser humilde; não é ser menos que alguém. É saber que não somos mais que ninguém!
SMF 2.0.4 | Meu site -->
Dell Vostro 3560 + AMD Radeon™ HD 7670M 1GB| Windows 8 Pro | Fedora 18 | IE10 | Google Chrome

Não atendo PM para pedidos de suporte/ajuda

Isa.F

Bom dia! Estou a experimentar o upgrade no meu PC, em localhost passando de versao 1.1.14 para 2.0.

É possivel fazer upgrade em localhost? Está a dar-me este erro...



Segui todo este tutorial, e o unico erro que me dá é esse... Visto que estou a fazer isto no meu computador, em localhost, como faço para fazer upgrade? Ou nao dá para fazer em localhost?

Obrigada...

Advertisement: