News:

SMF 2.1.2 has been released! Take it for a spin! Read more.

Main Menu

Hide Tag Special

Started by enik, April 11, 2005, 03:41:07 PM

Previous topic - Next topic

JackWise

Hi mates,

Can anyone tell me how "Enable Variable for Thank You Post Button and Link:" works ?

I enabled It but I don't konw what to do to see it working.

Thanks in advance,

JW

ディン1031

Quote from: JackWise on March 18, 2009, 06:29:03 PM
Hi mates,

Can anyone tell me how "Enable Variable for Thank You Post Button and Link:" works ?

I enabled It but I don't konw what to do to see it working.

Thanks in advance,

JW
You mean how the add on "Thank-O-Matic Add On: Hide Tag Link" work together with this mod?
Normal you need only to insert in the hidden content text $thankYouPostLink or $thankYouPostButton.
The link can be used in the way [url=$thankYouPostLink]Thank me now![/url] and the the $thankYouPostButton show only the the thank you button with link ;).

Bye
DIN1031
Support only via MOD Thread! NO PM Support!
My Forum: ayu][kult Forum
My Mods: My Small Mod Collection
My Parser: DIN1031's ModParser
Current Info: More away the next days, because i've to much work to do :x

MaXiForum.cz

Quote from: ディン1031 on February 27, 2009, 01:14:52 PM
Version 2.3.1 (27.02.08)
! Fixed the Wycsiwyg bug, that remove the hidden content on edit.
- Upgrade included

Should fix you problem :).
....
Bye
DIN1031

Hi,
I have with this problem on RC1 too ...

    // Fix the hide tag problem... my mod is strict to strict...
if(hideTagExists($text, 'text'))
$text = preg_replace("/\[\/hide\]/i", '#hide#', $text);
$text = parse_bbc($text, true, '', $allowed_tags);
// Set it back to normal :D
if(hideTagExists($text, 'text'))
$text = str_replace("#hide#", '[/hide]', $text);


BBC button missing :(

ディン1031

Quote from: MaxiPes on March 22, 2009, 12:59:22 PM
Hi,
I have with this problem on RC1 too ...
Than update your version, to the latest. (And it will work)

Quote
BBC button missing :(
Install the package for the button, i will never include this in my package because i don't like the button for hide.
Attached to the first post is the package for the bbc button ;).

Bye
DIN1031
Support only via MOD Thread! NO PM Support!
My Forum: ayu][kult Forum
My Mods: My Small Mod Collection
My Parser: DIN1031's ModParser
Current Info: More away the next days, because i've to much work to do :x

MaXiForum.cz

Hi,
lastest version is 2.3.1 and this I have instaled :)


Quote from: ディン1031 on March 23, 2009, 02:57:55 AM
...........
Install the package for the button, i will never include this in my package because i don't like the button for hide.
Attached to the first post is the package for the bbc button ;).

Bye
DIN1031

Thanks a lot DIN :) ;)

JackWise

Quote from: ディン1031 on March 19, 2009, 01:11:09 AM
Quote from: JackWise on March 18, 2009, 06:29:03 PM
Hi mates,

Can anyone tell me how "Enable Variable for Thank You Post Button and Link:" works ?

I enabled It but I don't konw what to do to see it working.

Thanks in advance,

JW
You mean how the add on "Thank-O-Matic Add On: Hide Tag Link" work together with this mod?
Normal you need only to insert in the hidden content text $thankYouPostLink or $thankYouPostButton.
The link can be used in the way [url=$thankYouPostLink]Thank me now![/url] and the the $thankYouPostButton show only the the thank you button with link ;).

Bye
DIN1031

can you give some examples ?
I tried this but with no results.

JW

JackWise

Quote from: JackWise on March 23, 2009, 05:38:23 PM
Quote from: ディン1031 on March 19, 2009, 01:11:09 AM
Quote from: JackWise on March 18, 2009, 06:29:03 PM
Hi mates,

Can anyone tell me how "Enable Variable for Thank You Post Button and Link:" works ?

I enabled It but I don't konw what to do to see it working.

Thanks in advance,

JW
You mean how the add on "Thank-O-Matic Add On: Hide Tag Link" work together with this mod?
Normal you need only to insert in the hidden content text $thankYouPostLink or $thankYouPostButton.
The link can be used in the way [url=$thankYouPostLink]Thank me now![/url] and the the $thankYouPostButton show only the the thank you button with link ;).

Bye
DIN1031

can you give some examples ?
I tried this but with no results.

JW

Hi,

I did'it, just like this :

[url=http://$thankYouPostLink][img]http://f.imagehost.org/0337/clicame.gif[/img][/url]

I put this in "hidden text information" under "hide tag special" in Admin.

It works.

Many thanks,

JW

Leonta

I can't get this to work. When I am using "$thankYouPostLink" or "$thankYouPostButton" all I get is blank. I have checked the files and all of them have been "hacked" correct with the installation. I am using greek language but it doesn't work even when I change to english and default theme :(

ディン1031

Quote from: Leonta on April 03, 2009, 07:08:14 AM
I can't get this to work. When I am using "$thankYouPostLink" or "$thankYouPostButton" all I get is blank. I have checked the files and all of them have been "hacked" correct with the installation. I am using greek language but it doesn't work even when I change to english and default theme :(
This will work only if you install the add on for the thank-o-matic. Without the addon this will not work ;).

Bye
DIN1031
Support only via MOD Thread! NO PM Support!
My Forum: ayu][kult Forum
My Mods: My Small Mod Collection
My Parser: DIN1031's ModParser
Current Info: More away the next days, because i've to much work to do :x

Leonta

#1009
I have installed it, I am no stupid  :D I have the option enabled from the control panel.

p.s I think I have something. I have these 2 errors from Display.php:

Undefined variable: ID_MEMBER at line 1297
Undefined index: ID_MSG at line 1296

These lines are:

$context['thank_you_post_extra']['msg'] = $message['ID_MSG'];
$context['thank_you_post_extra']['postWithThankYou'] = $context['thank_you_post_enable'] && empty($context['is_thank_you_post_locked']) && allowedTo('thank_you_post_post') && $ID_MEMBER != $message['ID_MEMBER'] && !isset($context['thank_you_post']['postet_thanks'][$message['ID_MSG']]) && !(empty($modSettings['thankYouPostOnePerPost']) && !empty($context['thank_you_post']['postet_thanks']));

These lines are from Thank-O-Matic Addon: Hide Tag Link
I hope this helps :)


ディン1031

Quote from: Leonta on April 03, 2009, 08:17:26 AM
I have installed it, I am no stupid  :D I have the option enabled from the control panel.

p.s I think I have something. I have these 2 errors from Display.php:

Undefined variable: ID_MEMBER at line 1297
Undefined index: ID_MSG at line 1296

These lines are:

$context['thank_you_post_extra']['msg'] = $message['ID_MSG'];
$context['thank_you_post_extra']['postWithThankYou'] = $context['thank_you_post_enable'] && empty($context['is_thank_you_post_locked']) && allowedTo('thank_you_post_post') && $ID_MEMBER != $message['ID_MEMBER'] && !isset($context['thank_you_post']['postet_thanks'][$message['ID_MSG']]) && !(empty($modSettings['thankYouPostOnePerPost']) && !empty($context['thank_you_post']['postet_thanks']));

These lines are from Thank-O-Matic Addon: Hide Tag Link
I hope this helps :)
On which version of the Thank-O-Matic did you install this modification? :X
Support only via MOD Thread! NO PM Support!
My Forum: ayu][kult Forum
My Mods: My Small Mod Collection
My Parser: DIN1031's ModParser
Current Info: More away the next days, because i've to much work to do :x

Leonta

Quote from: ディン1031 on April 04, 2009, 04:14:31 PM
Quote from: Leonta on April 03, 2009, 08:17:26 AM
I have installed it, I am no stupid  :D I have the option enabled from the control panel.

p.s I think I have something. I have these 2 errors from Display.php:

Undefined variable: ID_MEMBER at line 1297
Undefined index: ID_MSG at line 1296

These lines are:

$context['thank_you_post_extra']['msg'] = $message['ID_MSG'];
$context['thank_you_post_extra']['postWithThankYou'] = $context['thank_you_post_enable'] && empty($context['is_thank_you_post_locked']) && allowedTo('thank_you_post_post') && $ID_MEMBER != $message['ID_MEMBER'] && !isset($context['thank_you_post']['postet_thanks'][$message['ID_MSG']]) && !(empty($modSettings['thankYouPostOnePerPost']) && !empty($context['thank_you_post']['postet_thanks']));

These lines are from Thank-O-Matic Addon: Hide Tag Link
I hope this helps :)
On which version of the Thank-O-Matic did you install this modification? :X

2.0 Beta 9

mkress

is it possible to disable the hide-tag for a special post.

I used the nobbc tags and php-tags, but the hide-tags always get parsed...

ディン1031

Quote from: Leonta on April 05, 2009, 07:11:21 AM
Quote from: ディン1031 on April 04, 2009, 04:14:31 PM
Quote from: Leonta on April 03, 2009, 08:17:26 AM
I have installed it, I am no stupid  :D I have the option enabled from the control panel.

p.s I think I have something. I have these 2 errors from Display.php:

Undefined variable: ID_MEMBER at line 1297
Undefined index: ID_MSG at line 1296

These lines are:

$context['thank_you_post_extra']['msg'] = $message['ID_MSG'];
$context['thank_you_post_extra']['postWithThankYou'] = $context['thank_you_post_enable'] && empty($context['is_thank_you_post_locked']) && allowedTo('thank_you_post_post') && $ID_MEMBER != $message['ID_MEMBER'] && !isset($context['thank_you_post']['postet_thanks'][$message['ID_MSG']]) && !(empty($modSettings['thankYouPostOnePerPost']) && !empty($context['thank_you_post']['postet_thanks']));

These lines are from Thank-O-Matic Addon: Hide Tag Link
I hope this helps :)
On which version of the Thank-O-Matic did you install this modification? :X

2.0 Beta 9
This AddOn does not work in that version... (normal i wonder why it is installable... i was sure there was an error in it :X)
But you can fix it if you like ;).
Normal if you replace the ID_MEMBER with id_member and ID_MSG with id_msg it should normal work =).

Quote from: fca07 on April 06, 2009, 01:38:02 PM
is it possible to disable the hide-tag for a special post.

I used the nobbc tags and php-tags, but the hide-tags always get parsed...
Hmmm no... the content will be parsed every time... i could ad a option that will only allow the hide remove on specific boards? Would that be useful for you?

Bye
DIN1031
Support only via MOD Thread! NO PM Support!
My Forum: ayu][kult Forum
My Mods: My Small Mod Collection
My Parser: DIN1031's ModParser
Current Info: More away the next days, because i've to much work to do :x

Leonta

Thanks, that did the trick. The add on is working, I still get flood by "Undefined variable: id_member" errors at the logs but I guess I'll have to ignore them.

ディン1031

Quote from: Leonta on April 09, 2009, 02:23:13 AM
Thanks, that did the trick. The add on is working, I still get flood by "Undefined variable: id_member" errors at the logs but I guess I'll have to ignore them.
But you right i forgot something *g*


$context['thank_you_post_extra']['msg'] = $message['ID_MSG'];
$context['thank_you_post_extra']['postWithThankYou'] = $context['thank_you_post_enable'] && empty($context['is_thank_you_post_locked']) && allowedTo('thank_you_post_post') && $ID_MEMBER != $message['ID_MEMBER'] && !isset($context['thank_you_post']['postet_thanks'][$message['ID_MSG']]) && !(empty($modSettings['thankYouPostOnePerPost']) && !empty($context['thank_you_post']['postet_thanks']));


replace with

global $user_info;
$context['thank_you_post_extra']['msg'] = $message['id_msg'];
$context['thank_you_post_extra']['postWithThankYou'] = $context['thank_you_post_enable'] && empty($context['is_thank_you_post_locked']) && allowedTo('thank_you_post_post') && $user_info['id'] != $message['id_member'] && !isset($context['thank_you_post']['postet_thanks'][$message['id_msg']]) && !(empty($modSettings['thankYouPostOnePerPost']) && !empty($context['thank_you_post']['postet_thanks']));


Possible that the global $user_info; is not needed, you should test this, but after that the second error should be away, too =).

Or replace simple the $ID_MEMBER with $user_info['id'] ;).

bye
DIN1031
Support only via MOD Thread! NO PM Support!
My Forum: ayu][kult Forum
My Mods: My Small Mod Collection
My Parser: DIN1031's ModParser
Current Info: More away the next days, because i've to much work to do :x

ɔɔɔɔɔɔuɥoɾ

Hi, Great mod the new updated one works with wysiwyg editor well, thanks.

I have a question though,
For the option " Enable auto add [hide][/hide] on new topics: " would it be possible to make the hde tags wrap only around code tags, instead of the whole post, if so, could you please see where the change in code would be and post it here :)

Thanks in advanced.


SMF 2.0 RC5

   
Webhost to New Webhost file transfer service, PM me - Fast transfers

ディン1031

Quote from: johncccccc on April 28, 2009, 11:03:52 AM
Hi, Great mod the new updated one works with wysiwyg editor well, thanks.

I have a question though,
For the option " Enable auto add [hide][/hide] on new topics: " would it be possible to make the hde tags wrap only around code tags, instead of the whole post, if so, could you please see where the change in code would be and post it here :)

Thanks in advanced.
Yes it's possible i will see if i can make something that can do that ;).

Bye
DIN1031
Support only via MOD Thread! NO PM Support!
My Forum: ayu][kult Forum
My Mods: My Small Mod Collection
My Parser: DIN1031's ModParser
Current Info: More away the next days, because i've to much work to do :x

PHPLearner

Thanks For this mod, This Is what I need But installing on 1.1.8 it says cannot parse from the mod page, It works and does great(package manager)but gives me about 50 errors per click, I am kinda new to this,  thanks again, Dave

Oh Yeah error on install is ./Sources/Subs.php , If I could manually code it would be great, but the mod says it supports 1.1.8? Thanks, You obviously have good mods!!!!!!!

ディン1031

Quote from: fmap4life on April 30, 2009, 10:51:28 PM
Thanks For this mod, This Is what I need But installing on 1.1.8 it says cannot parse from the mod page, It works and does great(package manager)but gives me about 50 errors per click, I am kinda new to this,  thanks again, Dave

Oh Yeah error on install is ./Sources/Subs.php , If I could manually code it would be great, but the mod says it supports 1.1.8? Thanks, You obviously have good mods!!!!!!!
Are you sure they come from this modification oO?
What kind of errors?

Bye
DIN1031
Support only via MOD Thread! NO PM Support!
My Forum: ayu][kult Forum
My Mods: My Small Mod Collection
My Parser: DIN1031's ModParser
Current Info: More away the next days, because i've to much work to do :x

Advertisement: