News:

SMF 2.1.2 has been released! Take it for a spin! Read more.

Main Menu

Hide Tag Special

Started by enik, April 11, 2005, 03:41:07 PM

Previous topic - Next topic

ディン1031

#380
I won't fix this, when i fix this it's possible to read hidden content without posting (and this also for guests, as long it is public.) (If you don't belive me, i give you a example how this possible).

So i can not remove it, because than it's not a hide tag any more.

Normal, if all changes made correct it remove this button on hidden content things. So that the inline edit normal not seeable. Hmmmm i could be remove post with hidden content and return a error so that the post will not be inline editable any more...

Bye
DIN1031




Support only via MOD Thread! NO PM Support!
My Forum: ayu][kult Forum
My Mods: My Small Mod Collection
My Parser: DIN1031's ModParser
Current Info: More away the next days, because i've to much work to do :x

Greek

#381
When somebody open the member list or display a profile, I get this error in errors log.
Quote
8: Undefined index: hide_hiddentext
File: /home/domain/public_html/forum/Sources/Subs.php
Line: 1089
What's wrong?

Here is the error located

Quote$message = preg_replace("/\[hide\](.+?)\[\/hide\]/i", (empty($modSettings['hide_onlyonetimeinfo']) ? $modSettings['hide_hiddentext'] : "&nbsp"), $message);
      $message = preg_replace(array('~\n?\[hide.*?\].+?\[/hide\]\n?~is', '~^\n~', '~\[/hide\]~'), (empty($modSettings['hide_onlyonetimeinfo']) ? $modSettings['hide_hiddentext'] : "&nbsp"), $message);

ディン1031

#382
Did you enable the MUI Switch?
If yes than language things are missing.


Which version is this?

Because i see this is normal not the current version, it's not possible. At least nothing would be insert in the variable if nothing set ;).

Bye
DIN1031
Support only via MOD Thread! NO PM Support!
My Forum: ayu][kult Forum
My Mods: My Small Mod Collection
My Parser: DIN1031's ModParser
Current Info: More away the next days, because i've to much work to do :x

Greek

Quote from: DIN1031 on March 07, 2007, 09:50:42 AM
Did you enable the MUI Switch?
If yes than language things are missing.


Which version is this?

Because i see this is normal not the current version, it's not possible. At least nothing would be insert in the variable if nothing set ;).

Bye
DIN1031

I have upgrated to the last version. My language is greek, but I have installed the greek language strings.

Even if I don't activate MUI, these errors still appear when somebody open the member list or any profile.

What can I do?

Thanks.

ディン1031

Quote from: Greek on March 07, 2007, 12:00:59 PM
Quote from: DIN1031 on March 07, 2007, 09:50:42 AM
Did you enable the MUI Switch?
If yes than language things are missing.


Which version is this?

Because i see this is normal not the current version, it's not possible. At least nothing would be insert in the variable if nothing set ;).

Bye
DIN1031

I have upgrated to the last version. My language is greek, but I have installed the greek language strings.

Even if I don't activate MUI, these errors still appear when somebody open the member list or any profile.

What can I do?

Thanks.
Hmmm from which version did you upgrade?

Can you give me you subs.php?

Bye
DIN1031
Support only via MOD Thread! NO PM Support!
My Forum: ayu][kult Forum
My Mods: My Small Mod Collection
My Parser: DIN1031's ModParser
Current Info: More away the next days, because i've to much work to do :x

Greek

If I remember well my initial version was 2.0


Here is my Subs.php Thanks  :)

ディン1031

#386
Is your sup.php filesize so large ?_? i think it's to large... and i don't have a version 2.0 of the mod ?_?.

And i can't open it correct... so i think... i can't help you with this strange file <<, can you zip it an upload it... 

And i like to know which option do you set :x, for the hide mod.

Bye
DIN1031
Support only via MOD Thread! NO PM Support!
My Forum: ayu][kult Forum
My Mods: My Small Mod Collection
My Parser: DIN1031's ModParser
Current Info: More away the next days, because i've to much work to do :x

Greek

Sorry I meaned version 1.2.0

I suppose that my subs is big because of many mods.

Here is the zipped file

ディン1031

#388
Hmmm i think i can improve my mod a little bit for this. :x

Search for


//Hide Mod.. i remove the code before i do anything...
//Built the correct hidden content informations :), or add a the one time infomration :)
if((empty($context['user_post_avaible']) || !isset($context['user_post_avaible'])) && $message !== false && !empty($message)) {
//Check you're a guest? Should i show this infomations?
if(empty($modSettings['hide_noinfoforguests']) || !$user_info['is_guest']) {
//Lets change the HideTag ;) this is a secret and should be a secret :)
if (empty($modSettings['hide_hiddentext'])) $modSettings['hide_hiddentext'] = '&nbsp;'; //A tiny little space =)


and replace it with

//Hide Mod.. i remove the code before i do anything...
//Built the correct hidden content informations :), or add a the one time infomration :)
if (empty($modSettings['hide_hiddentext'])) $modSettings['hide_hiddentext'] = '&nbsp;'; //A tiny little space =)
if((empty($context['user_post_avaible']) || !isset($context['user_post_avaible'])) && $message !== false && !empty($message)) {
//Check you're a guest? Should i show this infomations?
if(empty($modSettings['hide_noinfoforguests']) || !$user_info['is_guest']) {
//Lets change the HideTag ;) this is a secret and should be a secret :)


And tell me if it work.

Can you also tell me what are you hide tag settings are you use?

Bye
DIN1031
Support only via MOD Thread! NO PM Support!
My Forum: ayu][kult Forum
My Mods: My Small Mod Collection
My Parser: DIN1031's ModParser
Current Info: More away the next days, because i've to much work to do :x

Greek

It works! Thanks!  :D
No more errors (at least from this mod  ;D )

As I said I didn't activate this mod so far. I tested today and it works fine (and with Thank you mod). I want only to test it with a image insist of text.

Thanks again for your help DIN1031  :)

downcen

I use SMF 1.1.2. It can't use with you mod. Please help me. I like you mod very much. Thank you for read.

babjusi

Quote from: downcen on March 11, 2007, 10:26:40 AM
I use SMF 1.1.2. It can't use with you mod. Please help me. I like you mod very much. Thank you for read.

I took a look at the mod and there it says that it supports 1.1.2. Did u try to install it and if it didn''t install, what error message it gave you?

downcen

"The package you are trying to download or install is either corrupt or not compatible with this version of SMF."

babjusi

Quote from: downcen on March 11, 2007, 10:41:11 AM
"The package you are trying to download or install is either corrupt or not compatible with this version of SMF."

Give it a try to install it manually then

downcen

Manual is meaning upload files form computer?
I did that at first.

babjusi

Quote from: downcen on March 11, 2007, 11:10:33 AM
Manual is meaning upload files form computer?
I did that at first.

Here you have a detalied descrition of how to manually uoload a mod. Hope it helps

http://docs.simplemachines.org/index.php?topic=402

downcen

Thanks very much. I'll do it.  :D

[MaxX]


khurrum

if you can add sound it will be great. (sound on every new message)
Khurrum Kamaal
Mobile: 97150-7868522
kk@khurrum.com
http://www.uaetraders.net
http://www.khurrum.com

ディン1031

Quote from: khurrum on March 13, 2007, 04:44:11 AM
if you can add sound it will be great. (sound on every new message)
y should i do that. IT's unlogical to do this for this mod ;).

Bye
DIN1031
Support only via MOD Thread! NO PM Support!
My Forum: ayu][kult Forum
My Mods: My Small Mod Collection
My Parser: DIN1031's ModParser
Current Info: More away the next days, because i've to much work to do :x

Advertisement: