News:

SMF 2.0.19 has been released! Please update. Read more.

Main Menu

Hide Tag Special

Started by enik, April 11, 2005, 03:41:07 PM

Previous topic - Next topic

ディン1031



Version 1.2.7 (27.05.07)
! Fixed the not replaced $language variable on the unhidden image.

Upgrade is included :).

Thx to Stelios for this information...

Bye
DIN1031
Support only via MOD Thread! NO PM Support!
My Forum: ayu][kult Forum
My Mods: My Small Mod Collection
My Parser: DIN1031's ModParser
Current Info: More away the next days, because i've to much work to do :x

babjusi

Hi ディン1031. Does this mean the language for the unhidden image which will be shown to the members viewing the hidden post,  can be set from the admin''s panel? Thank you

ディン1031

Yes ;) it was possible since Version *thinking* 1.2.2 but i made a mistake on the built of the unhidden image.

Bye
DIN1031
Support only via MOD Thread! NO PM Support!
My Forum: ayu][kult Forum
My Mods: My Small Mod Collection
My Parser: DIN1031's ModParser
Current Info: More away the next days, because i've to much work to do :x

babjusi

Quote from: ディン1031 on May 29, 2007, 09:23:59 AM
Yes ;) it was possible since Version *thinking* 1.2.2 but i made a mistake on the built of the unhidden image.

Bye
DIN1031

Thank you for your answer and for making something like that possible, it is so handy

nitins60

Hmmm... Really confused of the settings! I didn't understand the complex English used in Basic Feature Settings!

I just wanted to hide content with image until they post, let me know how to do it?

ディン1031

Hmmmm complex english xD

Putt a link to the image in the "Image link for hidden..." box ;).

Than a image appear instead of the hidden text.

Bye
DIN1031
Support only via MOD Thread! NO PM Support!
My Forum: ayu][kult Forum
My Mods: My Small Mod Collection
My Parser: DIN1031's ModParser
Current Info: More away the next days, because i've to much work to do :x

nitins60

Can any1 give image to use @Hide Tag? 

thegto

#467
้ำhello
I still have problem when install this mod one the web server (I use freeweb hosting, freehostia.com)

i try with v1.2.7

   ./Sources/Subs.php     Test failed

but strangely , in my offline server every thing work great , please give me some advise how to resolve this problem.

thanks
Thegto

ディン1031

#468
Quote from: thegto on June 11, 2007, 12:12:09 AM
้ำhello
I still have problem when install this mod one the web server (I use freeweb hosting, freehostia.com)

i try with v1.2.7

   ./Sources/Subs.php     Test failed

but strangely , in my offline server every thing work great , please give me some advise how to resolve this problem.

thanks
Thegto

Oh this is the most importend change :x, can you give me you subs.php and the list of mods that you installed?

Quote from: nitins60 on June 10, 2007, 10:19:06 PM
Can any1 give image to use @Hide Tag? 

Hmmmm a example only -> -> http://nextsite.org/hidden.gif it's from this post

Bye
DIN1031
Support only via MOD Thread! NO PM Support!
My Forum: ayu][kult Forum
My Mods: My Small Mod Collection
My Parser: DIN1031's ModParser
Current Info: More away the next days, because i've to much work to do :x

babjusi

One quick question Din. If I use this link ''http://nextsite.org/hidden.gif''; will the image shown above, show at the post of which I am hiding the links?

ディン1031

Yes ;), it will be shown instead of the text.

But it's only example, i don't know if the user allow that someone else use it xD.

Bye
DIN1031
Support only via MOD Thread! NO PM Support!
My Forum: ayu][kult Forum
My Mods: My Small Mod Collection
My Parser: DIN1031's ModParser
Current Info: More away the next days, because i've to much work to do :x

thegto

installedmod
1. No Spam by Guests!      0.1
2. Anonymous Posting Mod      1.01

SMF 1.1.1
Theme :orange-it

babjusi

Quote from: ディン1031 on June 11, 2007, 04:05:36 AM
Yes ;), it will be shown instead of the text.

But it's only example, i don't know if the user allow that someone else use it xD.

Bye
DIN1031

Thanks for you answer din. I don''t think that the user would mind it, but I will ask his permission anyway

babjusi

Quote from: Lord Anubis on March 29, 2007, 11:36:56 PM
Quote from: DIN1031 on March 29, 2007, 06:43:12 AM
Okay you've replaced it completely wrong xD, i've attached the correct one to the post.

Quote from: Lord Anubis on March 28, 2007, 01:45:38 PM
I make ppl reply to see the hidden content...

But say under permissions if I allow a Global Moderator to use the hide tag all the BBC code doesn't work and all their posts end up like [img.]http://link to image[./img], without the periods of course :)
I don't understand it ?_?. What are your settings for the Hide Mod... i think you didn't set it correct.

Bye
DIN1031



MUI Switch - Unchecked
Hide Standard Text -
Image link for hidden contet - Blank
Image link for unhidden contet - unhidden.gif
Show only one time the hidden content information, at the end of the post. - Unchecked
Admin should see the hide without post? - Checked
Hide hidden text/image for guests - Checked
Groups IDs who allowed to see a hidden content without posting? - 2
Minmum post count to allow unhide content - 0
Minmum post count to unhide content without posting - 0

I don't see how any of this would affect the BBC code though  :(

Hi Lord Anubis. May I  use the image you placed here, in my site as well to be shown for the hidden links.

mforum

A suggestion to the Author, if it`s possible.

To have Show only one time the hidden content information, at the end of the post option for Hidden pictures too.
For example, if a member use lot`s of Hide Tags in a post, only one Hide image to show at the end of post.

Also, to have the ability to use BBC on image link text, so we can link or center the image.  ;)

ディン1031

Yeah i will do this ;).

But i think i will change a little bit the System in my Hide Mod for this, but it will be better after it and easier to understand (hope it xD). With the new system unhidden text will also be possible =). But i will do this at the weekend.

@thegto

I looked into the subs.php file somehow i'm not 100% sure but it looks like the replace should work :x, i go look again at the evening but at the first saw it should work.

Bye
DIN1031
Support only via MOD Thread! NO PM Support!
My Forum: ayu][kult Forum
My Mods: My Small Mod Collection
My Parser: DIN1031's ModParser
Current Info: More away the next days, because i've to much work to do :x

thegto

Thank yous DIN1031,

If the code works, I will try to reinstall webboard again. It might something wrong which I don't remember what I did in the beginning.

As I ever told you, I tested this mod on my computer but when I installed on the host side. It shows me this error.

I will do after you confirm the code again.

Bye
Thegto

topiQ

great mod DIN!
it would be nice if it'd be possible to implemtent BBC to the hidden/unhidden image. the CODE tag for example.
and one question: is it normal that the unhidden image is shown below the unhidden text?

ディン1031

Yes it's normal ;).

In the next version (1.5.1) this will be possible, because the hidden and unhidden text much more better to edit ;). I will release it in a few days, after some testings. (It will also be have a working inline edit where the hidden content is not removed by clicking on inline edit).

Bye
DIN1031
Support only via MOD Thread! NO PM Support!
My Forum: ayu][kult Forum
My Mods: My Small Mod Collection
My Parser: DIN1031's ModParser
Current Info: More away the next days, because i've to much work to do :x

ディン1031

New Release :

Version 1.5.1 (19.06.07)
* Overworked the complete Hide Tag Special Options
* Moved to Posts and Topic -> Hide Tag Special in the Admin CP.
+ Unhidden Text and Image Possible
+ Unhidden Content is now in the css class "hiddencontent", with that you can now format the unhidden content
* Reprogrammed Code to make Inline Edit with hidden content possible. (without destroying it).
* Overworked the Group Select
+ Add a lot of Help for Options...
- Turkish is not Included for the New Version (Need a complete new Translation)
- Upgrade is included, only for Version 1.2.7. (This is a complete overwork of the Mod!)
- Removed all not needed Versions...

This is Importend for Upgrader:

A Upgrade is included but make follow things after the Upgrade:

First Thing:
You need to set many things new so that the mod will work correct, so please do this first after you installed the mod!

Second Thing:
Please be sure that you look if the change in the Display.template.php made in all your themes!
Here is the Change:

<edit file>
$themedir/Display.template.php
</edit file>

<search for>
<div class="post"', $message['can_modify'] ? ' id="msg_' . $message['id'] . '"' : '', '>', $message['body'], '</div>', $message['can_modify'] && empty($message['hidden_content']) ? '
</search for>

<replace>
<div class="post"', $message['can_modify'] ? ' id="msg_' . $message['id'] . '"' : '', '>', $message['body'], '</div>', $message['can_modify'] ? '
</replace>

This Change is needed to remove some error messages in you error log, so please don't forget this :).




So, hf with the new version :).

Bye
DIN1031
Support only via MOD Thread! NO PM Support!
My Forum: ayu][kult Forum
My Mods: My Small Mod Collection
My Parser: DIN1031's ModParser
Current Info: More away the next days, because i've to much work to do :x

Advertisement: