News:

SMF 2.1.2 has been released! Take it for a spin! Read more.

Main Menu

Hide Tag Special

Started by enik, April 11, 2005, 03:41:07 PM

Previous topic - Next topic

souluna

okey thanks DIN, i will try frst :)

xtremecruiser

I had it installed and after the upgrade to 1.1 RC2 it wont install again.

Quadro

#142
I from russia, and nobody can not me to help.
what do that hidden saw right after to registrations, rather then after accompaniment of the topic?

ディン1031

Quote from: Quadro on January 01, 2006, 11:13:49 AM
I from russia, and nobody can not me to help.
what do that hidden saw right after to registrations, rather then after accompaniment of the topic?

Sorry i don't know nothing about that <<... (okay i don't know what you mean *runs*).

Quote from: xtremecruiser on December 31, 2005, 10:14:53 PM
I had it installed and after the upgrade to 1.1 RC2 it wont install again.
Oh a new realease of smf... i didn't have the time to test it :x, i try it today or tomorrow ;).

Bye
DIN1031
Support only via MOD Thread! NO PM Support!
My Forum: ayu][kult Forum
My Mods: My Small Mod Collection
My Parser: DIN1031's ModParser
Current Info: More away the next days, because i've to much work to do :x

xtremecruiser

Quote from: din1031 on January 02, 2006, 04:30:31 AM
Quote from: Quadro on January 01, 2006, 11:13:49 AM
I from russia, and nobody can not me to help.
what do that hidden saw right after to registrations, rather then after accompaniment of the topic?

Sorry i don't know nothing about that <<... (okay i don't know what you mean *runs*).

Quote from: xtremecruiser on December 31, 2005, 10:14:53 PM
I had it installed and after the upgrade to 1.1 RC2 it wont install again.
Oh a new realease of smf... i didn't have the time to test it :x, i try it today or tomorrow ;).

Bye
DIN1031

I have found some do, some dont with the new RC2

Quadro

I want see hidden [hide] text right now after registration,
but not after accompaniments of the message to the topic.

ディン1031

Quote from: Quadro on January 02, 2006, 11:04:39 PM
I want see hidden [hide] text right now after registration,
but not after accompaniments of the message to the topic.
i sent you a pm ;).

Bye
DIN1031
Support only via MOD Thread! NO PM Support!
My Forum: ayu][kult Forum
My Mods: My Small Mod Collection
My Parser: DIN1031's ModParser
Current Info: More away the next days, because i've to much work to do :x

ディン1031

Quote from: xtremecruiser on January 02, 2006, 09:20:09 AM
I have found some do, some dont with the new RC2

Version 1.16

This Version Work only in 1.1RC2 (and no other Versions of SMF :x)

Bye
DIN1031
Support only via MOD Thread! NO PM Support!
My Forum: ayu][kult Forum
My Mods: My Small Mod Collection
My Parser: DIN1031's ModParser
Current Info: More away the next days, because i've to much work to do :x

xtremecruiser

Quote from: din1031 on January 03, 2006, 02:04:00 PM
Quote from: xtremecruiser on January 02, 2006, 09:20:09 AM
I have found some do, some dont with the new RC2

Version 1.16

This Version Work only in 1.1RC2 (and no other Versions of SMF :x)

Bye
DIN1031

got a tone of errors but it works

Warning: gzwrite(): supplied argument is not a valid stream resource in xxxxxxxxxx/Sources/Subs-Package.php

ディン1031

#149
Quote from: xtremecruiser on January 03, 2006, 04:18:46 PM
Quote from: din1031 on January 03, 2006, 02:04:00 PM
Quote from: xtremecruiser on January 02, 2006, 09:20:09 AM
I have found some do, some dont with the new RC2

Version 1.16

This Version Work only in 1.1RC2 (and no other Versions of SMF :x)

Bye
DIN1031

got a tone of errors but it works

Warning: gzwrite(): supplied argument is not a valid stream resource in xxxxxxxxxx/Sources/Subs-Package.php
Hmm this one is new XD. I think thats RC2 error :x. (Or because of the not existing german language file *thinking*).

And the error 512: parseBoardMod(): The filename 'Themes/default/Display.template.php' is not a full path!
is something i don't know how to remove... i told the question in a other thread but i didn't became a answer... (and as long as it work ;)).

Bye
DIN1031
Support only via MOD Thread! NO PM Support!
My Forum: ayu][kult Forum
My Mods: My Small Mod Collection
My Parser: DIN1031's ModParser
Current Info: More away the next days, because i've to much work to do :x

xtremecruiser

It works just fine and I was able to un install it and do a re-install

Quote from: din1031 on January 04, 2006, 02:32:03 AM
Quote from: xtremecruiser on January 03, 2006, 04:18:46 PM
Quote from: din1031 on January 03, 2006, 02:04:00 PM
Quote from: xtremecruiser on January 02, 2006, 09:20:09 AM
I have found some do, some dont with the new RC2

Version 1.16

This Version Work only in 1.1RC2 (and no other Versions of SMF :x)

Bye
DIN1031

got a tone of errors but it works

Warning: gzwrite(): supplied argument is not a valid stream resource in xxxxxxxxxx/Sources/Subs-Package.php
Hmm this one is new XD. I think thats RC2 error :x. (Or because of the not existing german language file *thinking*).

And the error 512: parseBoardMod(): The filename 'Themes/default/Display.template.php' is not a full path!
is something i don't know how to remove... i told the question in a other thread but i didn't became a answer... (and as long as it work ;)).

Bye
DIN1031


kat

#151
Hmmmm. Couldn't find anything about the errors I'm getting.

I'm still using SMF 1.05 and I'm trying to install HideTagMod112 and 112a.

On install, I'm getting:

4. Execute Modification ./Sources/Printpage.php  Failure

and

5. Execute Modification ./Sources/Subs.php Failure

which isn't entirely, helpful. :(

Both files are fully write-enabled.

Any clues?

Ta!

DirkDiggler

I had this on the top of my Joomla Site
Notice: Undefined index: hide_hiddentext in /home/browns/public_html/Forum/Sources/Subs.php on line 963

Also when I hide text it just doesnt show, it doesnt give an indication there is hidden text is that normal

BigGunn

I have this installed on my 1.0.5 installation and was trying to alter it to allow Global Mods to see all hidden content without replying and Mods to be able to do so in the forums that they moderate.

Here's the original code before I changed any:

// Find if there a post from you in this thread :) (For the hide tag)
if ($user_info['is_admin'] && !empty($modSettings['hide_adminshouldsee']))
$context['user_post_avaible'] = 1;
elseif (!$user_info['is_guest']) {
$request = db_query("
SELECT ID_MSG, ID_MEMBER
FROM {$db_prefix}messages
WHERE ID_TOPIC = $topic AND ID_MEMBER = $ID_MEMBER
LIMIT 1", __FILE__, __LINE__);

if (mysql_num_rows($request)) $context['user_post_avaible'] = 1;
else $context['user_post_avaible'] = 0;
mysql_free_result($request);
}
else $context['user_post_avaible'] = 0; //Anyway no way you should see it!


I've since changed it to this:

// Find if there a post from you in this thread :) (For the hide tag)
if ($user_info['is_admin'] && !empty($modSettings['hide_adminshouldsee']))
$context['user_post_avaible'] = 1;
elseif ($user_info['is_gmod'] && !empty($modSettings['hide_adminshouldsee']))
$context['user_post_avaible'] = 1;
elseif ($user_info['is_mod'] && !empty($modSettings['hide_adminshouldsee']))
$context['user_post_avaible'] = 1;
elseif (!$user_info['is_guest']) {
$request = db_query("
SELECT ID_MSG, ID_MEMBER
FROM {$db_prefix}messages
WHERE ID_TOPIC = $topic AND ID_MEMBER = $ID_MEMBER
LIMIT 1", __FILE__, __LINE__);

if (mysql_num_rows($request)) $context['user_post_avaible'] = 1;
else $context['user_post_avaible'] = 0;
mysql_free_result($request);
}
else $context['user_post_avaible'] = 0; //Anyway no way you should see it!


The Global Mod part doesn't work, but the Mod part did. Any ideas what I'm doing wrong?

ディン1031

$user_info['is_gmod'] this is not a existing variable in 1.0.5, i think also not in 1.1 ;D you must use $user_settings['ID_GROUP'] == '2' this should be the Global Mod Group :).

new code should something like this (don't forget to load the global $user_settings)


global $user_settings; //important, without this variable, group ids is not avaible.
// Find if there a post from you in this thread :) (For the hide tag)
if (($user_info['is_admin'] || $user_settings['ID_GROUP'] == '2'  || $user_info['is_mod']) && !empty($modSettings['hide_adminshouldsee']))
$context['user_post_avaible'] = 1;
elseif (!$user_info['is_guest']) {
$request = db_query("
SELECT ID_MSG, ID_MEMBER
FROM {$db_prefix}messages
WHERE ID_TOPIC = $topic AND ID_MEMBER = $ID_MEMBER
LIMIT 1", __FILE__, __LINE__);

if (mysql_num_rows($request)) $context['user_post_avaible'] = 1;
else $context['user_post_avaible'] = 0;
mysql_free_result($request);
}
else $context['user_post_avaible'] = 0; //Anyway no way you should see it!
Support only via MOD Thread! NO PM Support!
My Forum: ayu][kult Forum
My Mods: My Small Mod Collection
My Parser: DIN1031's ModParser
Current Info: More away the next days, because i've to much work to do :x

BigGunn

Works great now! Thanks a lot!

I also edited my Modsettings.english.php and changed the one line in there for the adminshouldsee option to read about Admins & Mods seeing it. Hope you don't mind my tweaking your mod like this!  :D

ディン1031

Quote from: BigGunn on January 09, 2006, 04:25:19 AM
Works great now! Thanks a lot!

I also edited my Modsettings.english.php and changed the one line in there for the adminshouldsee option to read about Admins & Mods seeing it. Hope you don't mind my tweaking your mod like this!  :D
Somtimes i add this modorator group and the adiotional groups to the mod :X (i think on the final release of smf 1.1 (new forum, new and better overworked hide mod)).

Bye
DIN1031
Support only via MOD Thread! NO PM Support!
My Forum: ayu][kult Forum
My Mods: My Small Mod Collection
My Parser: DIN1031's ModParser
Current Info: More away the next days, because i've to much work to do :x

kat

Quote from: din1031 on July 01, 2005, 03:27:54 AM
I made a special Version for the Faster Parscode made by Sheepy -> http://www.anetcity.com/bbs/index.php?topic=999.0

This drove me mental!

Would it be wise to put this on the mod page, too?

Ta!

ディン1031

Quote from: kat on January 09, 2006, 03:43:06 PM
Quote from: din1031 on July 01, 2005, 03:27:54 AM
I made a special Version for the Faster Parscode made by Sheepy -> http://www.anetcity.com/bbs/index.php?topic=999.0

This drove me mental!

Would it be wise to put this on the mod page, too?

Ta!
No because it's not s smf standard :X.

Quote from: DirkDiggler on January 08, 2006, 12:09:28 PM
I had this on the top of my Joomla Site
Notice: Undefined index: hide_hiddentext in /home/browns/public_html/Forum/Sources/Subs.php on line 963

Also when I hide text it just doesnt show, it doesnt give an indication there is hidden text is that normal

Öhm did you put some Hidden Text in the Admin Settings and this happend?
Which Version do you use? MUI or the other Version? (Normal the other error should also not happen... that not normal...).

Bye
DIN1031
Support only via MOD Thread! NO PM Support!
My Forum: ayu][kult Forum
My Mods: My Small Mod Collection
My Parser: DIN1031's ModParser
Current Info: More away the next days, because i've to much work to do :x

kat

What about putting a link on that page, explaining why it's there?

I think an awful lot of people have fasterparse installed, my friend...

Just a suggestion. It'll stop people having to trawl through this whole thread. They might not even know that fasterparse interferes with it, after all.

Advertisement: