News:

SMF 2.1.2 has been released! Take it for a spin! Read more.

Main Menu

Hide Tag Special

Started by enik, April 11, 2005, 03:41:07 PM

Previous topic - Next topic

haktanir2

din, the old messages on having a hidden and unhidden image is very confusing

could u pls explain in a new post?

L.G.S

Quote from: desistyle on February 10, 2006, 05:08:00 PM
Quote from: L.G.S on February 10, 2006, 12:50:35 PM
^^ Just use

[img*]img link[/img*] in the hidden text nesage box?
can u tell me how can i do this in smf 1.06

Admin > Features and Options > Find hide area
FREE and LIVE World Cup + Premier League football streams:

www.gamesandgoals.com


quasar

I'm getting an issue with this install.  It's got a problem with the subs.php file in the Soruces folder.  Any reasons why?

mforum

#203
What i did is to use <img src="imagelink"> at admins panel in "What should the text for user without Post in the thread" box...
You can use an unhide image inside hidden part of post, so when a user reply see unhide image along with the hidden part......
as

[*hide*]
[*img*] Unhide Image Link [*/img*]
Whatever is Hidden
[*/hide*]

ArkServer

Quote from: din1031 on February 10, 2006, 05:13:28 PM
Quote from: L.G.S on February 10, 2006, 12:50:35 PM
^^ Just use

[img*]img link[/img*] in the hidden text nesage box?
he want use two pics and i know there is a way XD, but i forgot how to made it :x... i think i post it somewhere in the thread XD.




Quote from: desistyle on February 10, 2006, 05:08:00 PM
can u tell me how can i do this in smf 1.06

Use html code in 1.0x <img src="imagelink"> (because the parse work in a another way).



@ArkServer
Ahh found it (i think)

http://www.simplemachines.org/community/index.php?topic=32954.90
(one page before could also possible, but i think it's somewhere there XD)

Bye
DIN1031

thnx a bunch, till take a look later  8)!

haktanir2

As far as I can see, the hide can only be hidden once in a topic, once someone has replied, he will no longer see anything hidden... am I right?

mforum

Quote from: haktanir2 on February 14, 2006, 01:08:19 PM
As far as I can see, the hide can only be hidden once in a topic, once someone has replied, he will no longer see anything hidden... am I right?

Yes ..!! Thats the idea ...  :)

haktanir2

I got the idea but I would have preferred it to be this way:

I post something hidden, those that reply see the content. Then in the same topic I post another hidden content and that too cannot be seen unless a new reply is made. That way you could make like a trivia topic, rather than opening a new topic for each question.

ディン1031

Quote from: haktanir2 on February 15, 2006, 06:40:53 AM
I got the idea but I would have preferred it to be this way:

I post something hidden, those that reply see the content. Then in the same topic I post another hidden content and that too cannot be seen unless a new reply is made. That way you could make like a trivia topic, rather than opening a new topic for each question.
Nearly impossible to made :x (okay nothing is impossible XD), if you want this you must made a extra table who check only if the user already post after this post but also check if the user post before to see the old content XD, it's a lot work to do something like this. (Okay Other way is to check before and after for each post in the display, but this take a lot load time XD, because it must check it for each post who loaded.)

Hmmm there is a other hide mode evtl this mod can do it XD, but i don't know. (This mod work in a complete diffrent way the mod i made).

(But i think this mod can also not do this XD).

Bye
DIN1031
Support only via MOD Thread! NO PM Support!
My Forum: ayu][kult Forum
My Mods: My Small Mod Collection
My Parser: DIN1031's ModParser
Current Info: More away the next days, because i've to much work to do :x

haktanir2

How about if a different title is used within the same topic, would that simplify things?

For example in the trivia topic I post a message with the title Question 1. Replies to it become RE: Question 1. Then I post message with title Question 2.

cH40z-Lord

Your Mod doesn't work in 1.1 RC2 ???

If i post something with  [hide]text[/hide]  then I'll see  [hide]text[/hide]  ... :(

I installed it via. the packet manager... and it said it's installed now +.+"

haktanir2

go to admin panel and fill in the related parts to the mod

mforum

Quote from: cH40z-Lord on February 15, 2006, 08:49:52 AM
Your Mod doesn't work in 1.1 RC2 ???

If i post something with  [hide]text[/hide]  then I'll see  [hide]text[/hide]  ... :(

I installed it via. the packet manager... and it said it's installed now +.+"

seems like your installation wasn`t succesfull

ディン1031

#213
Quote from: haktanir2 on February 15, 2006, 08:35:22 AM
How about if a different title is used within the same topic, would that simplify things?

For example in the trivia topic I post a message with the title Question 1. Replies to it become RE: Question 1. Then I post message with title Question 2.
Hmmm i've think a little about that and i think i've got a solution, but i must look if all variables are avaible XD. Give me some time :), i sent you a pm, because you must test it (i've no time to test it). (But i need a little bit time XD.)

Okay i sent you a Change info for each version :P, you've luck that i've got a little bit time :x...

Quote from: mforum on February 16, 2006, 04:55:20 AM
Quote from: cH40z-Lord on February 15, 2006, 08:49:52 AM
Your Mod doesn't work in 1.1 RC2 ???

If i post something with  [hide]text[/hide]  then I'll see  [hide]text[/hide]  ... :(

I installed it via. the packet manager... and it said it's installed now +.+"

seems like your installation wasn`t succesfull

hehe yes it's seems like iot's not installed :P, and i know! that it work ;).

Bye
DIN1031
Support only via MOD Thread! NO PM Support!
My Forum: ayu][kult Forum
My Mods: My Small Mod Collection
My Parser: DIN1031's ModParser
Current Info: More away the next days, because i've to much work to do :x

NiKoLiN

Quote from: mforum on February 14, 2006, 04:05:08 AM
What i did is to use <img src="imagelink"> at admins panel in "What should the text for user without Post in the thread" box...
You can use an unhide image inside hidden part of post, so when a user reply see unhide image along with the hidden part......
as

[*hide*]
[*img*] Unhide Image Link [*/img*]
Whatever is Hidden
[*/hide*]


Well i did this and it worked out good. the thing is how do i put the HIDE image?

Another thing is a bug that i found (i thing somebody else already found it)
In a hide text, if you press QUOTE then you see all the hidden text. I just the serch in this forum, but i didn'd find anything.

Sorry for my english...i'm spanish

mforum

Quote from: NiKtOrDo on February 19, 2006, 12:40:29 PM

Another thing is a bug that i found (i thing somebody else already found it)
In a hide text, if you press QUOTE then you see all the hidden text. I just the serch in this forum, but i didn'd find anything.

Sorry for my english...i'm spanish

Certainly NOT !!! when you press quote you see :
Quote
<img src="http://**********.com/hidenimg.gif">
When you press Modify you see all text of post along with tags and thats normal !!
I havent found a way that hidden part is seen without reply....


Quote
Well i did this and it worked out good. the thing is how do i put the HIDE image?

you upload the image on your server lets say http://yourdomain.com/hidden.gif
then you put in box where the hidden txt shows: <img src="http://yourdomain.com/hidden.gif">

Ok, if you "quote" post with hidden txt the hidden txt shows on original post, thats normal couse quote is a reply too  :)

NiKoLiN

Quote from: mforum on February 20, 2006, 05:56:36 AM
Quote from: NiKtOrDo on February 19, 2006, 12:40:29 PM
In a hide text, if you press QUOTE then you see all the hidden text.

Certainly NOT !!! when you press quote you see :
Quote
<img src="http://**********.com/hidenimg.gif">

Quote
you upload the image on your server lets say http://yourdomain.com/hidden.gif
then you put in box where the hidden txt shows: <img src="http://yourdomain.com/hidden.gif">

Well if i press MODIFY it's normal that it shows everything, buy for strange reasonif somebody press the QUOTE botton he can see everything in the quotet text without answering.
maybe if i put the hide image it will do like you said

quasar

#217
Quote from: ronitvohra on November 08, 2005, 01:12:02 AM
problem solved.i edited the Post.template.php.......and instead of glow button...i changes it to [hide][/hide]
so glow button will tag hide tag.......

I love smf........and thx for the hidden tag mod...

If you want to add an image to the code instead of replacing one, add this line into Post.template.php
'hide' => array('code' => 'hide', 'before' => '[hide]', 'after' => '[/hide]', 'description' => $txt[631]),
after this line:
'list' => array('code' => 'list', 'before' => '[list]\n[li]', 'after' => '[/li]\n[li][/li]\n[/list]', 'description' => $txt[261]),

Then add this message into Post.english.php (or appropriate language file):
$txt[631] = 'Spoiler/Hide Tags';
after this line:
$txt[532] = 'Font Size';
$txt[533] = 'Font Face';


Then create an image 23 x 22 pixels on a transparent background, add it to the folder 'images>bbc' of whichever template you are using, naming the file 'hide.gif'.

You should have a working image.

ディン1031

#218
Quote from: NiKtOrDo on February 20, 2006, 08:36:22 AM
Quote from: mforum on February 20, 2006, 05:56:36 AM
Quote from: NiKtOrDo on February 19, 2006, 12:40:29 PM
In a hide text, if you press QUOTE then you see all the hidden text.

Certainly NOT !!! when you press quote you see :
Quote
<img src="http://**********.com/hidenimg.gif">

Quote
you upload the image on your server lets say http://yourdomain.com/hidden.gif
then you put in box where the hidden txt shows: <img src="http://yourdomain.com/hidden.gif">

Well if i press MODIFY it's normal that it shows everything, buy for strange reasonif somebody press the QUOTE botton he can see everything in the quotet text without answering.
maybe if i put the hide image it will do like you said

The hidden content should nerver shown... any errors on the install?
Or if you switch on admin can see all, than you see it :X (I think you can see but i'm not sure xD). (Even if you not have a text, at least the mod replace it with a Space).

Hmmm i try it with a install without any settings changed, but i'm sure it work :).

Öhm which forum Version show this problem?



@quasar:
Thx for the help =).

Bye
DIN1031
Support only via MOD Thread! NO PM Support!
My Forum: ayu][kult Forum
My Mods: My Small Mod Collection
My Parser: DIN1031's ModParser
Current Info: More away the next days, because i've to much work to do :x

NiKoLiN


Advertisement: