• Welcome to Simple Machines Community Forum. Please login or sign up.

Strange XML tag error

Started by iioc, February 11, 2005, 01:36:11 AM

Previous topic - Next topic

iioc

I have installed the mambo bridge and everything was working fine with my mambo template and everything... Then I start doing some customizing of the mambo template and when I'm done I get this error when I go to "forums"....

The XML page cannot be displayed
Cannot view XML input using XSL style sheet. Please correct the error and then click the Refresh button, or try again later.


--------------------------------------------------------------------------------

End tag 'td' does not match the start tag 'img'. Error processing resource 'hxxp:xxxxxx.org/component/option,com_smf/... [nonactive]

        <td width="164"><img src="hxxp:xxxxx.org/templates/vr_corp/images/topimg1.gif [nonactive]" width="164" height="4...


...I have my forums wrapped and did not change anything in the smf theme or anything... just my mambo theme...

So then I reupload the original template that I KNOW works becuase it was fine earlier and still the same error.... I try a completly different template and its fine....

What in the world is wrong??? It was fine earlier

iioc


trusk

April 12, 2005, 04:25:56 AM #2 Last Edit: April 12, 2005, 04:32:31 AM by trusk
how did you fix it? i have the same error. it won't display my mambo template if i patch it with the smf bridge (from mambohacks, Mambo-SMFIntegrationv120-Final) and the error message goes as follows:
The XML page cannot be displayed
Cannot view XML input using XSL style sheet. Please correct the error and then click the Refresh button, or try again later.


--------------------------------------------------------------------------------

A name contained an invalid character. Error processing resource 'http://thecarebears.shrinkhead.ch/wow/index.php' [nofollow];. Line 5...

                      <td nowrap><span class="pathway">Cave </span>
--------------------------------^

and this happens only in IE... it works in firefox!

i use mambo version 4.5.1 and the Mambo-SMFIntegrationv120-Final bridge. the link is the one above, and the error is only displayed in internet explorer
mambo and smf is on the same database...
here my system info:
FreeBSD server15.hostpoint.ch [nofollow] 4.10-RELEASE-p5 FreeBSD 4.10-RELEASE-p5 #0: Wed i386 
Database Version:  4.1.10a 
PHP Version:  4.3.10 
Web Server:  Apache/1.3.33 (Unix) mod_auth_passthrough/1.8 FrontPage/5.0.2.2510a mod_log_bytes/1.2 mod_bwlimited/1.4 PHP/4.3.10 
WebServer to PHP interface:  apache 
Mambo Version:  Version: Mambo 4.5.1a Stable [Three For Rum] 05/10/2004 16:12 GMT 
User Agent:  Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; Hot Lingo 2.2; .NET CLR 1.0.3705; .NET CLR 1.1.4322) 
Relevant PHP Settings:  Safe Mode:  OFF 

System  FreeBSD server15.hostpoint.ch [nofollow] 4.10-RELEASE-p5 FreeBSD 4.10-RELEASE-p5 #0: Wed i386 
Build Date  Mar 15 2005 11:54:11 
Configure Command  './configure' '--with-apxs=/usr/local/sbin/apxs' '--prefix=/usr/local' '--with-layout=GNU' '--disable-pear' '--enable-versioning' '--enable-memory-limit' '--enable-discard-path' '--with-zlib-dir=/usr' '--with-regex=php' '--disable-cli' '--disable-all' '--enable-bcmath' '--with-bz2=/usr' '--enable-calendar' '--enable-ctype' '--with-curl=/usr/local' '--with-dom=/usr/local' '--with-dom-xslt=/usr/local' '--with-dom-exslt=/usr/local' '--enable-exif' '--enable-ftp' '--with-gd=/usr/local' '--enable-gd-native-ttf' '--with-freetype-dir=/usr/local' '--with-t1lib=/usr/local' '--with-jpeg-dir=/usr/local' '--with-png-dir=/usr/local' '--with-gettext=/usr/local' '--with-iconv-dir=/usr/local' '--with-mcrypt=/usr/local' '--with-mhash=/usr/local' '--with-mime-magic=/usr/share/misc/magic.mime' '--with-ming=/usr/local' '--with-mysql=/usr/local' '--with-ldap=/usr/local' '--with-openssl-dir=/usr' '--with-openssl=/usr' '--enable-overload' '--with-pdflib=/usr/local' '--with-pcre-regex=yes' '--enable-posix' '--enable-session' '--enable-sockets' '--enable-wddx' '--with-expat-dir=/usr/local' '--enable-xml' '--with-xmlrpc' '--enable-xslt' '--with-xslt-sablot=/usr/local' '--with-zip=/usr/local' '--with-zlib=yes' '--with-imap=/usr/local' '--with-imap-ssl=/usr/local' 
Server API  Apache 
Virtual Directory Support  disabled 
Configuration File (php.ini) Path  /usr/local/etc/php.ini 
PHP API  20020918 
PHP Extension  20020429 
Zend Extension  20021010 
Debug Build  no 
Thread Safety  disabled 
Registered PHP Streams  php, http, ftp, https, ftps, compress.bzip2, compress.zlib 


thank you for your help.

[Unknown]

Internet Explorer is checking your xhtml's validity, and there are problems in it.  For example, you've got "nowrap" there without a value.  It's value should be "nowrap" as well, for it to be valid xml/xhtml.

-[Unknown]

trusk

thanks to the admin from mambohacks i have the solution.
just remove
<!-- Begin Mambo-SMF -->
<!-- End Mambo-SMF -->
from the patched template.

Advertisement: