Advertisement:

Author Topic: Problem sa prevodom?  (Read 7456 times)

Offline Bezimeni

  • Semi-Newbie
  • *
  • Posts: 32
Problem sa prevodom?
« on: August 17, 2009, 01:38:37 AM »
Imam problem sa Srpskim cirilicnim prevodom i kolko vidim enkoding je utf-8 ali i dalje prevod ne radi kako treba, tacnije nijedno slovo nije u redu.  Sta moze da bude problem ako ocigledno enkoding nije u pitanju?

Evo ovo izlazi umesto slova  ��� �������� ��� ��������� �� ��������� ������� ���������� ������. ������ ����� ������� �� ���� ������������, ����� �� ���� ������ �� ��������� �������� ��� ������.

Offline dan555

  • Full Member
  • ***
  • Posts: 654
    • SF tim
Re: Problem sa prevodom?
« Reply #1 on: August 17, 2009, 03:42:11 AM »
Probaj da u Settings.php pod $db_character_set = 'utf8'; staviš 'utf-8'. Ako ti je već sa crticom, probaj bez nje.

Offline Bezimeni

  • Semi-Newbie
  • *
  • Posts: 32
Re: Problem sa prevodom?
« Reply #2 on: August 17, 2009, 11:27:06 AM »
Hvala na pomoci ali ne vredi.  Dodao sam crtu pa se cak i engleski zezno a sa cirilicom isti problem...

Offline Dzonny

  • Local Moderator
  • SMF Super Hero
  • *
  • Posts: 11,905
  • Gender: Male
  • No sleep...
    • dzontra.nikola on Facebook
    • Dzonny on GitHub
    • dzontranikola on LinkedIn
    • @opusteniforum on Twitter
    • Samo opusteno
Re: Problem sa prevodom?
« Reply #3 on: August 17, 2009, 02:08:20 PM »
Polgedaj u phpMyAdminu, koji ti je character set postavljen pa promeni po potrebi.

Offline Bezimeni

  • Semi-Newbie
  • *
  • Posts: 32
Re: Problem sa prevodom?
« Reply #4 on: August 18, 2009, 02:31:00 AM »
Ne vredi ni to probao sam.  :(    Nego nesto se razmisljam da nisam mozda lose instalirao jezik a uradio sam sledece...
Raspakovo zip fajl i prekopirao Default, Babilon i onaj treci folder u folder Themes i to je to.  Dal sam trebao jos nesto mozda da uradim?  I da ne zaboravim SMF je 1.1.10 i ne koristim ove default teme...

Offline Dzonny

  • Local Moderator
  • SMF Super Hero
  • *
  • Posts: 11,905
  • Gender: Male
  • No sleep...
    • dzontra.nikola on Facebook
    • Dzonny on GitHub
    • dzontranikola on LinkedIn
    • @opusteniforum on Twitter
    • Samo opusteno
Re: Problem sa prevodom?
« Reply #5 on: August 18, 2009, 03:48:06 AM »
Dobro je to.
Admin > Forum Maintenance > Convert the database and data to UTF-8

Offline Bezimeni

  • Semi-Newbie
  • *
  • Posts: 32
Re: Problem sa prevodom?
« Reply #6 on: August 18, 2009, 10:13:45 AM »
Pazi ovako pogledao sam u bazi, baza je vec utf8 kao i forum a u admin panelu nemam to sto si predlozio vec samo ovo

Optimize all tables to improve performance.
Check all files against current versions.
Find and repair any errors.
Recount all forum totals and statistics.
Empty out unimportant logs.
Convert HTML-entities to UTF-8 characters

E sad dal je ovo zadnje to na sta si mislio i dal je to sigurno da se ne zezne baza i slicno?

Offline dan555

  • Full Member
  • ***
  • Posts: 654
    • SF tim
Re: Problem sa prevodom?
« Reply #7 on: August 18, 2009, 12:08:15 PM »
Једно питање, да ли ти се ћирилица не види у порукама корисника или у самом форуму, у менију и разним линковима и дугмићима?

Колико видим, уместо карактера јављају се "празни" карактери. Пробај да ставиш фајл (преименуј га ако је потребно) за индекс страну који прилажем у Themes/default/languages па да видимо да ли се почетна страна добро приказује.
У ФТП подеси аутоматско подешавање врсте фајла при преносу (transfer mode).

Offline Bezimeni

  • Semi-Newbie
  • *
  • Posts: 32
Re: Problem sa prevodom?
« Reply #8 on: August 19, 2009, 02:56:20 AM »
Quote
Једно питање, да ли ти се ћирилица не види у порукама корисника или у самом форуму, у менију и разним линковима и дугмићима?

Kad prebacim Language na Cirilicu ne vidi se nigde cirilica samo ona prazna slova s upitnicima...
« Last Edit: August 19, 2009, 03:16:01 AM by Bezimeni »

Offline Bezimeni

  • Semi-Newbie
  • *
  • Posts: 32
Re: Problem sa prevodom?
« Reply #9 on: August 19, 2009, 03:06:13 AM »
Sad barem sa tvojim fajlom prikazuje normalno naslovnu stranu i dugmice ali ne prikazuje uopste opcije u admin panelu kao i tekst u Help, Register, i ostalim menijima...   ;)

Offline dan555

  • Full Member
  • ***
  • Posts: 654
    • SF tim
Re: Problem sa prevodom?
« Reply #10 on: August 19, 2009, 03:30:00 PM »
Значи да је до фајлова. Скини поново превод, отпакуј га и пребаци фајлове директно у Themes/default/languages/ то би требало да реши проблем.

Offline Bezimeni

  • Semi-Newbie
  • *
  • Posts: 32
Re: Problem sa prevodom?
« Reply #11 on: August 19, 2009, 04:11:18 PM »
Ja ako napisem sta je zapravo bio problem smejace mi se ljudi ali na greskama se uci...   :-\

Ladno sam umesto ovog fajla smf_1-1-10_serbian_cyrillic-utf8  skinuo i instalirao onaj prvi smf_1-1-10_serbian_cyrillic
pa zato nije ni htelo   :D  Odo skocim s mosta.   U svkom slucaju hvala svima na pomoci  :)