• Welcome to Simple Machines Community Forum. Please login or sign up.

[Theme] SMFone

Started by A.M.A, April 15, 2005, 07:01:21 PM

Previous topic - Next topic

JC

Hi, I love the design  ;) but im having a little problem im trying to change the user avatar, because every time that a usre post a message their avatar looks like inside a box that has scroll arrows, so i need to change that so we can see the image to the orginal size...

I was traying to change that in the avatars seccion and on allow users to chose external avatar i change that field to =0   and  =0 and nothing happens...


I hope you guys can help

Thank You amazin theme...

Burpee

It's been mentioned here, here and here. I wouldn't be surprised if it has been mentioned in other places as well.



pierse

Quote from: A.M.A on May 25, 2005, 06:20:32 AM
Aravot
Images attached.


OIDanTheManIO
http://www.simplemachines.org/community/index.php?topic=33352.msg261691#msg261691
Images attached .. http://www.simplemachines.org/community/index.php?topic=33352.msg268325#msg268325

d3v
As Burpee said, you need to modify the following images to remove that line:
re_top_4.gif , re_top_4.gif and re_top_6.gif


These are great images... however, they do not match the images supplied with the theme.  Anyway they can max??  These are larger (16X16) verses the images with the theme (16X13).  As well has not being "greyed out"  These images are bold and three deminisional, while the ones with the theme are almost "greyed out" and two deminisional.  Can we fix?  I need images for forum and downloads, however I was going to use these images.  Any help would be great!

A.M.A

lchance
Glad you got it working.

d3v
Have you applied all the changes i.e. the first and second one.

Thanks Burpee for the help.

pierse
Hope you like the attached ones.
Really sorry .. real life is demanding my full attention .. will be back soon hopefully :)

d3v

Yeah I did A.M.A. There's a link included with the modified version display.template.php so u can see what's left if you interested. I'm going to triple check it again right now, but it was a clean cut job as far as I remember.

A.M.A

I do not recommend removing the header as it holds useful information, but if you still need to, then in Display.template.php look for and remove:
<tr>
<td width="100%" height="25" class="titlebg">
<div>
<div class="smalltext" style="float: right;">« <b>', !empty($message['counter']) ? $txt[146] . ' #' . $message['counter'] : '', ' ', $txt[30], ':</b> ', $message['time'], ' »</div>
<a href="', $message['href'], '"><img src="', $settings['images_url'], '/post/' . $message['icon'] . '.gif" alt="" border="0" /></a> <b><a href="', $message['href'], '">', $message['subject'], '</a></b>
</div>
</td>
</tr>


The bottom part, look for:
if ($settings['linktree_inline'])
echo '
<td valign="top" align="left">', theme_linktree(), '</td> ';
echo '
<td valign="top" align="right" class="smalltext"> <span class="nav"> ', $context['previous_next'], '</span></td>
and only delete ', theme_linktree(), ' and  <span class="nav"> ', $context['previous_next'], '</span> from it.
Really sorry .. real life is demanding my full attention .. will be back soon hopefully :)

d3v

June 15, 2005, 05:37:33 AM #286 Last Edit: June 15, 2005, 05:48:15 AM by d3v
You are right, I'm going to keep the header. Didn't think when I made that post. The bottom breadcrumbs is what's still there. This portion of the code that you pasted before failed for me:

$buttonArray = array();
if ($context['can_reply'])
$buttonArray[] = '<a href="' . $scripturl . '?action=post;topic=' . $context['current_topic'] . '.' . $context['start'] . ';num_replies=' . $context['num_replies'] . '">' . ($settings['use_image_buttons'] ? '<img src="' . $settings['images_url'] . '/' . $context['user']['language'] . '/reply.gif" alt="' . $txt[146] . '" border="0" />' : $txt[146]) . '</a>';
if ($context['can_mark_notify'])
$buttonArray[] = '<a href="' . $scripturl . '?action=notify;sa=' . ($context['is_marked_notify'] ? 'off' : 'on') . ';topic=' . $context['current_topic'] . '.' . $context['start'] . ';sesc=' . $context['session_id'] . '" onclick="return confirm(\'' . ($context['is_marked_notify'] ? $txt['notification_disable_topic'] : $txt['notification_enable_topic']) . '\');">' . ($settings['use_image_buttons'] ? '<img src="' . $settings['images_url'] . '/' . $context['user']['language'] . '/notify.gif" alt="' . $txt[131] . '" border="0" />' : $txt[131]) . '</a>';

// Another special case, similar to above but reversed.  Show "add poll" unless they can't - then show unread here too.
if ($context['can_add_poll'])
$buttonArray[] = '<a href="' . $scripturl . '?action=post;poll;msg=' . $context['topic_first_message'] . ';topic=' . $context['current_topic'] . '.' . $context['start'] . ';sesc=' . $context['session_id'] . '">' . ($settings['use_image_buttons'] ? '<img src="' . $settings['images_url'] . '/' . $context['user']['language'] . '/addpoll.gif" alt="' . $txt['add_poll'] . '" border="0" />' : $txt['add_poll']) . '</a>';
elseif ($context['user']['is_logged'] && $settings['show_mark_read'])
$buttonArray[] = '<a href="' . $scripturl . '?action=markasread;sa=topic;topic=' . $context['current_topic'] . '.' . $context['start'] . '">' . ($settings['use_image_buttons'] ? '<img src="' . $settings['images_url'] . '/' . $context['user']['language'] . '/markunread.gif" alt="' . $txt['mark_unread'] . '" border="0" />' : $txt['mark_unread']) . '</a>';

if ($context['can_send_topic'])
$buttonArray[] = '<a href="' . $scripturl . '?action=sendtopic;topic=' . $context['current_topic'] . '.0">' . ($settings['use_image_buttons'] ? '<img src="' . $settings['images_url'] . '/' . $context['user']['language'] . '/sendtopic.gif" alt="' . $txt[707] . '" border="0" />' : $txt[707]) . '</a>';
$buttonArray[] = '<a href="' . $scripturl . '?action=printpage;topic=' . $context['current_topic'] . '.0" target="_blank">' . ($settings['use_image_buttons'] ? '<img src="' . $settings['images_url'] . '/' . $context['user']['language'] . '/print.gif" alt="' . $txt[465] . '" border="0" />' : $txt[465]) . '</a>';

echo implode($context['menu_separator'], $buttonArray);

echo '&nbsp;
</td>
</tr>
</table>
</td>
</tr>
</table>
</div>


When I removed that I got a parsing error. Going to go through it right now to see if I can remove line by line

P.S.

if ($settings['linktree_inline'])
echo '
<td valign="top" align="left">', theme_linktree(), '</td> ';
echo '
<td valign="top" align="right" class="smalltext"> <span class="nav"> ', $context['previous_next'], '</span></td>


That's done.

EDIT: Actually this is what happened. I have normal top breadcrumbs on top of every page, except for message pages where I now have bottom breadcrumbs only. Seems that we removed those instead.
My Goal is to have standard top breadcrumbs on every page, and not to have them on the bottom. I think I can probably do this on my own by comparing code to original template. Thanks once again for your help A.M.A. as I have mentioned I put your name on my Credit page since you answered 10+ of my posts.

pierse

Absolutely the best!  Thanks!!!

d3v

Maybe it's not that easy. I went through all 5 files that had reference to theme_linktree and changed the setting from "bottom" to "top" where I could. still on my post pages breadcrumbs show up on the bottom only and not on top section. All my files are heavily customized so it's a bit too late to re-upload freshies. Can you please tell me which file and which setting ( if it's not theme_linktree ) is responsible for showing breadcrumbs. They are fine on every other pages, but post page: Screenie attached:


JC

June 16, 2005, 11:50:55 PM #289 Last Edit: June 16, 2005, 11:54:42 PM by JC
Thank you for your help another thing the green theme is not available any more???

And the forum name some times appears and some times not, i have to hilade it and then it appears...


THank you

Burpee

The green theme is the default theme, named "SMFone_theme".

What on earth does hilade mean? :P

JC

A mean  hightlight  in the top left corner the name should appear but some times it does and some times not, if it doen't appear if you hightlight  that section it will appear...

You can see it from here...


hxxp:www.hackerlatino.net/foro [nonactive]


Thank  you for your help and how do i take off my logo in the top right corner?

thanks

azuregenesis

it seems to not be compatible with Bloc's Tinyportal mod. :( oh well.

is there a TP converted version of this?


flychica

I really like this theme, only problem is how the posts are set up.  I want them to be like these boards w/ the member info., avatar, etc. all to the left and the message to the right.  Anyway of getting it like that?

I'd like to note, I have very lil' experience w/ php scripting.  As far as going into it and reading it and replacing it w/ other codes.  Its confusing to my eyes....lol.  But I'm willing to try w/ some good instructions?


noex

Quote from: flychica on June 19, 2005, 01:57:50 PM
I really like this theme, only problem is how the posts are set up.  I want them to be like these boards w/ the member info., avatar, etc. all to the left and the message to the right.  Anyway of getting it like that?

I'd like to note, I have very lil' experience w/ php scripting.  As far as going into it and reading it and replacing it w/ other codes.  Its confusing to my eyes....lol.  But I'm willing to try w/ some good instructions?

Download the Display.template.php from the first Post:

Quote from: A.M.A on April 15, 2005, 07:01:21 PM

Notes
....
5. See attached files for badges and a Display.template.php which you can copy it over the original one to get same look as the default one.[/size]
"Jetzt, wo ich weiß wie es geht, versteh ich auch die Gebrauchsanleitung"

flychica

June 19, 2005, 05:16:05 PM #295 Last Edit: June 19, 2005, 05:21:33 PM by flychica
Thank you Noex...that made that simple....Question, what are badges?  Also is there anything to make the messageindex template and boardindex...set up like the regular boards?....

Puc conDoin

This theme is looking great! I only like to have the double-rowed topic listing changed to one row per topic.

How can I change that in the code?

noex

Quote from: flychica on June 19, 2005, 05:16:05 PM
Thank you Noex...that made that simple....Question, what are badges?  Also is there anything to make the messageindex template and boardindex...set up like the regular boards?....

remove the MessageIndex.template.php and the BoardIndex.template.php from your (SMFOne) Theme Folder or just rename them
"Jetzt, wo ich weiß wie es geht, versteh ich auch die Gebrauchsanleitung"

Burpee

Quote from: Puc conDoin on June 20, 2005, 03:23:50 PM
This theme is looking great! I only like to have the double-rowed topic listing changed to one row per topic.

How can I change that in the code?

Remove MessageIndex.template.php and it will give you the default (one row per topic) view.

A.M.A

Burpee - noex
Thanks for the help .. I really appreciate it.


d3v
The code I've posted should remove the theme link tree from the bottom when I tested it.

JC
in index.template.php look for and remove:
// This part is the logo and forum name.  You should be able to change this to whatever you want...
    if (empty($settings['your_logo']))
{
echo '
    <div style="float: right;">
      <img src="', $settings['images_url'], '/smflogo.gif" width="250" alt="" />
    </div>';
}
    else
{
echo '
    <div style="float: right;">
      <img src="', $settings['your_logo'], '" style="float: right;" alt="" />
    </div>';
}


azuregenesis
sorry, but there is not. I may converted to TP when it is released.

Puc conDoin
in MessageIndex.template.php look for:
   <div>
       <div style="overflow: auto; width: 26%; float: right;">';
if ($settings['images_url'] != $settings['theme_url'] . '/images' || file_exists($settings['theme_dir'] . '/images/icons/last_post.gif'))
echo '
          <a href="', $topic['last_post']['href'], '"><img src="', $settings['images_url'], '/icons/last_post.gif" alt="', $txt[111], '" title="', $txt[111], '" border="0" style="float: left;" /></a>';
echo '
          <span class="smalltext">
   ', $topic['last_post']['time'], '<br />
   ', $txt[525], ' ', $topic['last_post']['member']['link'], '
          </span>
       </div>
   ', $topic['first_post']['link'];
// Is this topic new? (assuming they are logged in!)
if ($topic['new'] && $context['user']['is_logged'])
echo '
   <a href="', $scripturl, '?topic=', $topic['id'], '.from', $topic['newtime'], '#new"><img src="', $settings['images_url'], '/', $context['user']['language'], '/new.gif" alt="', $txt[302], '" border="0" /></a>';
echo '
   <span class="smalltext">', $topic['pages'], '</span>
   </div>

cut it and paste it just right above the <div> in the following lines:
<td class="windowbg2" valign="middle" width="100%">
<div>
<div style="float: right;">';
// Show the quick moderation options?
Really sorry .. real life is demanding my full attention .. will be back soon hopefully :)

Advertisement: