Advertisement:

Author Topic: Upgrader cannot find crucial files  (Read 1758 times)

Offline Catalyst

  • Semi-Newbie
  • *
  • Posts: 21
Upgrader cannot find crucial files
« on: June 13, 2017, 08:36:58 PM »
So, I'm trying to upgrade from 1.1.13 to 2.0.14 and downloaded the large upgrade package, smf_2-0-14_upgrade.zip. I used FileZilla to move everything over, overwriting the old files. But I'm getting these:

Notice: Undefined index: upgrade_overall_progress in /home/catalyst7/lemuria.catalyst-pub.com/upgrade.php on line 3511

Notice: Undefined index: upgrade_time_elapsed in /home/catalyst7/lemuria.catalyst-pub.com/upgrade.php on line 3536
: 0
Notice: Undefined index: upgrade_time_mins in /home/catalyst7/lemuria.catalyst-pub.com/upgrade.php on line 3537
, 1
Notice: Undefined index: upgrade_time_secs in /home/catalyst7/lemuria.catalyst-pub.com/upgrade.php on line 3537

Notice: Undefined index: upgrade_step in /home/catalyst7/lemuria.catalyst-pub.com/upgrade.php on line 3502
1: Login

Notice: Undefined index: upgrade_step in /home/catalyst7/lemuria.catalyst-pub.com/upgrade.php on line 3502
2: Upgrade Options

Notice: Undefined index: upgrade_step in /home/catalyst7/lemuria.catalyst-pub.com/upgrade.php on line 3502
3: Backup

Notice: Undefined index: upgrade_step in /home/catalyst7/lemuria.catalyst-pub.com/upgrade.php on line 3502
4: Database Changes

Notice: Undefined index: upgrade_step in /home/catalyst7/lemuria.catalyst-pub.com/upgrade.php on line 3502
5: Delete Upgrade

And so on. I'm also getting this:

The upgrader was unable to find some crucial files.

Please make sure you uploaded all of the files included in the package, including the Themes, Sources, and other directories.

It wasn't looking quite right so I wound up uploading the folders one by one, then the rest of the files outside of the folder. It fixed the appearance of the screen, but with the same errors. I don't know what to try from here.

Offline Kindred

  • The Mean One
  • Support Specialist
  • SMF Legend
  • *
  • Posts: 55,259
  • Gender: Male
    • Kindred-999 on GitHub
Re: Upgrader cannot find crucial files
« Reply #1 on: June 13, 2017, 09:25:10 PM »
Restore back to your original installation...  then upgrade from 1.1.13 to 1.1.21 THEN try the upgrade to 2.0.14

Also, please confirm your php version?
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

Offline Catalyst

  • Semi-Newbie
  • *
  • Posts: 21
Re: Upgrader cannot find crucial files
« Reply #2 on: June 14, 2017, 12:01:52 AM »
Sorry. PHP 5.6. I was getting errors which is why I thought I should upgrade. I'll try downgrading and going from there.

Offline Kindred

  • The Mean One
  • Support Specialist
  • SMF Legend
  • *
  • Posts: 55,259
  • Gender: Male
    • Kindred-999 on GitHub
Re: Upgrader cannot find crucial files
« Reply #3 on: June 14, 2017, 06:08:27 AM »
it's not downgrading... and yes, you will need to upgrade to the 2.0.x series...

however, we have discovered that sometimes the upgrade works best if you upgrade to the latest in the 1.1.x series before doing the version jump to 2.0.x
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

Offline Catalyst

  • Semi-Newbie
  • *
  • Posts: 21
Re: Upgrader cannot find crucial files
« Reply #4 on: June 14, 2017, 10:21:37 AM »
Alright, I went back and successfully upgraded to 1.1.21, then tried upgrading to 2.0.14 and still got the same error. I decided to try upgrading to 2.0 instead, and got an error after "Updating indexes on "messages"...done".

Error!
Server has not responded for 30 seconds. It may be worth waiting a little longer or otherwise please click here to try this step again

Offline newborndeath

  • Newbie
  • *
  • Posts: 7
Re: Upgrader cannot find crucial files
« Reply #5 on: June 27, 2017, 11:11:42 PM »
Alright, I went back and successfully upgraded to 1.1.21, then tried upgrading to 2.0.14 and still got the same error. I decided to try upgrading to 2.0 instead, and got an error after "Updating indexes on "messages"...done".

Error!
Server has not responded for 30 seconds. It may be worth waiting a little longer or otherwise please click here to try this step again

I clicked the "click here" whenever it popped up. Always went to the next step after that.