• Welcome to Simple Machines Community Forum. Please login or sign up.

Error with Files Attachment

Started by oloment, November 14, 2009, 05:13:10 AM

Previous topic - Next topic

oloment

November 14, 2009, 05:13:10 AM Last Edit: November 16, 2009, 04:43:00 PM by oloment
SMF version 2.0 RC2
No modifications and no themes installed
French pack languages installed 2.0 RC1

Serveur web :
Apache/2.2.3 (Debian) PHP/5.2.0-8+etch15
Client version of MySQL: 5.0.32
Extension PHP: mysql

Error occurred when adding attachment files of size higher than 1,5 Mb
Critical error : 4fd6b51f6126cfaf3fa63239e9648375
Description : Your attached file could not be transferred. It is possible that its transfer was too long, or that the file is larger than the limit imposed by the server.
Parameters of file attachment : no limits of the size and number of files transferred

I have no upload limit with my server so I don't understand why I have this error. I can send files higher than 200 Mb on my FTP ! If someone have the solution, please answer !
Thanx in advance

Arantor

Did you configure SMF to allow more than 1.5 MB attachments in Admin > Forum > Attachments and Avatars > Attachment Settings > Max size per attachment ?

Note also it may be your server's configuration, specifically the PHP configuration. Most hosts are not configured to allow file uploads (through PHP, and thus SMF) of more than 2MB.

If you think you should be able to, please provide a copy of your phpinfo output - please see this for more information: What is a phpinfo() file?
No good deed goes unpunished
All helpful urges should be circumvented

oloment

November 16, 2009, 04:36:05 PM #2 Last Edit: November 16, 2009, 06:43:45 PM by oloment
Yes, I configure theses parameters : "Parameters of file attachment : no limits of the size and number of files transferred"
So, there is probably an upload limit through PHP but not FTP ?
Here you will find the phpinfo contents
Thanks for your help

Arantor

There are two limits that control uploading.

First and foremost is the PHP setting, upload_max_filesize, which in your case is 2 MB and that's the default.

There is a second, post_max_size, which refers to the HTTP POST message (that contains the attachment), which defaults to 8MB; post_max_size has to be the same or greater than upload_max_filesize for that to work at all, but you need to be asking your host to change upload_max_filesize first.


Moving to 2.x Support; this is not an SMF bug.
No good deed goes unpunished
All helpful urges should be circumvented

oloment

Thanks you very much. I will ask to change theses values, but I'm not sure they will agree. I need a max file size to 35 Mb !

Arantor

Then get your host/sysadmin to change upload_max_filesize and post_max_size to 40M.

You may need to restart Apache for it to take effect.
No good deed goes unpunished
All helpful urges should be circumvented

Advertisement: