News:

SMF 2.0.19 has been released! Please update. Read more.

Main Menu

Subaccounts

Started by SlammedDime, November 12, 2009, 09:59:09 AM

Previous topic - Next topic

Rotten Apple

First of all, this is definitely an amazing mod (and definitely has made the life of an admin easier XD) and I'm definitely glad to see several security issues fixed on the SMF 2.0 RC4 release!

I'm not sure if this has already been answered before, and if it has my apologies. I'm currently working on creating a custom skin based off of Curve and I'd like to move the main subaccount dropdown to appear above (or below) the linktree. Is this possible? I have a logo that's pretty much covered the area where the subaccount dropdown would appear in, so it'd be more convenient for me (and future users) to see this in a different location. The only actual files I have for this skin is the Curve index.template.php, index.php, and theme_info.xml file, whilst all other files are images, css, and other skin necessities.

Suggestions on what to do?

SlammedDime

Just take a look at the edits made to index.template.php to produce the dropdown and replicate that wherever you wish to have it displayed.
SlammedDime
Former Lead Customizer
BitBucket Projects
GeekStorage.com Hosting
                      My Mods
SimpleSEF
Ajax Quick Reply
Sitemap
more...
                     

wynnyelle

Thank you very, very much for getting back to me on this info. Is there a way to mod this account so that store points do tally to the main account as well, and, also, the parent account's name would show up on the sub account's mini profile as "Played by {parent account}" under the subaccount's name or under the avatar or something? This is for an RPG. Or should this request go under the paid requests thingy? Would these mods on this mod be hard to do?

Thanks again for addressing my questions.

Rotten Apple

#283
I installed the index.template.php portion of the code on the custom theme (considering this is purely a 'based on' theme), but when I try to insert the last line to where I'd like it to be, I receive a syntax error.

QuoteThe file you tried to save generated the following error:
Parse error: syntax error, unexpected ',' in index.template.php on line 303

I pretty much did something like this along with trying other methods:


   // Show the navigation tree.
   theme_linktree();

' <span>', $context['user']['name'], '</span>', $context['subaccount_dropdown'], '


Now, this is me assuming that the hello greeting before that is what'd appear by default on the original method of installing this mod. I simply want the dropdown to show. Am I doing this correctly? o_o; Also, thanks for answering my questions. It's definitely appreciated.

Ncen

I'm not an expert, but perhaps you could try using this instead while waiting for SlammedDime to answer:

   // Show the navigation tree.
   theme_linktree();

echo ' <span>', $context['subaccount_dropdown'], '</span>'

or this, depending on what's on your next line:
   // Show the navigation tree.
   theme_linktree();

echo ' <span>', $context['subaccount_dropdown'], '</span>'';


Although, it might be easier to see if you showed him line 300 to 305. :)

NanoSector

Quote from: Ncen on January 12, 2011, 09:51:51 AM
I'm not an expert, but perhaps you could try using this instead while waiting for SlammedDime to answer:

   // Show the navigation tree.
   theme_linktree();

echo ' <span>', $context['subaccount_dropdown'], '</span>'

or this, depending on what's on your next line:
   // Show the navigation tree.
   theme_linktree();

echo ' <span>', $context['subaccount_dropdown'], '</span>'';


Although, it might be easier to see if you showed him line 300 to 305. :)
Neither pieces of code are correct. (I am not the PHP expert here but even I see that lol)
    // Show the navigation tree.
   theme_linktree();

echo ' <span>', $context['subaccount_dropdown'], '</span>';


One ' too much :P
My Mods / Mod Builder - A tool to easily create mods / Blog
"I've heard from a reliable source that the Answer is 42. But, still no word on what the question is."

Ncen

Quote from: Simple Series team on January 12, 2011, 10:52:43 AM
Neither pieces of code are correct. (I am not the PHP expert here but even I see that lol)
    // Show the navigation tree.
   theme_linktree();

echo ' <span>', $context['subaccount_dropdown'], '</span>';


One ' too much :P

Gosh, sorry about that. *embarrassed* I meant to include just one ' there. Simple Series team is absolutely correct. I should definitely proofread before I post. ^^  Hope that one works!

Rotten Apple

Thanks for the help both of you. Simple Series teams correction worked. =D

NanoSector

I made worse mistakes in the past ;)

copy($boarddir '/FTSM.php''$boarddir . '/backups/FTSM_backup-'. getdate() . '.php')

Notice the '$boarddir. I was like "huh WTF" when I saw the upcoming error lol, commented out the code, opened SMF, made a post with the [php] tag and saw that. Never ever gonna make that mistake again :-[

Anyhow, glad I could help :)
My Mods / Mod Builder - A tool to easily create mods / Blog
"I've heard from a reliable source that the Answer is 42. But, still no word on what the question is."

MarkLeevE

is this account swithcer? wow this is pretty cool.. i'll try this

Mari-chi

Hi!

I downloaded this mod, and it's been working great! I noticed a little problem today, however, and would like to know if that can be fixed. :D

When I choose another account from the dropdown box in the Quick Reply area, it keeps posting as the one I'm logged on. For example:

* Logged in as Test123
* Tries to choose a subaccount called Admin123 from dropdown in Quick Reply
* Clicks 'post' after typing something
* Post shows up as Test123's post, and not Admin123's


I hope I've made sense. :)

SlammedDime

Hrm... that is definitely not supposed to happen... anyone else having this issue?
SlammedDime
Former Lead Customizer
BitBucket Projects
GeekStorage.com Hosting
                      My Mods
SimpleSEF
Ajax Quick Reply
Sitemap
more...
                     

Mari-chi

:( Maybe it's just me...? The only other mod I have installed in relation to the quick reply is the AJAX Instant Reply mod.

SlammedDime

That would be why... AJAX quick reply doesn't take it into account.  The javascript would have to modified to handle it.  I don't know when I'll have time to look at the code (it's a one line addition to xml_topic.js, but I have to take the time look through the code to see what the contents of that line needs to be).  I'm currently moving and have very little time to hop on here.
SlammedDime
Former Lead Customizer
BitBucket Projects
GeekStorage.com Hosting
                      My Mods
SimpleSEF
Ajax Quick Reply
Sitemap
more...
                     

Kanianlak

Hey there! Great mod, really huge!

I have a few questions. I wanted to have not just in parent profiles, to list their subbaccounts, but in subaccount profiles to list their parents. As well as in "post's profiles" (ya know on the left) to list one account's parent. But I can't handle it, some modifications were made, but they did not worked.

I would be very grateful and happy if you could provide me some code for smf 2.0 rc4 to me to get this working  Thanks!  :)

origamikitsune

I just wanted to chime in with a "Nice Mod" comment. :) This is an absolutely beautiful mod. I put on my beta forum and played around with it, and I can't wait until I get it live once I finish my new theme. Much with the kudos!

Mari-chi

I uninstalled the AJAX instant reply, and the subaccounts is working as it's supposed to. :D It'd be awesome if we could use it together. :)

Mari-chi

Hi again. :)

I deleted an account that had one subaccount, but the subaccount is still being listed as a member.

For example:

Parent Account: Astrid Sonja Johanssen
Subaccount: Mireillo Renard

^ I deleted Astrid's account, and while 'Mireillo Renard' is not showing up on the Member list page, she is being recognised as a member... If I type in 'Mir' in the 'recipient' box when sending a new PM, it will show 'Mireillo Renard' in the dropdown box. I also cannot register a new member named "Mireillo Renard", because the forum thinks it's still an existing member.

How can I fix this? :S

SlammedDime

Go to the Mireillo profile and delete the account... (might also have to go into the database and remove the entry in the subaccounts table that links the two accounts).
SlammedDime
Former Lead Customizer
BitBucket Projects
GeekStorage.com Hosting
                      My Mods
SimpleSEF
Ajax Quick Reply
Sitemap
more...
                     

Mari-chi

:3 Used the Pretty URL to figure out the URL of Mireillo's profile. :D

Thanks, SD. :)

Advertisement: