Subaccounts

Started by SlammedDime, November 12, 2009, 09:59:09 AM

Previous topic - Next topic

Ahadawan

Quote from: Ahadawan on May 26, 2014, 11:49:51 AM
I removed a SubAccount (just deleted it) without splitting it from the user, now I can see it in ?action=admin;area=subaccounts but other than that it's just gone. I wanted to remove it completely, how can I fix the remaining links and avoid this in the future?

I can see it in the smf_Subaccounts table in phpMyAdmin, only the parent value and the value of the user I removed, can I safely remove that line? Are there any other edits I should do?

Has someone else had this problem? Do you guys still have half-empty rows in the smf_Subaccount with only parent id and the user id removed?

Caltan

You can safely remove that line from the smf_subaccounts table.

Ahadawan

Quote from: Caltan on June 16, 2014, 10:21:23 PM
You can safely remove that line from the smf_subaccounts table.

Thank you :D

Sigyn

#503
I am running 2.0.8 and the SubAccounts are working just fine... my only problem is that the images for the buttons (i.e Merge/Split/Delete etc) are not working and show the broken image symbol. I am interested in fixing these images and making them work for ease of use - but I cannot seem to fathom how to go about doing so. Could anyone point me in the right direction to change/edit/add these images so the ugly broken image link is gone?

Appreciate any insights!

margarett

Use Firefox + Firebug. It will tell you the link to the missing image. Then you can check the files/folders for the missing files and add them as needed ;)
Se forem conduzir, não bebam. Se forem beber... CHAMEM-ME!!!! :D

QuoteOver 90% of all computer problems can be traced back to the interface between the keyboard and the chair

Sigyn

margarett... I think I love you! Thank you so freaking much you lifesaver you!  ;D

Ilúvatar

I'm new to SMF and implementing subaccounts would seriously streamline things for my members, given that I am setting up a roleplaying forum.

Could anyone advise me on where to start with getting this mod to run on 2.0.9?  Any help would be much appreciated! ~

Caltan

Well, start with this thread, really.  Your first step is to emulate 2.0RC3 in your package manager; the mod should install without a hitch everywhere but your custom theme index, and you can find those directions either in here or by parsing the mod package and following the code additions for index.template.php.

bethkozlowski

Just wondering if this is up to date for 2.0.9? I'd really like to install this, but the version listed above for downloading isn't compatible :( This would be really useful for my rp forum

live627

I think it'll work when emulating 2.0 RC4.

bethkozlowski

And how would I do that? Sorry, i'm very new to this open source thing. I do appreciate all the help :)

Kindred

Слова
Украина

Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

bethkozlowski

I got it to install partially correct using RC 4 Security Patch but it's not working correctly. I tried RC4 without and the same thing happened. Any other suggestions?

Kindred

wait...   WHAT?????   You used WHAT security patch?


The instructions for installing a mod do not include any security patches...
Слова
Украина

Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

margarett

You need to emulate "2.0 RC4" (without quotes).
And when you say "not working correctly", what exactly do you mean? You should always give us the exact error you get ;)
Se forem conduzir, não bebam. Se forem beber... CHAMEM-ME!!!! :D

QuoteOver 90% of all computer problems can be traced back to the interface between the keyboard and the chair

Arantor

Quote from: Kindred on January 29, 2015, 01:48:35 PM
wait...   WHAT?????   You used WHAT security patch?


The instructions for installing a mod do not include any security patches...

Check the mod site... ;)
Perhaps it would have been better if I'd simply never bothered. Y'all clearly would be less unhappy that way.

bethkozlowski

LOL I used SMF 2.0 RC4 I saw it had a security patch and tried to emulate it. It didn't work either way LOL.

Margarett, it tells me Test Failed in big, bold letters when it was installing it on my board (over 30 test fails) when I tried it the other way. I'll try it the way you suggested :)

So, I deleted the file, then tried to use SMF 2.0 RC4 WITHOUT the patch and had the same (if not more) errors) and the patch did not install correctly.

Are there any other RC versions or versions of SMF in general that this mod might work with? or is there anyone you can highly recommend that might be willing to make me a mod similar to this one for 2.0.9? I have some additions that I'd like implemented to it, but I am at a lost at the moment. This would be the perfect mod for my board if I could get it to work correctly :(


Arantor

Given the number of security vulnerabilities in the versions between 2.0 RC4 and 2.0.9 (bear in mind there's 11 versions difference)... anything below 2.0.9 is not recommended.
Perhaps it would have been better if I'd simply never bothered. Y'all clearly would be less unhappy that way.

bethkozlowski

Aranator,

I get that, I really do, unfortunately this mod has not been made for 2.0.9 :( At least not to my knowledge. I tried using the method that Margaret suggested, and got  significantly fewer errors. I think I saw someone had tried it on RC3. I'll give that one a go as well. Has anyone tried it on RC5? or is that the current version? Sorry, I'm way new to this open source thing, and I apologize for all of the questions.

Arantor

No... in order of release there was 2.0 RC4, 2.0 RC5, 2.0, 2.0.1, 2.0.2, 2.0.3, 2.0.4, 2.0.5, 2.0.6, 2.0.7, 2.0.8, 2.0.9.

Any version less than 2.0.9 is a bad idea and if the mod doesn't install cleanly... it's not a good idea to use it just because using any version other than 2.0.9 is insecure.
Perhaps it would have been better if I'd simply never bothered. Y'all clearly would be less unhappy that way.

Advertisement: