Advertisement:

Author Topic: Login Issue (previous title was SMF Wrapped has no theme)  (Read 20333 times)

Offline marinesct

  • Semi-Newbie
  • *
  • Posts: 59
Re: Login Issue (previous title was SMF Wrapped has no theme)
« Reply #20 on: December 19, 2009, 11:20:37 PM »
Allow User Registration: Yes 
Use New Account Activation: Yes 

This is where I register: http://test.usmcg.org/index.php?option=com_registration&task=register

How do I redirect the registration to com_smf_registration?

Orstio

  • Guest
Re: Login Issue (previous title was SMF Wrapped has no theme)
« Reply #21 on: December 20, 2009, 03:38:34 AM »
EIther use the bridge login module, or change your registration method to Mambo registration and use the Mambo registration with the SMF_register mambot.

Offline marinesct

  • Semi-Newbie
  • *
  • Posts: 59
Re: Login Issue (previous title was SMF Wrapped has no theme)
« Reply #22 on: December 20, 2009, 12:22:08 PM »
I've changed my registration method in the bridge to use the Mambo registration.  smg_register mambot is still published.

Same URL results.  ???
« Last Edit: December 20, 2009, 12:26:06 PM by marinesct »

Orstio

  • Guest
Re: Login Issue (previous title was SMF Wrapped has no theme)
« Reply #23 on: December 20, 2009, 01:30:41 PM »
Yes.  But now the user should automagically appear in both Mambo and SMF upon registration.

Offline marinesct

  • Semi-Newbie
  • *
  • Posts: 59
Re: Login Issue (previous title was SMF Wrapped has no theme)
« Reply #24 on: December 21, 2009, 12:14:51 AM »
With the bridge set to Mambo registration, I tried registering through Mambo and got the 500 error.  Using the same settings, I tried registering through the SMF and got the same error.

I set the bridge registration to SMF and registered via the forums successfully, but it didn't communicate with Mambo.

Could there have been something not installed properly during the initial install?  Should I delete the mambots, modules, components and tables?  You've provided guidance o me on this for quite sometime now and I'm starting to think that the modules aren't communicating properly between the two systems.

Orstio

  • Guest
Re: Login Issue (previous title was SMF Wrapped has no theme)
« Reply #25 on: December 21, 2009, 12:39:45 AM »
Are you sure your SMF database user has access to your Mambo database?

Offline marinesct

  • Semi-Newbie
  • *
  • Posts: 59
Re: Login Issue (previous title was SMF Wrapped has no theme)
« Reply #26 on: December 21, 2009, 07:13:18 AM »
Both SMF and Mambo share the same database.

Orstio

  • Guest
Re: Login Issue (previous title was SMF Wrapped has no theme)
« Reply #27 on: December 21, 2009, 08:05:00 AM »
Who is your host?

Offline marinesct

  • Semi-Newbie
  • *
  • Posts: 59
Re: Login Issue (previous title was SMF Wrapped has no theme)
« Reply #28 on: December 22, 2009, 02:15:55 AM »
1and1 is my host.

Orstio

  • Guest
Re: Login Issue (previous title was SMF Wrapped has no theme)
« Reply #29 on: December 22, 2009, 08:36:33 AM »
Did you install SMF and/or Mambo using an auto-installer like Fantastico?

Offline marinesct

  • Semi-Newbie
  • *
  • Posts: 59
Re: Login Issue (previous title was SMF Wrapped has no theme)
« Reply #30 on: December 22, 2009, 10:07:51 PM »
Fantastico? Never heard of it.  But no on the auto-installers. I utilized the installers that came with the software.

Orstio

  • Guest
Re: Login Issue (previous title was SMF Wrapped has no theme)
« Reply #31 on: December 22, 2009, 10:13:39 PM »
OK, re-reading your first post, you indicated you had to apply some sort of fix due to your version of PHP?  What version is that?

Offline marinesct

  • Semi-Newbie
  • *
  • Posts: 59
Re: Login Issue (previous title was SMF Wrapped has no theme)
« Reply #32 on: December 23, 2009, 01:53:08 AM »
It was the php version in my php.ini file if I remember correctly.  I'll have to look later when I have access to the control panel.  But according to my phpinfo, I'm currently using PHP Version 4.4.9.

That might be wherein lies the problem, yes?

Orstio

  • Guest
Re: Login Issue (previous title was SMF Wrapped has no theme)
« Reply #33 on: December 23, 2009, 07:46:39 AM »
Possibly.  What changes did you have to make in Mambo in order for it to work?

Offline marinesct

  • Semi-Newbie
  • *
  • Posts: 59
Re: Login Issue (previous title was SMF Wrapped has no theme)
« Reply #34 on: December 26, 2009, 11:23:59 AM »
I'm traveling right now and can't check the htaccess file.  The php.ini only reflects zend for my Treasury module by mh2designs.

I'll have to verify that I put it in the htaccess correctly, but this should be the only change I made (other than the recommended changes in the Mambo install process)

Code: [Select]
AddType x-mapp-php5 .php
AddHandler application/x-httpd-php5 .php
AddHandler cgi-php5 .php

Orstio

  • Guest
Re: Login Issue (previous title was SMF Wrapped has no theme)
« Reply #35 on: December 26, 2009, 11:26:39 AM »
Oh, OK.

I thought you were referring to changes in the PHP files.

Offline marinesct

  • Semi-Newbie
  • *
  • Posts: 59
Re: Login Issue (previous title was SMF Wrapped has no theme)
« Reply #36 on: December 26, 2009, 10:34:33 PM »
Nope, Im not that brave ;)