• Welcome to Simple Machines Community Forum. Please login or sign up.

Tidy Child Boards

Started by Arantor, December 09, 2009, 04:00:36 AM

Previous topic - Next topic

Robbo_

I don't give support via PM. Either post your problem here or PM someone else.
Aus-Newerth

Quote from: IRC
Roph> I just finished a double 1/2lb cheese, bacon & salad beef burger
Roph> no woman on earth could satisfy me as much as I am satisfied right now by this burger
... later on ...
Roph> how could ensie go about satisfying me =o
<Ensiferous> Roph: Merely looking at me would yield far more pleasure than a burger can provide.

Kat9119

I'm curious if anyone knows how to get something like this to work for the child boards INSIDE the parent forum?

Oya

it does

only it only shows them if the child boards have children boards.

so if you have parent > child > child 2, when inside parent, child is shown normally with child 2 tidied udner it

Kat9119

Well, I'm just going to have a Parent, with 12 child's inside it. I want the main index to look how the Tidy fixes it up. The child boards will not have more child boards. So, will it look nice and tidy too in the parent without the child forums having child forums? Haha thats confusing! :)

Oya

it must have made sense to the author as thats exactly how he wrote it to work

jjzx2sr

This is a great mod works well on my default curve theme. But it wont work on my custom curve theme using Anecdota, by Crip.

So before some one asks
Using

SMF 2.0 RC3

Theme


Anecdota, by Crip.

Mods


1.     SMF Bay PRO      1.0.6.1      
2.    AjaxChat Integration    3.2.1 (modified for SMF 2 RC3)    
3.    Aeva ~ Auto-Embed Video & Audio    7.1    
4.    SMF Links    2.3    
5.    Tidy Child Boards    1.3    
6.    Ultimate Profile    0.9.1

Yes i went in to the admin panel and enabled it, like i said works well on curve but not on my custom curve based theme.

Oh yeah i selected apply to all themes when i installed it.

What else do yah need to know?
If it doesn't fit get a bigger hammer.

Iviiik

If I have Images on board and tidy child boards mod, I have little problem :( in screen ...

How fix it :( ?

Oya


Iviiik


Sabre™

The browser would have nothing to do with it.
This fix comes courtesy of the infamous Arantor

Quote from: Arantor on January 27, 2010, 10:27:12 PM
You should be able to fix it by adding the following to Themes/default/tidyboards.css and refreshing the page:

.board_children { clear:left; }
Do NOT give admin and/or ftp details to just anybody, see if they are trust worthy first!!  Do your homework ;)


Iviiik

Sabre : thanks  ;) it´s working

Sabre™

My pleasure, and Arantors Im sure.
Enjoy :)
Do NOT give admin and/or ftp details to just anybody, see if they are trust worthy first!!  Do your homework ;)


Kat9119

Ok, so I really want to use this. I have a two column layout on my test forum and it looks great. Except for one thing. . .

All the other child boards in other areas look silly. Why? Because there are only 1 or 2 of them. I see that Robo stated he wanted to make it per board but doesn't have the time to support it anymore.

Anyhow, my question is this. Is there some way to make this mod work only on ONE parent forum (or one category) and have all other parent/categories show the child forums the same old way they used to before installing? And if so, can someone please tell me how to do it.

Basically I only need this for one area that has 12 child boards.

Thank you!

Oya

what board number?

you can do it by changing subs-boardindex.php like so

//For tidying boards; examine the children and realign into groups for tidying
function tidyBoards(&$board) {
global $modSettings, $context, $settings;

$limit = ceil(count($board['children']) / $modSettings['tidy_child_boards']);


//For tidying boards; examine the children and realign into groups for tidying
function tidyBoards(&$board) {
global $modSettings, $context, $settings;

if ($board['id'] != #BOARD HERE#)
return;

$limit = ceil(count($board['children']) / $modSettings['tidy_child_boards']);


where i put #BOARD HERE# that's where you put the board number if it's board 1.0 just put in 1 for example

Kat9119

October 11, 2010, 12:59:37 AM #234 Last Edit: October 11, 2010, 05:17:16 PM by Kat9119
Thanks! I'll give it
Quote from: Oya on October 10, 2010, 09:23:04 PM
what board number?

you can do it by changing subs-boardindex.php like so

//For tidying boards; examine the children and realign into groups for tidying
function tidyBoards(&$board) {
global $modSettings, $context, $settings;

$limit = ceil(count($board['children']) / $modSettings['tidy_child_boards']);


//For tidying boards; examine the children and realign into groups for tidying
function tidyBoards(&$board) {
global $modSettings, $context, $settings;

if ($board['id'] != #BOARD HERE#)
return;

$limit = ceil(count($board['children']) / $modSettings['tidy_child_boards']);


where i put #BOARD HERE# that's where you put the board number if it's board 1.0 just put in 1 for example

That is awesome! Thank you so much! One other question, because I'm using this, the forum icon beside the title, is pushed way at the top. How do I center it ?

Now I just need to figure out how to hide extra boards inside the parent forum on a selected forum only. And I'm all set! Someone had given me code in another topic, but it didn't appear to work because of installing Tidy Child Boards. Haven't gotten a response yet though...

If anyone here knows that would be great

MF Tlaxcala

This is an impressive and handy mod. Thank you. :)

Kat9119

I need to hide the 1st child boards inside the first parent forum on one board. Can you tell me how to do this?

anidea

Hi all,

I know I read this somewhere, but can anyone confirm that this works with RC3?  I know I'll have to do a manual install, which is fine, I just want to make sure it works before I do it.

Thanks!

MF Tlaxcala

October 16, 2010, 07:11:11 PM #238 Last Edit: November 06, 2010, 08:58:45 AM by MF Tlaxcala
Quote from: anidea on October 16, 2010, 06:56:53 PM
Hi all,

I know I read this somewhere, but can anyone confirm that this works with RC3?  I know I'll have to do a manual install, which is fine, I just want to make sure it works before I do it.

Thanks!
It works perfectly on RC3. See my forum to look at it: www.ccmasters.x10.mx

anidea

Quote from: MF Tlaxcala on October 16, 2010, 07:11:11 PM
Quote from: anidea on October 16, 2010, 06:56:53 PM
Hi all,

I know I read this somewhere, but can anyone confirm that this works with RC3?  I know I'll have to do a manual install, which is fine, I just want to make sure it works before I do it.

Thanks!
It works perfectly on RC3. See my forum to look at it: www.ccmasters.x10.mx

Beautiful!  Thanks :)

Advertisement: