• Welcome to Simple Machines Community Forum. Please login or sign up.

Tidy Child Boards

Started by Arantor, December 09, 2009, 04:00:36 AM

Previous topic - Next topic

Arantor

Mod works fine for me, on all the sites I run it on. I have no idea why it's not working for you. I can't see your site so I can't even look at that to see what's going on.
No good deed goes unpunished
All helpful urges should be circumvented

NW Dreamer

Hi, yes, my first post is about this mod!  I just installed v2.08 and spent a few days getting up to speed on everything (the first Simple Machines forum I've ever tried).  Anyway almost everything has gone very, very nicely (good job to all that created it!).  :)

Anyway, I have spent hours searching and reading so as not to be that guy who posts about something obvious.  That said, I'm really hoping I've missed a couple of things.  Obviously I'm looking to have child boards that aren't squished together under their parent board or I wouldn't be in this thread (I'm going to have a lot under one board).

If there's an easy code fix (I'm new to PHP but have programmed for a LONG time), a feature I haven't found in v2.0.8, or something that will come out in v2.1 (in which case I can wait) that will list the child boards indented like I see them in the Admin area then I would love to know about it!

Out of all my searching here I kept finding what I thought were answers, but then I look at the dates and the posts were all from 2005-2007!  This mod doesn't exactly do what I'm looking for (one column), but it should do.  Which brings us to the big question:  Will it work in v2.0.8 if I revert all the way back to 1.4.1?  I only see compatibility back to v2.0.4 listed in the download area.

I can't get my forum to communicate with SMF (and, no, it's not a "try again later" situation which I read about, I've tried dozens and dozens of times over the last three days.  So I did figure out how to download the mod manually.  I've also read how to install it using the revert feature, however the only method I've seen for uninstalling it if it doesn't work is to restore from backup!  Is that really true?

Thanks for your help!

Craig
Craig

Arantor

QuoteThis mod doesn't exactly do what I'm looking for (one column), but it should do.

No, it shouldn't. I never wrote it to support one column.

QuoteWhich brings us to the big question:  Will it work in v2.0.8 if I revert all the way back to 1.4.1?  I only see compatibility back to v2.0.4 listed in the download area.

No code has changed since 2.0.4 in the board index display, so if you use the last version of the mod, then use How can I install a mod that doesn't work in my SMF version? to emulate to 2.0.4 it should install.

One of these days I'll tweak the version and check it works on 2.0.8 but I'm pretty busy on paid mods these days.
No good deed goes unpunished
All helpful urges should be circumvented

Kimmie

Arantor, I am using v 1.3 on 2.0.8 (installed this way back in 2011) and it works just fine :)


SMF is also showing that is the latest version but I noticed the mod page says 1.4.1 so you may want to check that.



Arantor

SMF is doing exactly what it is supposed to with regards 'the latest version'. It doesn't do what people think it should...

I'll check the version number later though, bit late for that kind of thing just now, but thanks for the heads-up.
No good deed goes unpunished
All helpful urges should be circumvented

Kimmie

Quote from: Arantor on September 01, 2014, 11:39:45 PM
SMF is doing exactly what it is supposed to with regards 'the latest version'. It doesn't do what people think it should...

I'll check the version number later though, bit late for that kind of thing just now, but thanks for the heads-up.


I don't understand. The legend at the bottom clearly says it pertains to the mods


NW Dreamer

Thanks for the follow-up.  I decided to install the mod that removes child boards from the main index page for now, but may revisit this mod later if I need to see the child boards on the main page.

Quote from: Arantor on September 01, 2014, 09:05:54 AM
QuoteThis mod doesn't exactly do what I'm looking for (one column), but it should do.

No, it shouldn't. I never wrote it to support one column.


BTW - I wasn't saying your mod should do one column, I was merely commenting that it's probably an acceptable alternative for me to use for now until I find something that can do one column.  Sorry I wasn't clear.  ;)
Craig

Arantor

QuoteI don't understand. The legend at the bottom clearly says it pertains to the mods

Trust me, it doesn't do what you think it does.

This is designed for if you have multiple versions of a mod installed, whereupon it will show you which version is the current version.

Mods, theoretically, can contain update instructions for themselves. For example, it's theoretically possible to have a 1.0 mod and a 1.1 mod where the 1.1 mod doesn't just contain instructions for installing the 1.1 version but also instructions on how to upgrade the 1.0 mod to 1.1. The problem is, doing this is so much hard work (since you end up maintaining two copies of the same code) that mod authors (me included) don't bother.

But if a mod did do that, you'd have both in the list and the 1.0 version would be shown as 'older version' and 1.1 as 'current version'.

It's doing exactly what it's supposed to be doing... even if that's not what people think it should be.
No good deed goes unpunished
All helpful urges should be circumvented

Kimmie

Quote from: Arantor on September 02, 2014, 08:42:48 AM
QuoteI don't understand. The legend at the bottom clearly says it pertains to the mods

Trust me, it doesn't do what you think it does.

This is designed for if you have multiple versions of a mod installed, whereupon it will show you which version is the current version.

Mods, theoretically, can contain update instructions for themselves. For example, it's theoretically possible to have a 1.0 mod and a 1.1 mod where the 1.1 mod doesn't just contain instructions for installing the 1.1 version but also instructions on how to upgrade the 1.0 mod to 1.1. The problem is, doing this is so much hard work (since you end up maintaining two copies of the same code) that mod authors (me included) don't bother.

But if a mod did do that, you'd have both in the list and the 1.0 version would be shown as 'older version' and 1.1 as 'current version'.

It's doing exactly what it's supposed to be doing... even if that's not what people think it should be.

Isn't that common sense though? Why would anyone need multiple versions of a mod? I guess it could possibly help out those who don't really know what they are doing in terms of things like not bothering to look to see if you have one already installed before installing an updated version. I have always thought (and relied upon)  that telling me if the one I had installed was the latest version. To be honest, I don't think it really works at all based on the fact I have several updates and they all say they are the latest




I guess from now on I will have to constantly check to see if all the mods I have (34) get updated. This is going to be a pain.

Arantor

QuoteIsn't that common sense though? Why would anyone need multiple versions of a mod?

For the *specific* reason I outlined, where you install 1.0 and then install 1.1 without having to uninstall 1.0 first because 1.1 can upgrade from 1.0 without that extra step.

And no, the patches for SMF itself have never been distributed in that fashion because of the ridiculous amount of extra maintenance it generates, which is what I was saying. (Since the 2.0.2 patch would have to have all the 2.0.1 patch stuff in plus its own, 2.0.3 would have to have 2.0.1 + 2.0.2 + 2.0.3, 2.0.4 would have to have 2.0.1 + 2.0.2 + 2.0.3 + 2.0.4, 2.0.5 would have to have 2.0.1 + 2.0.2 + 2.0.3 + 2.0.4 + 2.0.5 and so on)

Sorry, I feel I've just wasted both our times trying to explain this, though thankfully I believe it has been removed in 2.1 because it just confuses people because it doesn't do what they expect even when it does actually work exactly as designed.
No good deed goes unpunished
All helpful urges should be circumvented

coldy316

I have had this mod working since it got release and its never let me down. I just want to know is there
any mod coder in here willing to update it to SMF 2.0.9 , reason why I ask is because I reckon this is far
better then the other child forum mods I have seen so far..
Would you believe it that i live in gods country
Australia

margarett

Se forem conduzir, não bebam. Se forem beber... CHAMEM-ME!!!! :D

QuoteOver 90% of all computer problems can be traced back to the interface between the keyboard and the chair

Arantor

QuoteI just want to know is there
any mod coder in here willing to update it to SMF 2.0.9

I will if and when I get time, OK? Just started new job, lots of things going on.
No good deed goes unpunished
All helpful urges should be circumvented

coldy316

but instead of emulating the mod and going back to different versions, Arantor could update the mod and have it
compatiable with future new versions of smf forums. So it would be like this roughly:

smf vers: 2.0.9
smf vers: 2.x.x 

smart and ahead of other moders thinking of the future. saves updating the mod every time a new version comes out...

Would you believe it that i live in gods country
Australia

Arantor

Yes I heard you the first time. I will update it as and when I have time and NOT BEFORE. Please understand I do not have vast amounts of time to spend on SMF related stuff, especially not for stuff I wrote 5 years ago and should really rewrite knowing what I know now.
No good deed goes unpunished
All helpful urges should be circumvented

CHRIS-7

February 18, 2015, 12:37:10 PM #415 Last Edit: February 18, 2015, 01:37:58 PM by CHRIS-7
Hi , I Want (Tidy Child Boards) For SMF 2.0.9
I Need This Mod , Because It's Very Nice
(My Theme is (Insidious II
! Please Help
:)

Steve

First, please don't use large text, especially when making a request for help. It implies shouting and many people take it as rude on a support board.

Second, if you go to the first post in this thread there's a link to the mod.

Third, How can I install a mod that doesn't work in my SMF version?
Please do not PM me for support.

njtweb

Any chance this mod gets updated? I get "Package" corrupt when trying to upload.

Mark S

Would love to see this mod updated for 2.0.11

Really looked much better than the line list of sub boards and made it easier for my forum members to pick them out from the other, main boards
:)

Steve

Please do not PM me for support.

Advertisement: