Advertisement:

Author Topic: Subs.php Error  (Read 5189 times)

Offline glc

  • Jr. Member
  • **
  • Posts: 106
  • Gender: Male
  • Thinking in binary, Talking in IP, doing in RT
    • CroHerza Gaming Community
Subs.php Error
« on: December 23, 2009, 04:50:03 PM »
When I try to open PM on first page i got this error:

Fatal error: Maximum execution time of 30 seconds exceeded in /home/croherze/public_html/forum/Sources/Subs.php on line 1804
that line is this:
Code: [Select]
$message = substr($message, 0, $last_pos) . $data . substr($message, $pos);
I can't remember but someone has left post that changing some thing will fix this :S
« Last Edit: December 23, 2009, 05:03:07 PM by glc »

Offline H

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 21,662
  • Gender: Male
Re: Subs.php Error
« Reply #1 on: December 30, 2009, 03:42:25 PM »
Which mods do you have installed?
-H
Former Support Team Lead
                              I recommend:
Namecheap (domains)
Fastmail (e-mail)
Linode (VPS)
                             

Offline glc

  • Jr. Member
  • **
  • Posts: 106
  • Gender: Male
  • Thinking in binary, Talking in IP, doing in RT
    • CroHerza Gaming Community
Re: Subs.php Error
« Reply #2 on: January 06, 2010, 07:01:03 PM »
Only Load Standard Language

:/ help ??

Offline H

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 21,662
  • Gender: Male
Re: Subs.php Error
« Reply #3 on: January 07, 2010, 04:07:43 PM »
Please attach Subs.php here
-H
Former Support Team Lead
                              I recommend:
Namecheap (domains)
Fastmail (e-mail)
Linode (VPS)
                             

Offline glc

  • Jr. Member
  • **
  • Posts: 106
  • Gender: Male
  • Thinking in binary, Talking in IP, doing in RT
    • CroHerza Gaming Community
Re: Subs.php Error
« Reply #4 on: January 07, 2010, 06:53:36 PM »
it's original subs.php from SMF, I also tryed replacing them but same error :/
:S


Offline H

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 21,662
  • Gender: Male
Re: Subs.php Error
« Reply #5 on: January 09, 2010, 02:07:07 PM »
Does the problem occur with the default theme?
Does this happen to all users?
-H
Former Support Team Lead
                              I recommend:
Namecheap (domains)
Fastmail (e-mail)
Linode (VPS)
                             

Offline glc

  • Jr. Member
  • **
  • Posts: 106
  • Gender: Male
  • Thinking in binary, Talking in IP, doing in RT
    • CroHerza Gaming Community
Re: Subs.php Error
« Reply #6 on: January 11, 2010, 07:20:16 AM »
Just one user told me that error :/

He has few pages of PM and that error comes on second page just :/

Offline its

  • Newbie
  • *
  • Posts: 4
Re: Subs.php Error
« Reply #7 on: January 16, 2010, 04:44:56 PM »
I have this problem too. With my acc., default theme, mods - Ad Managment 2.3.6; SimplePortal 2.3.1. Ad Mod can be uninstalled
successfully but uninstalling SPortal leads to error in index.php. And I see a huge number of core files in my form's folder
« Last Edit: January 16, 2010, 05:02:15 PM by its »

Offline greyknight17

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 14,890
  • Gender: Male
    • Kevin's Resource Center
Re: Subs.php Error
« Reply #8 on: February 14, 2010, 09:22:12 PM »
Is this issue resolved?

So it's only happening to that user? If so, one of his PMs is causing the problem. PM me if you still need assistance with this.

Offline glc

  • Jr. Member
  • **
  • Posts: 106
  • Gender: Male
  • Thinking in binary, Talking in IP, doing in RT
    • CroHerza Gaming Community
Re: Subs.php Error
« Reply #9 on: February 15, 2010, 07:21:07 AM »
yea, still had problem :/

Offline its

  • Newbie
  • *
  • Posts: 4
Re: Subs.php Error
« Reply #10 on: February 19, 2010, 09:55:28 AM »
Problem solved - SMF reinstall and no more SPortal

Offline Foreclosurepedia

  • Semi-Newbie
  • *
  • Posts: 84
  • Gender: Male
  • Catching Out on the Red Eye
    • International Brotherhood of Rail Riders
Re: Subs.php Error
« Reply #11 on: February 26, 2010, 09:36:54 PM »
I have this:  Fatal error: Maximum execution time of 30 seconds exceeded in /home/xxx/xxx/forum/Sources/Subs.php  on line 1985

I can't even access any part of the forum now and it's mine and I'm the admin.  I have cpanel.

smf 2.0 rc2  mods are simple portal (latest), and a couple basic ones, curve (default theme). 

PLEASE HELP!  I mean i can't access ANYTHING!  gives this error on each page

the subs.php is the one from smf.  man, i had to pay to upgrade and have no idea of how to reinstall.  is there any help for this?  rebooted the computer no good.

« Last Edit: February 27, 2010, 01:17:29 AM by ibrrorg »
Vincit Omnia Veritas

Offline Kill Em All

  • SMF Friend
  • SMF Hero
  • *
  • Posts: 8,144
  • Gender: Male
  • Something has to go wrong. Just has to.
    • KEAGaming
Re: Subs.php Error
« Reply #12 on: February 26, 2010, 10:00:26 PM »
ibrrorg, have you tried the suggestion stated above maybe? :p
My Site: KEAGaming.com

Manual Installation of Mods
Prevent Spam and Forum Attacks
Please do not PM or email me for support unless offered, help should be publicly displayed to others.

Offline Foreclosurepedia

  • Semi-Newbie
  • *
  • Posts: 84
  • Gender: Male
  • Catching Out on the Red Eye
    • International Brotherhood of Rail Riders
Re: Subs.php Error
« Reply #13 on: February 26, 2010, 10:14:23 PM »
i am really hesitant to reinstall the software as i don't know what i am doing that's why i added that in my question, but i will try to hire it out.

thank you
Vincit Omnia Veritas

Offline Foreclosurepedia

  • Semi-Newbie
  • *
  • Posts: 84
  • Gender: Male
  • Catching Out on the Red Eye
    • International Brotherhood of Rail Riders
Re: Subs.php Error
« Reply #14 on: February 26, 2010, 10:34:09 PM »
went ahead and followed exactly what they said to do:  reuploaded and overwrote the files.  still same error.

This is my site
Vincit Omnia Veritas

Offline Kill Em All

  • SMF Friend
  • SMF Hero
  • *
  • Posts: 8,144
  • Gender: Male
  • Something has to go wrong. Just has to.
    • KEAGaming
Re: Subs.php Error
« Reply #15 on: February 26, 2010, 10:40:21 PM »
You are still running Simpleportal. you need to uninstall that, then if you have to reupload all the files overwriting them.
My Site: KEAGaming.com

Manual Installation of Mods
Prevent Spam and Forum Attacks
Please do not PM or email me for support unless offered, help should be publicly displayed to others.

Offline Foreclosurepedia

  • Semi-Newbie
  • *
  • Posts: 84
  • Gender: Male
  • Catching Out on the Red Eye
    • International Brotherhood of Rail Riders
Re: Subs.php Error
« Reply #16 on: February 26, 2010, 10:42:23 PM »
THIS is my point I cannot access ANYTHING!  Anything I click gives me that darn screen!!!  Thus, I can't uninstall it!
Vincit Omnia Veritas

Offline Kill Em All

  • SMF Friend
  • SMF Hero
  • *
  • Posts: 8,144
  • Gender: Male
  • Something has to go wrong. Just has to.
    • KEAGaming
Re: Subs.php Error
« Reply #17 on: February 26, 2010, 10:48:14 PM »
You are going to have to manually uninstall it then.

Download your simpleportal package, then upload it here:
http://resourcez.biz/PackageParser/

Select your SMF, then select uninstall. Then view info. If you are copying over the files correctly, there is no reason why you should be doing this.
My Site: KEAGaming.com

Manual Installation of Mods
Prevent Spam and Forum Attacks
Please do not PM or email me for support unless offered, help should be publicly displayed to others.

Offline Foreclosurepedia

  • Semi-Newbie
  • *
  • Posts: 84
  • Gender: Male
  • Catching Out on the Red Eye
    • International Brotherhood of Rail Riders
Re: Subs.php Error
« Reply #18 on: February 26, 2010, 10:52:30 PM »
where/how do i download it from?  i mean do i go into cpanel and track it down somewhere?  thank you, also for taking the time to help me; i am not a coder and i know it must be frustrating.

as to copying the files correctly:  i downloaded the smf 2.0 rc2 upgrade pack, uploaded it with overwrite files selected and that was it

figured out how to do it, but............

Error: This package is not Uninstallable on SMF 2.0 RC2!  this is what the smf package parser says
« Last Edit: February 26, 2010, 11:08:06 PM by ibrrorg »
Vincit Omnia Veritas

Offline Foreclosurepedia

  • Semi-Newbie
  • *
  • Posts: 84
  • Gender: Male
  • Catching Out on the Red Eye
    • International Brotherhood of Rail Riders
Re: Subs.php Error
« Reply #19 on: February 27, 2010, 02:14:59 PM »
This is the conclusion/solution to the problem I was experiencing.  There never was a need to reinstall anything and thank G-d I had server rewind to recapture my data!

So, here's the deal:  Had to contact my server (A2 Hosting).  They were really cool about the stuff.  They said that it isn't SimplePortal itself, but the chat feature.  He said something about only allowing 35 actions (concurrent I think is the word) going on at once; related them to mods being in play on the front end.

SiNaN at SimpleProfile was kind enough to teach me the debug technique!  Man, see a simple deal like that, known to any coder, cuts right to the chase!  MANY thanx again!

I am going to play w/the chat deal, but am worried and would like some input.  I will follow the thread and reply back and thanx to all once again!
Vincit Omnia Veritas

Offline Kill Em All

  • SMF Friend
  • SMF Hero
  • *
  • Posts: 8,144
  • Gender: Male
  • Something has to go wrong. Just has to.
    • KEAGaming
Re: Subs.php Error
« Reply #20 on: February 27, 2010, 02:56:45 PM »
Marking solved.
My Site: KEAGaming.com

Manual Installation of Mods
Prevent Spam and Forum Attacks
Please do not PM or email me for support unless offered, help should be publicly displayed to others.