Advertisement:

Author Topic: Mambo 4.6.5 and SMF 2.0RC2 Bridged log in issue  (Read 6601 times)

Offline higherauthority

  • Jr. Member
  • **
  • Posts: 268
  • Gender: Male
    • Midwest Airsofters
Mambo 4.6.5 and SMF 2.0RC2 Bridged log in issue
« on: January 20, 2010, 08:10:55 PM »
I installed a fresh copy of Mambo 4.6.5 

I created a duplicate of my forums system running SMF 2.0 RC2 

Using the Bridge 2.0

I followed the directions supplied in the read me in the bridge zip file.  its pretty self explanatory.


I am using the Bridge registration method

The absolute path is /home/computi1/public_html/manew/forums
                    I verified this per the bridge install read me

I am using a wrapped integration

In mambo I unpublished the MOD_Login that std mambo uses and published Mod_SMF_login in its place.



I am using 2 separate databases on the same server with the same user and permissions wide open for both.


SMF_header_include  mambot is published

SMF_Login, SMF_logout, SMF _register etc are all unpublished.   I tried published it makes no difference.

in mambo I have the global settings to allow user registration as I found in another thread could cause similar issues.

I sync all my smf users to mambo that worked fine.

but once I publish the   mod_smf_login module I get this error

Code: [Select]
Notice: Undefined variable: configuration in /home/computi1/public_html/manew/modules/mod_smf_login.php on line 110

Fatal error: Call to a member function get() on a non-object in /home/computi1/public_html/manew/modules/mod_smf_login.php on line 110

I can access the forum direct

SMF URL is here:   http://midwestairsofters.org/forums/index.php

everything appears to be fine

and if I disable the mod_smf_login      Mambo will function correctly and no error but then I have no way users can log in  :-\.


Mambo URL is:     http://midwestairsofters.org   (This is where I see the error)

Previously I have installed bridges for SMF1.1XXX + Joomla 1.012    SMF1.1XXX + Mambo 4.6.5 and but this is the first time for SMF 2.0RC2 + Mambo 4.6.5.   

Am I missing a step somewhere? Anyone else have this error.  I found a bunch of threads but nothing that is exactly like my error

Has anyone had success in getting this to work using the combination of these versions?

Thanks in advance

« Last Edit: January 21, 2010, 12:28:17 PM by higherauthority »

Offline higherauthority

  • Jr. Member
  • **
  • Posts: 268
  • Gender: Male
    • Midwest Airsofters
Re: Mambo 4.6.5 and SMF 2.0RC2 Bridged log in issue
« Reply #1 on: January 22, 2010, 02:04:49 AM »
Just figured it out


I went to my mambo files and found   /modules/mod_smf_login.php   


I altered this code

Code: [Select]
global $lang, $mosConfig_lang, $synch_lang, $smf_lang, $smf_path;

to


Code: [Select]
global $lang, $mosConfig_lang, $synch_lang, $smf_lang, $smf_path, $configuration;