News:

Wondering if this will always be free?  See why free is better.

Main Menu

Multi Quote Mod

Started by Nibogo, January 23, 2010, 09:52:26 PM

Previous topic - Next topic

Nibogo

Quote from: Gryzor on March 25, 2010, 04:57:03 AM
Yes! Worked great first try on 2.0RC3. Thanks for a much, much-needed mod. Very useful.

The only issue (non-functionality related) that I have is that I don't get the icons next to the labels... what do I have to do? mquote_remove.gif is in default/images/buttons, but I don't see either that or the icon of the add multi-quote in the forum...

Thanks once more...

[EDIT] Ehm... it worked. For some reason the first couple of times I tried it they wouldn't show up, but now they do :)

That happened because you must clean the cache in order to see the icon

Glad you have it working

Antechinus

If you can make it work with quick reply it'll be great. At the moment it isn't much of an advantage over the standard Post.template.php topic summary listing.
Sources code: making easy front end changes difficult since 1873 :P

Mods & Themes | Revamped theme for this site | Dark theme for this site | GitHub for n00bz

Nibogo

Quote from: Antechinus on April 22, 2010, 04:51:56 AM
If you can make it work with quick reply it'll be great. At the moment it isn't much of an advantage over the standard Post.template.php topic summary listing.

Isn't much of an advantage having with quick reply because I already can quote a lot of posts and all of them go  to the quick reply box

MATTEK

Is there a way to edit the Text it displays? Instead of the long " Add Mluti-Quote " I was hoping to change it to just "Multi-Quote"
SMF 2.0.1

Like Comics, Books, Movies or T.V. Shows? Read about them here!!

Antechinus

Quote from: NIBOGO on April 22, 2010, 03:09:33 PMIsn't much of an advantage having with quick reply because I already can quote a lot of posts and all of them go  to the quick reply box
True, but if you supply a multi-quote button a lot of people will use it when they want lotsa quotes, then wonder why the quotes aren't appearing in the quick reply. :)

It would be better for all round idiot-proofing if this mod had the same behaviour as the standard quote: display quotes in the quick reply if that is open, otherwise default to Post.template.php.

My 2c. :)
Sources code: making easy front end changes difficult since 1873 :P

Mods & Themes | Revamped theme for this site | Dark theme for this site | GitHub for n00bz

Antechinus

Quote from: MATTEK on April 22, 2010, 03:59:18 PM
Is there a way to edit the Text it displays? Instead of the long " Add Mluti-Quote " I was hoping to change it to just "Multi-Quote"

Themes/default/languages/Modifications.english.php:

$txt['multi_quote'] = 'Add Multi Quote';
$txt['multi_quote_remove'] = 'Remove Multi Quote';
Sources code: making easy front end changes difficult since 1873 :P

Mods & Themes | Revamped theme for this site | Dark theme for this site | GitHub for n00bz

MATTEK

Quote from: Antechinus on April 22, 2010, 04:35:21 PM
Quote from: MATTEK on April 22, 2010, 03:59:18 PM
Is there a way to edit the Text it displays? Instead of the long " Add Mluti-Quote " I was hoping to change it to just "Multi-Quote"

Themes/default/languages/Modifications.english.php:

$txt['multi_quote'] = 'Add Multi Quote';
$txt['multi_quote_remove'] = 'Remove Multi Quote';


You're like an angel sent from the Forum Gods.  O:) Thanks man.
SMF 2.0.1

Like Comics, Books, Movies or T.V. Shows? Read about them here!!

B.SkiLLs

Awesome mod. Most handy. Very needed. Default should have this on SMF. Good work ;)

Only one question or issue. Why does it make the page load lag ?? It lags for a few seconds (like 15) then posts and the quotes pop in the text box.

VICKTORY THE UNDERDOG Documentary – Pitbulls the untold true story

This is a must read & watch. Then Buy your DVD today. You will not regret it. Totally AWESOME. Best i ever seen. --
 
____________________
Message approved by
: [B. SkiLLs]
 


Nibogo

Quote from: B.SkiLLs on May 14, 2010, 07:31:29 AM
Awesome mod. Most handy. Very needed. Default should have this on SMF. Good work ;)

Only one question or issue. Why does it make the page load lag ?? It lags for a few seconds (like 15) then posts and the quotes pop in the text box.



Because in the Post area this is the less important thing and the quotes are only loaded after all the rest of the page load succesfully

B.SkiLLs

Quote from: Nibogo on May 14, 2010, 09:16:02 AM
Quote from: B.SkiLLs on May 14, 2010, 07:31:29 AM
Awesome mod. Most handy. Very needed. Default should have this on SMF. Good work ;)

Only one question or issue. Why does it make the page load lag ?? It lags for a few seconds (like 15) then posts and the quotes pop in the text box.



Because in the Post area this is the less important thing and the quotes are only loaded after all the rest of the page load succesfully

Yeah OK i kinda figured that but thought i would ask anyways. Plus with it being cookie ran so..

Not only that tho it just seems like it has slowed posting page down period. I'll keep a close eye on it for a bit and see what happens and if it stays slower with the full page on a post  page

Thanks for the fast reply tho ;)
VICKTORY THE UNDERDOG Documentary – Pitbulls the untold true story

This is a must read & watch. Then Buy your DVD today. You will not regret it. Totally AWESOME. Best i ever seen. --
 
____________________
Message approved by
: [B. SkiLLs]
 


michelangelo

#50
Quote from: Nibogo on March 24, 2010, 06:08:32 PM
Quote from: hcfwesker on March 24, 2010, 04:39:50 PM
The quote tags get broken ... for some reason, even when quoting one post, when I click the "quote" button, the cursor automatically starts inbetween the [/qu^ote]   <---- where the arrow is.  So, as you see, that's causing each quote in multi quote to get broken off like that.

I mean, the very last line in the box I put into code should have explained ...

[/quote]ote]ote]



I can duplicate that error plus this mod uses the same Insert Quote function used by SMF so in case that you have an error loading the quotes it's a bug with your SMF

Hi, first at all thanks for this great script. Weve been waiting a long time for this. I run a big smf 1.11 forum with 500k posts. I can duplicate the error and confirm the bug. I think the majority of smf 1.1x users will have this problem. When quoting multiple posts the ouput looks like this:


Quote from: passive on June 04, 2010, 12:17:55 AM
Quote 1
[/quot
Quote from: donyusufahmed on June 03, 2010, 11:47:13 AM
Quote 2
[/quot
Quote from: Ahmyrak on June 05, 2010, 10:30:13 AM
Quote 3
[/q
Quote from: anagox on June 03, 2010, 09:41:52 AM
Quote 4
[/quot
Quote from: Stuyvesant on June 04, 2010, 05:22:43 AM
Quote 5
[/qu
Quote from: somedude2000 on June 04, 2010, 03:46:21 AM
Quote 6
ote]e]uote]e]e]

It would be kindly appreciated if the reason can be located and fixed.

gbsothere

#51

*puzzled*

I have 1.1.11 and ours works beautifully.  Am I misunderstanding hcfwesker about "clicking the quote" button?  It was my understanding that the "Add Multi Quote" link is to be used instead of the "Quote" link, not in conjunction with it.  I have nested quotes turned off and when my users want to quote more than one comment, they use only the "Add Multi Quote" link and don't touch the "Quote" link, at all.  Our quotes look like this:



Perhaps we're doing it incorrectly?  *grin*  In any event, we leave the "Quote" link alone, unless we only want to quote one post, and use Multi-Quote for the rest. 


EDIT:  As far as the Quote tag being broken, we're not having that issue, so I'm curious to know why some 1.1.x versions do and some don't.   :-\
My apologies, but I am taking a break from accepting PM requests for support.  If I am not currently assisting you, please do not ask as long as this notice is posted.  Thank you.

I Don't Want To Grow Old Alone


It has been proven that Steely Dan reduces the occurrence of road rage, according to an independent study.



A reminder about admin / ftp passwords etc.

michelangelo

I tested it with a clean new installation of smf 1.11 and this is what I get when deactivating nested quotes and quote from 4 different posts. Note: I used only the multi quote link.


[quote author=su link=topic=1.msg3#msg3 date=1276267607]
this is another test

[/quo[quote author=Simple Machines link=topic=1.msg1#msg1 date=1263414378]
Welcome to Simple Machines Forum!

We hope you enjoy using your forum.  If you have any problems, please feel free to [url=http://www.simplemachines.org/community/index.php]ask us for assistance[/url].

Thanks!
Simple Machines
[[quote author=su link=topic=1.msg2#msg2 date=1276267502]
Hello, my friend. I Love you and miss you.
[/quot[quote author=su link=topic=1.msg4#msg4 date=1276267656]
hello
[/quote]e]/quote]te]



gbsothere

With default, Michelangelo, or a custom theme?

(I'm only curious, because we use default and I'm wondering why one 1.1.11 forum would have this error and another one wouldn't.)
My apologies, but I am taking a break from accepting PM requests for support.  If I am not currently assisting you, please do not ask as long as this notice is posted.  Thank you.

I Don't Want To Grow Old Alone


It has been proven that Steely Dan reduces the occurrence of road rage, according to an independent study.



A reminder about admin / ftp passwords etc.

michelangelo

Yes, we use the default template. There were no mods, no settings, just the standard installation.

Apache
Mysql 4
Php5
utf-8 db

adbrad

i have the mod working perfect in rc3 not saying you should upgrade just maybe consider it as an option

gbsothere

@ Michelangelo

Your forum default language is utf-8 (rather than just English)?

If so, did you make sure that your Modifications.english-utf8.php file has this mod's manual parsing?  (Just pulling at straws.)   :)
My apologies, but I am taking a break from accepting PM requests for support.  If I am not currently assisting you, please do not ask as long as this notice is posted.  Thank you.

I Don't Want To Grow Old Alone


It has been proven that Steely Dan reduces the occurrence of road rage, according to an independent study.



A reminder about admin / ftp passwords etc.

michelangelo

#57
It uses modifications.english.php so it should be fine should work fine. Sadly multi quote does not work :(

michelangelo

Ok, I have good news and bad news.

The good news is Multi Quote works with Firefox on a fresh install. The bad news it's buggy in Opera and I'm using Opera primarily. Thanks for your work, maybe you can get it to work in Opera some day.

MATTEK

This mod randomly stopped working. I've trying to uninstall and reinstall but I get errors on the uninstall.

Quote1.     Execute Modification     .Themes/default/css/index.css     Test successful
      1.    Replace    .Themes/default/css/index.css    Test successful
*    2.    Execute Modification    .Themes/default/Display.template.php    Test failed
      1.    Replace    .Themes/default/Display.template.php    Test failed
      2.    Replace    .Themes/default/Display.template.php    Test failed
*    3.    Execute Modification    .Themes/default/Post.template.php    Test successful
      1.    Replace    .Themes/default/Post.template.php    Test successful
*    4.    Execute Modification    .Themes/default/index.template.php    Test failed
      1.    Replace    .Themes/default/index.template.php    Test failed
*    5.    Execute Modification    .Themes/default/languages/Modifications.english.php    Test successful

Will I be ok to go ahead with the uninstall and then reinstall the mod?
SMF 2.0.1

Like Comics, Books, Movies or T.V. Shows? Read about them here!!

Advertisement: