• Welcome to Simple Machines Community Forum. Please login or sign up.
September 26, 2021, 05:17:37 PM

News:

SMF 2.1 RC4 has been released! Try it out and help us test! :) Read more.


SA Facebook Integration

Started by SMFHacks.com Team, February 12, 2010, 01:36:11 PM

Previous topic - Next topic

L.G.S

I installed this, and it worked great.

Then I changed my domain name, so I created a new app.

Now the new app links and logs in, then asks me to make a post on my wall, but thats it. If I click the menu link it doesn't do anything.

Help pls :(
FREE and LIVE World Cup + Premier League football streams:

www.gamesandgoals.com


anakmacan

Hi, great mod btw, but i think it wont work with Facebook Like mod.

NoFeaR / NFSMW

When i want to submit my aplication to facebook it says "Your application must have at least 5 total users or 10 monthly active users before you can submit it to the Application directory."
What do i do now???

Spoogs

1st.. know that submitting your app to facebook is completely optional.
2nd if you intend to submit to facebook, you simply need to meet their requirements by having people access your application on facebook

NoFeaR / NFSMW

Ok thank you. Now i get this error when clicking on Integrate forum account with Facebook.

API Error Code: 100
API Error Description: Invalid parameter
Error Message: next is not owned by the application.

NoFeaR / NFSMW

Ok i fixed that error. I enabled shared boards but where does it share 2???
I don't find anything on my profile and neither on my application.
Oh and the status update doesn't work.

4X4UK

Quote from: 4X4UK on May 27, 2010, 10:03:51 AM
wonder if you can help

installed in smf v1.11 and using a custom template, which I have modified everything seems to work ie share works integrate with FB seems to apart from one small bit

when you click on integrate with FB, the pop up apears asks for permission to share info when you click ok the resultant page which has the following url

http://www.4x4uk.org/forums/index.php?action=facebook;sa=sync

is completely blank, can't seem to figure out why
also noticed that if I log out of the forum and stay logged in to facebook if I click on the login with Facebook link that would appear to guests the also gives a blank page (http://www.4x4uk.org/forums/index.php?action=facebook;sa=connect;step) and wont log me in

Facebook connect settings as follows:
connect url: http://www.4x4uk.org/forums/
account preview: http://www.4x4uk.org/
all other fields left blank

any pointers as to what could be the problem would be greatly appreciated many thanks
Ian

well I am going to Upgrade my form to SMF 2, install fb connect for that and see if that works any better


Nirose

Got it to work perfectly. Awesome thanks

But the invitations don't seem to be sent even when it says its completed.

DJ Rg

RESOLVED: It had noting to do with this mod (previous coding error)

Hi

Installed this mod but couldnt get it to work ..i went to the SA Mod forums and couldnt get any help there either ..so i unstalled the mod (i am sure its a great mod but i could not get it to work)

Anyways my problem now is, when I go to my admin panel and go to logs >> Error Logs ..I keep getting this error message >> /tinroofalleypoets.org/poetry_boards/Themes/default/xxxx.template.php (body_above sub template - eval?)

each time i click/refresh the error log page ..the above error multiples and names a different xxxx.template.php...

it also says its on ..line 176 of each and every template.php ..but i see nothing unusual or common in regards to this error on that line.

in the error log it also gives a date of " December 31, 1969" ..lol..

I would really appreciate it if someone would help me clean this error up?

Thank you.


Divaksh

Quote from: Divaksh on May 23, 2010, 08:02:47 AM
I get this error when login using facebook connect(Integrate forum account with Facebook. also)

Fatal error: Class 'Facebook' not found in /home/hackmycr/public_html/forum/Sources/FB_Connect/FB_Connect_Subs.php  on line 359


Still waiting for help... :(

~DS~

For those who are wondering...

Quotejust a little note to appoligize to everyone for my absense and not ansering post here or at smf the truth is that i am so busy with rl right about now that i dont have much time todo dev work around september augast things will be back to normal and ill be able to ketchup with things

untill then guys im sry for any delay that may have been caused :)




http://www.sa-mods.info/index.php?topic=523.msg3775#msg3775
"There is no god, and that's the simple truth. If every trace of any single religion were wiped out and nothing were passed on, it would never be created exactly that way again. There might be some other nonsense in its place, but not that exact nonsense. If all of science were wiped out, it would still be true and someone would find a way to figure it all out again."
~Penn Jillette – God, NO! – 2011

Divaksh

thanks a lot....

another gud news is I've fixed it... there was error in my facebook.php file... :D :)

Kadai Crosshansen

This mod is just awesome.
Installed it, and it does appear to work.

Now, just a thing:
If you are using a custom template, the changes applied by this mod will not show at all, so, you'll require to actually make manual changes to "index.template.php" in order to get this one working.

Basically, go to the MOD simplemachine's page and follow the manual installation steps for this MOD and file, just be sure that you end with a "valid" php file, because since you are using a custom template, is very likely you'll require a bit of PHP knowledge  to implement certain things correctly.

Also, it is possible to implement this MOD to your website once it has been installed and it is working.
You'll require, basically, copy all javascripts used for facebook from your forum to our page and it will succeed.

You can see it working on a website here: hxxp://anime-age.com/noticias.php

Abel6669

Fatal error: Class 'Facebook' not found in /home/a2197288/public_html/forum/Sources/FB_Connect/FB_Connect_Subs.php on line 359



Ive just installed the above package, no problems (a few "test fails" on custom themes, but i just shook it off) now i get that error EVERY time i click Intergrate With Facebook.


what have i done wrong...Ive uploaded all THREE(yes, three) .zips of this mod i have, plus the one from the page itself, still same error.

it must be something ive done/not done, as the mod worked before...

Please help.


VERSION 2.0 RC3

bahgheera

Ok, I'm trying not to freak out here, but I am shocked at what happened overnight.

I installed SA Facebook connect last night, and when I wake up this morning, I find a message from a user that goes like this:

Quotehello man , you forum have one bug.when i log in whit my face book account,the forum log me as a ADMINISTRATOR :)
may i stay like a admin ?
but fix this because if this know from bad peoples the forum can get down..

I looked around and in fact he was logged in AS ADMIN. I don't understand how this could happen. There isn't anything saying that it would happen in the initial documentation. Luckily the guy didn't do too much damage, other than apparently delete the main admin account.

How did this happen and why???

Kadai Crosshansen

Quote from: bahgheera on June 10, 2010, 08:36:41 AM
Ok, I'm trying not to freak out here, but I am shocked at what happened overnight.

I installed SA Facebook connect last night, and when I wake up this morning, I find a message from a user that goes like this:

Quotehello man , you forum have one bug.when i log in whit my face book account,the forum log me as a ADMINISTRATOR :)
may i stay like a admin ?
but fix this because if this know from bad peoples the forum can get down..

I looked around and in fact he was logged in AS ADMIN. I don't understand how this could happen. There isn't anything saying that it would happen in the initial documentation. Luckily the guy didn't do too much damage, other than apparently delete the main admin account.

How did this happen and why???

What version of SMF was you using? What version of the mod (The most current?)
If you can, try to see what did that user specially; to detect how this might have happened.
And also, there is anyone else that have seen this behavior in their own forums?

As far I have seen, this MOD is used in a wide range of forums, so if this issue is easily reproducible, it can be a huge problem for anyone using this.

bahgheera

I used SA_FBConnect_0.2.zip on SMF 2.0 RC3. I agree, there are many people here who have no problem with SA Facebook Connect, so it's odd that this happened. I tested it with a couple of accounts and it seemed to work fine. I really want to use this plugin, but I'm scared to death of what might happen. It's a five year old forum with over 4000 members - so you can imagine I don't want to screw that up.

Hj Ahmad Rasyid Hj Ismail

How do I change the image Connect to Facebook to a smaller / shorter one? Any help is appreciated.

SA™

http://samods.github.io/SAChatBar/

Xbox Live: smokerthecheese 360 or xbone
My Work
Piano Movers / Delivery service
QuoteMy allies are dead.
I'm 'bout to be too.
Zombies are chasing me.
F*** it, I'm screwed -___-

Advertisement: