Advertisement:

Author Topic: SA Facebook Integration  (Read 1035195 times)

Offline Allusion

  • Jr. Member
  • **
  • Posts: 386
Re: SA FB Connect button doesn't show
« Reply #420 on: May 18, 2010, 07:19:50 PM »
I have SMF v1.1.11 with Classic YaBB SE Theme

This mod does not install on Classic, only on the default (Core) theme.

Offline luckyMM

  • Newbie
  • *
  • Posts: 9
Re: SA Facebook Connect Integration [now supports smf1 and smf2]
« Reply #421 on: May 18, 2010, 08:47:44 PM »
Hi ,
I found some problem with this mod. If forum can't enter Guest, this mod is no working.

Offline venex

  • Jr. Member
  • **
  • Posts: 123
Re: SA Facebook Connect Integration [now supports smf1 and smf2]
« Reply #422 on: May 19, 2010, 12:00:44 AM »
After Filling the
Connect URL... my Site address closing by /.......... (www.example.com/)

Account Preview URL...Blank

Base Domain........blank

Account Reclamation URL..........blank

its show the the error.

API Error Code: 100
API Error Description: Invalid parameter
Error Message: next is not owned by the application.

Tell me now what should i do.......

thanx for you previous reply....
Same thing is happening to me.

Offline RCC_SaMiaM

  • Jr. Member
  • **
  • Posts: 195
  • Gender: Male
  • I'm a llama!
    • firearmory.com
Re: SA Facebook Connect Integration [now supports smf1 and smf2]
« Reply #423 on: May 19, 2010, 11:19:39 PM »
I am using it with 1.11 and clicking the fb connect button or integrate link takes me to a login box (if not logged into facebook) then just back to my forum.  My forum is installed in root, is that an issue?

Offline Robin1989

  • Jr. Member
  • **
  • Posts: 165
  • Gender: Male
  • lovin smf
    • Acidmods
Re: SA Facebook Connect Integration [now supports smf1 and smf2]
« Reply #424 on: May 20, 2010, 06:33:54 AM »
hey does this mod incorporate the new like button im seeing on all the sites now that lets someone like any page that the button is placed on?

Offline RCC_SaMiaM

  • Jr. Member
  • **
  • Posts: 195
  • Gender: Male
  • I'm a llama!
    • firearmory.com
Re: SA Facebook Connect Integration [now supports smf1 and smf2]
« Reply #425 on: May 20, 2010, 05:06:47 PM »
I should of been more clear on my issue, with the mod enabled, when clicking on the link or button to login or integrate with facebook I get the pop up (to allow access or to login to facebook if logged out), once I click ok then my site loads in that little popup.

After doing that any time I click on the integrate with facebook link or connect with facebook button it just loads my site in the little pop up.

Offline vomega

  • Semi-Newbie
  • *
  • Posts: 14
Re: SA Facebook Connect Integration [now supports smf1 and smf2]
« Reply #426 on: May 20, 2010, 06:18:16 PM »
cant get this mod to work

API Error Code: 100
API Error Description: Invalid parameter
Error Message: Invalid parameter

i followed every single step carefully, ive created the facebook app still get same error

see forum  vandeatta.com/elchoneo/

Offline vomega

  • Semi-Newbie
  • *
  • Posts: 14
Re: SA Facebook Connect Integration [now supports smf1 and smf2]
« Reply #427 on: May 20, 2010, 10:40:42 PM »
got another error:

Invalid Argument
The Facebook Connect cross-domain receiver URL (http://vandeatta.com/elchoneo/fbc/xd_receiver.htm#fname=_opener&%7B%22t%22%3A3%2C%22h%22%3A%22fbCancelLogin%22%2C%22sid%22%3A%220.247%22%7D [nofollow]) must be in the same domain or be in a subdomain of an application's base domain (www.vandeatta.com [nofollow]). You can configure the base domain in the application's settings.

Offline vomega

  • Semi-Newbie
  • *
  • Posts: 14
Re: SA Facebook Connect Integration [now supports smf1 and smf2]
« Reply #428 on: May 20, 2010, 11:22:54 PM »
the connect cross it is in the same domain..
plaase help

Offline dsanchez

  • Jr. Member
  • **
  • Posts: 320
  • Gender: Male
Re: SA Facebook Connect Integration [now supports smf1 and smf2]
« Reply #429 on: May 22, 2010, 08:10:45 AM »
Hello!

I installed this mod and I can't see anywhere where the user can log using Facebook. I'm using the Curve theme.

Thanks!
Curefans.com - The meeting point for Curefans worldwide
http://www.curefans.com

Offline samueliyinbo

  • Semi-Newbie
  • *
  • Posts: 65
Re: SA Facebook Connect Integration [now supports smf1 and smf2]
« Reply #430 on: May 22, 2010, 11:23:05 PM »
Hello sleepy arcade, i want to thank you for  a great mode, it works fine but I seem to have a few problems.

I believe that the essence of the mod is for one to login in directly to an smf using the individual's fb login but I installed the mod on smf 1.1.11 using manual install and everything seems to be working fine except that, one cannot login via the fbconnect, if one tries to do that it would loginto facebook but not on my smf

In your reply to #24 in #25 which is similar to mine (except I don't have any of his coded problems )  I noticed you mentioned somethings about "register option" in admin but i didn't see that feature when I went to my admin.

Is there something i am missing?


ALso when I did the parse for SA Facebook Connect Integration - Installation Instructions for 1.1.11, i got to the end and  saw this:

"Code
installScript.php
This file should be able to execute standalone."


how do i run the installscript.php?

Thank you for your time, ALso please do you have another option for donations. Paypal doesn't accept my country

Offline vomega

  • Semi-Newbie
  • *
  • Posts: 14
Re: SA Facebook Connect Integration [now supports smf1 and smf2]
« Reply #431 on: May 23, 2010, 12:14:11 AM »
how can I have this mod work with the extrene 10 theme?

script please..

Offline Divaksh

  • Jr. Member
  • **
  • Posts: 214
  • Gender: Male
  • Sharing is Caring
    • Divaksh on Facebook
    • Divaksh on GitHub
    • @Divaksh on Twitter
    • Divaksh.Me
Re: SA Facebook Connect Integration [now supports smf1 and smf2]
« Reply #432 on: May 23, 2010, 08:02:47 AM »
I get this error when login using facebook connect(Integrate forum account with Facebook. also)

Fatal error: Class 'Facebook' not found in /home/hackmycr/public_html/forum/Sources/FB_Connect/FB_Connect_Subs.php  on line 359
« Last Edit: May 23, 2010, 08:10:11 AM by ÐіνÂкѕн »

Offline RCC_SaMiaM

  • Jr. Member
  • **
  • Posts: 195
  • Gender: Male
  • I'm a llama!
    • firearmory.com
Re: SA Facebook Connect Integration [now supports smf1 and smf2]
« Reply #433 on: May 23, 2010, 11:19:47 AM »
OK I had some progress, sort of.  I typically don't use www. in my urls, in the facebook app url I did use www., so after pulling it when using facebook connect everything seems to work correctly, except for when it shows the login in screen/create account screen, when clicking the link and logging in I don't see any difference.  When I click on the integrate with facebook link it just popped up a blank fb accept box.  After that it just flashes a popup quickly and it goes away.

What exactly are we suppose to see if this works correctly?

Offline HeNdRo

  • Newbie
  • *
  • Posts: 5
Re: SA Facebook Connect Integration [now supports smf1 and smf2]
« Reply #434 on: May 23, 2010, 11:35:05 PM »
Now, my new stupid question is:
How to view FB Connect button on the frontpage of the forum?

Offline venex

  • Jr. Member
  • **
  • Posts: 123
Re: SA Facebook Connect Integration [now supports smf1 and smf2]
« Reply #435 on: May 25, 2010, 08:00:56 PM »
OK I had some progress, sort of.  I typically don't use www. in my urls, in the facebook app url I did use www., so after pulling it when using facebook connect everything seems to work correctly, except for when it shows the login in screen/create account screen, when clicking the link and logging in I don't see any difference.  When I click on the integrate with facebook link it just popped up a blank fb accept box.  After that it just flashes a popup quickly and it goes away.

What exactly are we suppose to see if this works correctly?
U JUST FIXED ONE OF MY ERRORS lmao! I put "www" on Facebook too and that messed eveything up lmao. But Now I have a blank screen when is in "sync"... idk what to do...

cant get this mod to work

API Error Code: 100
API Error Description: Invalid parameter
Error Message: Invalid parameter

i followed every single step carefully, ive created the facebook app still get same error

see forum  vandeatta.com/elchoneo/

Check URL is the same in your forum and in facebook's app (EVEN "WWW" MATTERS!)...

Offline 4X4UK

  • Semi-Newbie
  • *
  • Posts: 39
  • Gender: Male
    • 4x4 UK
Re: SA Facebook Connect Integration [now supports smf1 and smf2]
« Reply #436 on: May 27, 2010, 10:03:51 AM »
wonder if you can help

installed in smf v1.11 and using a custom template, which I have modified everything seems to work ie share works integrate with FB seems to apart from one small bit

when you click on integrate with FB, the pop up apears asks for permission to share info when you click ok the resultant page which has the following url

http://www.4x4uk.org/forums/index.php?action=facebook;sa=sync

is completely blank, can't seem to figure out why
also noticed that if I log out of the forum and stay logged in to facebook if I click on the login with Facebook link that would appear to guests the also gives a blank page (http://www.4x4uk.org/forums/index.php?action=facebook;sa=connect;step) and wont log me in

Facebook connect settings as follows:
connect url: http://www.4x4uk.org/forums/
account preview: http://www.4x4uk.org/
all other fields left blank

any pointers as to what could be the problem would be greatly appreciated many thanks
Ian
« Last Edit: May 27, 2010, 10:08:11 AM by 4X4UK »

Offline RCC_SaMiaM

  • Jr. Member
  • **
  • Posts: 195
  • Gender: Male
  • I'm a llama!
    • firearmory.com
Re: SA Facebook Connect Integration [now supports smf1 and smf2]
« Reply #437 on: May 27, 2010, 10:27:49 AM »
Seems to be the same problem 3 times in a row :)

Offline 4X4UK

  • Semi-Newbie
  • *
  • Posts: 39
  • Gender: Male
    • 4x4 UK
Re: SA Facebook Connect Integration [now supports smf1 and smf2]
« Reply #438 on: May 27, 2010, 10:30:31 AM »
yes does seem to be very similar

Offline nicke157

  • Newbie
  • *
  • Posts: 8
Re: SA Facebook Connect Integration [now supports smf1 and smf2]
« Reply #439 on: May 30, 2010, 05:47:55 PM »
How I do if I want the "Connect with Facebook" button on frontpage with theme "ModernDark64"?