Advertisement:

Author Topic: httpBL  (Read 375841 times)

Offline landyvlad

  • Jr. Member
  • **
  • Posts: 285
    • Michael Reed on Facebook
    • GSX1400 Owners ORG
Re: httpBL
« Reply #1300 on: March 26, 2017, 09:49:41 PM »
OK so it seems it is working.  In the last 4 days it has detected and stopped (according to the spammers log page) 8 attempts, from 3 different IP addresses in total.

At the same time though an average of two a day are getting through past this to be intercepted by the "stop spammer' mod.

I couldn't find anything which details the difference between the various 'logs' so am seeking some guidance on this:

The 'humans log' indicates that two high threat ones have been stopped (and these are from the same IP as 6 of those in the 'spammers log'. It was also detected stopped 7 medium threat and one low threat attempt.

How does it know / decide whether it is a bot or human spammer attack?  I presume that's what the difference between these two logs is.


What is the "Errors Log" ?  As in what does it record - what sort of 'errors' ?
In the brief time this mod has been up and running, the errors log extends to 94 pages!
Also the IP column of that log has strange (non IP) codes in it eg. 2a02:c7f:d81b:a0  so obviously recording something different and just displaying it there?

Thanks for your help.
Please do not PM, IM or Email me with questions on astrophysics or theology.  You will get better and faster responses by asking homeless people in the street. Thank you.

Offline snoopy_virtual

  • Sophist Member
  • *****
  • Posts: 1,155
  • Gender: Male
    • jcredondosnoopy on Facebook
    • Snoopy Virtual Studio
Re: httpBL
« Reply #1301 on: March 28, 2017, 09:01:14 AM »
The 'humans log' indicates that two high threat ones have been stopped (and these are from the same IP as 6 of those in the 'spammers log'. It was also detected stopped 7 medium threat and one low threat attempt.

How does it know / decide whether it is a bot or human spammer attack?  I presume that's what the difference between these two logs is.

The Humans log is where you can see the visitors who have seen the captcha inside the warning page and who have answered the questions.

Only humans should be able to answer those questions. (That's how the program knows if they are human or robots).

But it looks like you are getting spam-bots who are visiting your site and answering the questions.

That means you haven't made the change to the warning page I suggested (or you have don't it wrong).

In all my sites I usually get something like 100 entries per day in the spammers log but just 1 or 2 per week in the humans log.

What is the "Errors Log" ?  As in what does it record - what sort of 'errors' ?
In the brief time this mod has been up and running, the errors log extends to 94 pages!
Also the IP column of that log has strange (non IP) codes in it eg. 2a02:c7f:d81b:a0  so obviously recording something different and just displaying it there?

The entries in the Errors log are all the errors inside the program so it should be always empty unless there is something wrong with the mod.

I already told you it would be a lot easier for me to see what's wrong if we could talk using Skype and I could take a look at your site using Teamviewer.
El verdadero sabio es aquel que lo ve todo, lo estudia todo, lo analiza todo y molesta poco.
A true wise man is he who sees everything, studies everything, analyses everything and hardly ever annoys.

Offline landyvlad

  • Jr. Member
  • **
  • Posts: 285
    • Michael Reed on Facebook
    • GSX1400 Owners ORG
Re: httpBL
« Reply #1302 on: March 28, 2017, 09:42:29 AM »
OK snoopy I'll get to work on getting skype working in next few days.  Cheers mate.
Please do not PM, IM or Email me with questions on astrophysics or theology.  You will get better and faster responses by asking homeless people in the street. Thank you.

Offline edi1967

  • Semi-Newbie
  • *
  • Posts: 15
Re: httpBL
« Reply #1303 on: May 01, 2017, 04:41:17 PM »
hi snoopy i using your Who.template of here:

http://www.simplemachines.org/community/index.php?topic=366399.msg2816231#msg2816231

but i have one little problem in your Who.template there are a couple of strings that i have not translated in my italian forum so them create me errore.
Please you could help me and tell me them translation?

$txt[139] = ?
$txt[92] = ?

thank you so much



Offline snoopy_virtual

  • Sophist Member
  • *****
  • Posts: 1,155
  • Gender: Male
    • jcredondosnoopy on Facebook
    • Snoopy Virtual Studio
Re: httpBL
« Reply #1304 on: May 02, 2017, 06:39:43 AM »
That was done 7 years ago and it was for SMF 1. That's why you cannot find those old $txt entries.

If you are using SMF 2 that page shouldn't work properly. Is it working for you?

Anyway, if you check the source code of SMF 1, in the file /Themes/default/languages/index.english.php you can see:

Code: [Select]
$txt[139] = 'Pages';
$txt[92] = 'View the profile of';
El verdadero sabio es aquel que lo ve todo, lo estudia todo, lo analiza todo y molesta poco.
A true wise man is he who sees everything, studies everything, analyses everything and hardly ever annoys.

Offline edi1967

  • Semi-Newbie
  • *
  • Posts: 15
Re: httpBL
« Reply #1305 on: May 02, 2017, 08:14:03 AM »
That was done 7 years ago and it was for SMF 1. That's why you cannot find those old $txt entries.

If you are using SMF 2 that page shouldn't work properly. Is it working for you?


Work perfectly in SMF 2.0.13

Thxnk you

Offline skitty

  • Newbie
  • *
  • Posts: 1
Re: httpBL
« Reply #1306 on: May 21, 2017, 04:32:02 PM »
just out of curiosity i keep getting Type of error: Undefined in the logs for the forums. its been happening it for a while but i never really looked at it that much.

Offline snoopy_virtual

  • Sophist Member
  • *****
  • Posts: 1,155
  • Gender: Male
    • jcredondosnoopy on Facebook
    • Snoopy Virtual Studio
Re: httpBL
« Reply #1307 on: May 22, 2017, 10:02:54 AM »
just out of curiosity i keep getting Type of error: Undefined in the logs for the forums. its been happening it for a while but i never really looked at it that much.

Could you copy the exact error you are getting and paste it here?

I mean the full text.

Just "Type of error: Undefined" could be almost anything.
El verdadero sabio es aquel que lo ve todo, lo estudia todo, lo analiza todo y molesta poco.
A true wise man is he who sees everything, studies everything, analyses everything and hardly ever annoys.

Offline landyvlad

  • Jr. Member
  • **
  • Posts: 285
    • Michael Reed on Facebook
    • GSX1400 Owners ORG
Re: httpBL
« Reply #1308 on: September 02, 2017, 11:53:21 PM »
I've been seeing a MASSIVE increase in Spammers over the lest few weeks.

It's only a small forum www.gsx1400owners.org ,  running SMF 2.0.13
I am running this httpBL mod as well as Stop Spammer mod (I'll ask there as well). Current versions of course.

Where we previously might have had to manually reject one or two a week, we are now manually rejecting at least 10 (often many more) each day. A few are even getting through to the forum itself (not being intercepted at all)

I get that they are largely being stopped and popped into the moderation queue BUT these are usually flagged red (spammers) against both the IP AND email address.  I'd have thought it should automatically boot those, rather than leave them for moderation?  That is, shouldn't they be intercepted and 'killed' before even making it to the possibility if registering.. which appears to be what's happening?

If you have any advice about how I should be addressing this issue, I'd be most appreciative.


(oh and one secondary question - I'm considering updating, I assume no problems between this mod and SMF2.0.14? )
 
Please do not PM, IM or Email me with questions on astrophysics or theology.  You will get better and faster responses by asking homeless people in the street. Thank you.

Offline Kindred

  • The Mean One
  • Support Specialist
  • SMF Legend
  • *
  • Posts: 55,122
  • Gender: Male
    • Kindred-999 on GitHub
Re: httpBL
« Reply #1309 on: September 03, 2017, 06:35:09 AM »
Add good questions
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

Offline ms_ukyankee

  • Full Member
  • ***
  • Posts: 529
  • Gender: Female
Re: httpBL
« Reply #1310 on: September 03, 2017, 07:44:09 AM »
Quote
I've been seeing a MASSIVE increase in Spammers over the lest few weeks.

I get this once or twice a year and I notice it drops off again if I change the questions and answers when I notice an increase. I'm guessing they use a bot to auto-fill answers, so if the answers change it doesn't work anymore. It seems to solve the problem for a few months.
SMF since 2004 <3

Offline Kindred

  • The Mean One
  • Support Specialist
  • SMF Legend
  • *
  • Posts: 55,122
  • Gender: Male
    • Kindred-999 on GitHub
Re: httpBL
« Reply #1311 on: September 03, 2017, 08:33:11 AM »
You should have at least 20 questions in the stack and ask 2-3 at registration.
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

Offline landyvlad

  • Jr. Member
  • **
  • Posts: 285
    • Michael Reed on Facebook
    • GSX1400 Owners ORG
Re: httpBL
« Reply #1312 on: September 03, 2017, 08:49:45 AM »
Twenty? Ouch ?!
I had a single Q&A.  That's now deleted

I now have 6 Q&A with a requirement of 2 to be answered.  Will see how that goes, thanks.

(Out of interest I don't suppose that if a bot does get through there is any way of knowing what question was compromised? ) 
Please do not PM, IM or Email me with questions on astrophysics or theology.  You will get better and faster responses by asking homeless people in the street. Thank you.

Offline Kindred

  • The Mean One
  • Support Specialist
  • SMF Legend
  • *
  • Posts: 55,122
  • Gender: Male
    • Kindred-999 on GitHub
Re: httpBL
« Reply #1313 on: September 03, 2017, 01:17:31 PM »
No...
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

Offline landyvlad

  • Jr. Member
  • **
  • Posts: 285
    • Michael Reed on Facebook
    • GSX1400 Owners ORG
Re: httpBL
« Reply #1314 on: September 06, 2017, 09:37:43 AM »
The changes seemed to have stemmed the flow back to close to 'normal'. Thanks
Please do not PM, IM or Email me with questions on astrophysics or theology.  You will get better and faster responses by asking homeless people in the street. Thank you.

Offline Torngate

  • Semi-Newbie
  • *
  • Posts: 21
  • Gender: Male
    • Torngate on GitHub
    • Shadow Fleet
Re: httpBL
« Reply #1315 on: November 30, 2017, 08:43:13 AM »
First I wanna say I love this mod, but I've been having two errors pop up in my logs with alarming frequency (Thousands a day, somehow?) that don't seem to be impacting performance on the site or the mod, yet show up and I can't say I understand them.

First, a "general" class error.

8: Undefined variable: ip
Apply Filter: Only show the errors from this file
File: /blahblahblahblah/forum/Sources/httpBL_Subs.php
Line: 519

and a "Uncategorized" error

2: Missing argument 1 for httpBL_look_for_empty_ip(), called in /home2/shadowi7/public_html/forum/Sources/httpBL_Subs.php on line 680 and defined
Apply Filter: Only show the errors from this file
File: /thingstuffthing/forum/Sources/httpBL_Subs.php
Line: 517

Any idea how to fix those? They seem to happen at random, when a user does a lot of things.

Any help would be appreciated!

Forum Version: SMF 2.0.15,
PHP: 7.0.25
Server version: Apache

I can provide more information if needed.

Thanks!
Site Administrator- Shadow Fleet Star Trek RPG

Offline snoopy_virtual

  • Sophist Member
  • *****
  • Posts: 1,155
  • Gender: Male
    • jcredondosnoopy on Facebook
    • Snoopy Virtual Studio
Re: httpBL
« Reply #1316 on: December 02, 2017, 01:13:11 PM »
@Torngate

Sorry.

This is a known bug that I discovered ages ago, but never found time to sort.

Look inside your Sources folder for the file httpBL_Subs.php

Inside that file look for the line:

Code: [Select]
$ip = httpBL_look_for_empty_ip();

Replace with:

Code: [Select]
$ip = httpBL_look_for_empty_ip($ip);

And that's it. Problem sorted.
El verdadero sabio es aquel que lo ve todo, lo estudia todo, lo analiza todo y molesta poco.
A true wise man is he who sees everything, studies everything, analyses everything and hardly ever annoys.

Offline Torngate

  • Semi-Newbie
  • *
  • Posts: 21
  • Gender: Male
    • Torngate on GitHub
    • Shadow Fleet
Re: httpBL
« Reply #1317 on: December 04, 2017, 06:57:48 PM »
@Torngate

Sorry.

This is a known bug that I discovered ages ago, but never found time to sort.

Look inside your Sources folder for the file httpBL_Subs.php

Inside that file look for the line:

Code: [Select]
$ip = httpBL_look_for_empty_ip();

Replace with:

Code: [Select]
$ip = httpBL_look_for_empty_ip($ip);

And that's it. Problem sorted.

This worked great! Thank you!
Site Administrator- Shadow Fleet Star Trek RPG