Advertisement:

Author Topic: httpBL  (Read 475557 times)

Offline Shades.

  • Jr. Member
  • **
  • Posts: 388
  • Gender: Male
  • BikerHound.com
    • bikerhound on Facebook
    • @bikerhoundcom on Twitter
    • Bikerhound.com
Re: httpBL
« Reply #1360 on: December 31, 2020, 03:07:18 PM »
Congrats, and I'm so sorry at the same time :P
eh well simple enough to disable ipv6 on my computer  ;D and I'm back up and running again...

hm, but this could be a problem for my users...hm.....well about that....may still need to remove this mod anyways if others who use ipv6 can't access the site, that's gonna be an issue
I just tested my connection at testmyipv6.com and it says Im on this ipv6. I'm also using this mod on several of my sites and have had no issues myself. I hope this wont be a problem.  :o 8)

BikerHound.com
Sniffing out the road ahead
https://bikerhound.com

Dream as if you'll live forever; Live as if you'll die today. - James Dean

Offline Aleksi "Lex" Kilpinen

  • A Peculiar Finn
  • Project Manager
  • SMF Super Hero
  • *
  • Posts: 19,592
  • Gender: Male
  • Don't worry, I'm n00b friendly
    • Aleksi.Kilpinen on Facebook
    • LexArma on GitHub
    • aleksi-kilpinen on LinkedIn
    • My Daily Dose Of Blasphemy
Re: httpBL
« Reply #1361 on: December 31, 2020, 03:11:37 PM »
Could also be a different version of the mod, or something else differing - but based on the error I saw, the DB field for IP in shadav's install couldn't hold an IPv6 address because of it's length.
A Finnish Project Manager (Support Specialist)
Happily running multiple SMF 2.x installations.
 Fooling around with an i7-10700 @ 2,90GHz-4.80GHz / 16Gb / RTX-2070 Super / 3840x2160 / Win 10 x64


How you can help SMF

"Before you allow people access to your forum, especially in an administrative position, you must be aware that that person can seriously damage your forum.
Therefore, you should only allow people that you trust, implicitly, to have such access." -Douglas

Offline shadav

  • Support Specialist
  • Sophist Member
  • *
  • Posts: 1,053
  • Gender: Female
    • shadav on Facebook
    • leashadav on GitHub
    • Ask The Muslims: A Place To Ask Honest Questions and Receive Respectful Answers
Re: httpBL
« Reply #1362 on: December 31, 2020, 03:24:57 PM »
here's where Lex is talking about

after a day of my site being down...I thought it was my host at first but then turns out it wasn't....for me I was seeing database error message but for everoyne else the site was fine....
after checking error logs httpbl was the one giving issues...which again is strange as it hadn't ever popped up before

https://www.simplemachines.org/community/index.php?topic=576208.0

after fixing the default to null, the last error that showed up was

Database Error: Data too long for column 'ip' at row 1<br /><br /><br />         INSERT INTO smf_log_httpBL(`logTime`, `ip`, `threat`, `last_activity`, `suspicious`, `harvester`, `comment`, `url`, `user_agent`, `errorNumber`, `username`, `raw`, `stopped`)<br />         VALUES<br />            (1609402130, '2601:805:8204:1430:7415:e9a:1fa1:68ab', 0, 0, 0, 0, 0, '/index.php?action=enotify', 'Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/87.0.4280.88 Safari/537.36', 200, 'Guest', 'unknown', 2)

Offline SugarD-x

  • Jr. Member
  • **
  • Posts: 399
  • Gender: Male
  • SMF and PHPBB Fan
    • SugarDx on Facebook
    • SugarD-x on GitHub
    • sugardx on LinkedIn
    • @SugarDx on Twitter
    • Clan Xperience
Re: httpBL
« Reply #1363 on: January 03, 2021, 10:34:32 AM »
Database Error: Data too long for column 'ip' at row 1<br /><br /><br />         INSERT INTO smf_log_httpBL(`logTime`, `ip`, `threat`, `last_activity`, `suspicious`, `harvester`, `comment`, `url`, `user_agent`, `errorNumber`, `username`, `raw`, `stopped`)<br />         VALUES<br />            (1609402130, '2601:805:8204:1430:7415:e9a:1fa1:68ab', 0, 0, 0, 0, 0, '/index.php?action=enotify', 'Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/87.0.4280.88 Safari/537.36', 200, 'Guest', 'unknown', 2)
That's likely because SMF 2.0.x is designed to store IPv4 addresses only, which are a specific length. IPv6 support was officially added in SMF 2.1.x, however this mod sadly has not been updated to support those versions yet. :(

Offline spiros

  • Language Moderator
  • SMF Hero
  • *
  • Posts: 1,956
  • Gender: Male
  • A different point of view
    • spiros.doikas on Facebook
    • doikas on LinkedIn
    • @greektranslator on Twitter
    • Greek Translation
Re: httpBL
« Reply #1364 on: February 02, 2021, 08:31:58 AM »
I just upgraded  to smf 2.0.18 and php 7.4  and I get multiple errors in error log:

Code: [Select]
8: Trying to access array offset on value of type null
 /home/translat/public_html/forum/Sources/httpBL_Subs.php
Line 674
$values['raw'] = $txt['httpBL_unknown'];
Line: 672
$values['username'] = $user_info['is_guest'] ? $txt['guest'] : $user_info['username'];

Offline Kolya

  • Full Member
  • ***
  • Posts: 480
  • systemshock.org
Re: httpBL
« Reply #1365 on: February 07, 2021, 06:09:41 AM »
I'm also on smf 2.0.18. I don't get any errors, possibly because I disabled all the translation stuff long ago.
But the mod is clearly not working either. HttpBL's spammers log just lists a lot of IPv6 addresses, without any further information besides "Guest" in the User column.
I've disabled this mod for now.

Offline spiros

  • Language Moderator
  • SMF Hero
  • *
  • Posts: 1,956
  • Gender: Male
  • A different point of view
    • spiros.doikas on Facebook
    • doikas on LinkedIn
    • @greektranslator on Twitter
    • Greek Translation
Re: httpBL
« Reply #1366 on: February 07, 2021, 06:52:33 AM »
Yes, I had to disable it until a fix is provided -:)
Pity, because it is a good mod.
Nice theme in your site by the way, which one is it?
« Last Edit: February 07, 2021, 07:03:46 AM by spiros »

Offline SugarD-x

  • Jr. Member
  • **
  • Posts: 399
  • Gender: Male
  • SMF and PHPBB Fan
    • SugarDx on Facebook
    • SugarD-x on GitHub
    • sugardx on LinkedIn
    • @SugarDx on Twitter
    • Clan Xperience
Re: httpBL
« Reply #1367 on: February 07, 2021, 07:32:28 AM »
Your issue is probably because of the same problem others are having:

That's likely because SMF 2.0.x is designed to store IPv4 addresses only, which are a specific length. IPv6 support was officially added in SMF 2.1.x, however this mod sadly has not been updated to support those versions yet. :(

Offline Kolya

  • Full Member
  • ***
  • Posts: 480
  • systemshock.org
Re: httpBL
« Reply #1368 on: February 07, 2021, 08:55:36 AM »
Nice theme in your site by the way, which one is it?
Thanks, it is self-created. Worked on it for some 15 years and became a frontend-dev over that.

Offline riou

  • Semi-Newbie
  • *
  • Posts: 40
Re: httpBL
« Reply #1369 on: February 07, 2021, 06:31:55 PM »
I just upgraded  to smf 2.0.18 and php 7.4  and I get multiple errors in error log:

Code: [Select]
8: Trying to access array offset on value of type null
 /home/translat/public_html/forum/Sources/httpBL_Subs.php
Line 674
$values['raw'] = $txt['httpBL_unknown'];
Line: 672
$values['username'] = $user_info['is_guest'] ? $txt['guest'] : $user_info['username'];


it seems the problem is that it doesn't find values for those $txt things if you replace $txt['guest'] with "guest" and $txt['httpBL_unknown'] with "unknown" (what they match in the english mod language file) it will make it stop erroring, not sure why it isn't picking it up from the language files anymore, not sure if more of the $txt's will have to do this too or not for now
« Last Edit: February 07, 2021, 07:11:21 PM by riou »

Offline Shades.

  • Jr. Member
  • **
  • Posts: 388
  • Gender: Male
  • BikerHound.com
    • bikerhound on Facebook
    • @bikerhoundcom on Twitter
    • Bikerhound.com
Re: httpBL
« Reply #1370 on: February 18, 2021, 07:28:14 PM »
I have this installed and working fine on several 2.0.17 sites but on one site I try to install it and get the following:
Code: [Select]
Table 'mysite_xxxx.bh_log_httpBL' doesn't exist
File: /home2/mysite/public_html/xxxx/Packages/temp/install_2.php
Line: 68

Do i need to create that table and if so how or what is the query?
Just installed it on a fresh 2.0.18 install and it works fine but still cant get it to install on the site in quotes because the table doesnt exist. Any help on this please?

BikerHound.com
Sniffing out the road ahead
https://bikerhound.com

Dream as if you'll live forever; Live as if you'll die today. - James Dean