Advertisement:

Author Topic: httpBL  (Read 467480 times)

Offline MartiMedia

  • Semi-Newbie
  • *
  • Posts: 28
Re: httpBL
« Reply #1340 on: January 22, 2019, 05:45:42 PM »
Ah ok, if so, is there a fix?

Offline SugarD-x

  • Jr. Member
  • **
  • Posts: 381
  • Gender: Male
  • SMF and PHPBB Fan
    • SugarDx on Facebook
    • SugarD-x on GitHub
    • sugardx on LinkedIn
    • @SugarDx on Twitter
    • Clan Xperience
Re: httpBL
« Reply #1341 on: January 27, 2019, 07:02:39 PM »
Ah ok, if so, is there a fix?
That would be up to the mod author to fix.

Offline shadav

  • Full Member
  • ***
  • Posts: 435
  • Gender: Female
    • Ask The Muslims: A Place To Ask Honest Questions and Receive Respectful Answers
Re: httpBL
« Reply #1342 on: September 09, 2019, 03:00:18 PM »
I tried testing my forum on my phone but I get an error and can't log in

Too few arguments to function httpBL_look_for_empty_ip(), 0 passed in /sources/httpBL_Subs.php on line 680 and exactly 1 expected
on line 680
Code: [Select]
$ip = httpBL_look_for_empty_ip();
lines 666 to 691
Code: [Select]
// Initialize some values and add some more stuff you could log for further analysis
$values = array();
$httpBL_url = httpBL_get_env('REQUEST_URI');
$values['url'] = $httpBL_url != '' ? $httpBL_url : '/';
$httpBL_user_agent = httpBL_get_env('HTTP_USER_AGENT');
$values['user_agent'] = $httpBL_user_agent != '' ? $httpBL_user_agent : $txt['httpBL_unknown'];
$values['username'] = $user_info['is_guest'] ? $txt['guest'] : $user_info['username'];
$values['stopped'] = 1;
$values['raw'] = $txt['httpBL_unknown'];
// If we ever get this error number something has gone really wrong
$values['errorNumber'] = 300;

// If $ip is empty let's try to find it with more methods
if ($ip == '')
$ip = httpBL_look_for_empty_ip();

$values['ip'] = $ip;
if ($values['ip'] == '')
{
// Still empty? Stop the visitor. Sorry, no blanks IPs allowed
// TO DO: Find more methods or more possibilities why sometimes $ip is blank
$values['errorNumber'] = 150;
$values['ID'] = httpBL_logme($values, true);
//httpBL_session_put_data($httpBL_session, $values, $cache_seconds);
return $values;
}

Offline Kindred

  • The Mean One
  • Support Specialist
  • SMF Legend
  • *
  • Posts: 59,308
  • Gender: Male
    • Kindred-999 on GitHub
Re: httpBL
« Reply #1343 on: September 09, 2019, 03:31:36 PM »
I don't think this mod has been updated for php 7.2

but, then again, SMF itself does not currently support php 7.2
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

Offline SugarD-x

  • Jr. Member
  • **
  • Posts: 381
  • Gender: Male
  • SMF and PHPBB Fan
    • SugarDx on Facebook
    • SugarD-x on GitHub
    • sugardx on LinkedIn
    • @SugarDx on Twitter
    • Clan Xperience
Re: httpBL
« Reply #1344 on: September 09, 2019, 05:48:24 PM »
I don't think this mod has been updated for php 7.2

but, then again, SMF itself does not currently support php 7.2
^This.

Unfortunately it also doesn't work on SMF 2.1.x, which makes me sad. :(

Offline shadav

  • Full Member
  • ***
  • Posts: 435
  • Gender: Female
    • Ask The Muslims: A Place To Ask Honest Questions and Receive Respectful Answers
Re: httpBL
« Reply #1345 on: September 09, 2019, 06:57:28 PM »
hm...hadn't paid attention, just switched to a new host and yeah my php is 7.2
if I use something lower will this work?
odd lol everything else so far seems to be working  ???

Offline riou

  • Semi-Newbie
  • *
  • Posts: 38
Re: httpBL
« Reply #1346 on: September 09, 2019, 08:43:37 PM »
I tried testing my forum on my phone but I get an error and can't log in

Too few arguments to function httpBL_look_for_empty_ip(), 0 passed in /sources/httpBL_Subs.php on line 680 and exactly 1 expected
on line 680
Code: [Select]
$ip = httpBL_look_for_empty_ip();


Believe the fix to this was changing that line to

Code: [Select]
$ip = httpBL_look_for_empty_ip($ip);

The mod was never updated to fix this and I think maybe the other issue that has existed for a bit in the 2.0 line

Offline shadav

  • Full Member
  • ***
  • Posts: 435
  • Gender: Female
    • Ask The Muslims: A Place To Ask Honest Questions and Receive Respectful Answers
Re: httpBL
« Reply #1347 on: September 09, 2019, 09:29:10 PM »
I tried testing my forum on my phone but I get an error and can't log in

Too few arguments to function httpBL_look_for_empty_ip(), 0 passed in /sources/httpBL_Subs.php on line 680 and exactly 1 expected
on line 680
Code: [Select]
$ip = httpBL_look_for_empty_ip();


Believe the fix to this was changing that line to

Code: [Select]
$ip = httpBL_look_for_empty_ip($ip);

The mod was never updated to fix this and I think maybe the other issue that has existed for a bit in the 2.0 line

thank you that seems to have fixed the issue

Offline snoopy_virtual

  • Sophist Member
  • *****
  • Posts: 1,157
  • Gender: Male
    • jcredondosnoopy on Facebook
    • Snoopy Virtual Studio
Re: httpBL
« Reply #1348 on: March 01, 2020, 10:18:46 AM »
Thanx @SugarD-x , I'm talking about the httbl error log.. In the httpbl mod page (in the admin console) it shows:
'Mod httpBL is ON, it is up-to-date and the connection with HoneyPot is perfect.'

I thought it may have to do with guests trying to register with a hidden ip (from a VPN for example)..
Anyway I'd like to get rid of those errors, so they don't flood my log, which help to analyse other less frequent messages (hard to spot now).
Unless the 'Cannot check. IP not normal. Allowed to pass' is an error I have to take action upon of course ;-)
Oh! I wonder if this could be a possible IPv6 issue then.

@MartiMedia
@SugarD-x

Sorry, I had missed this conversation.

Yes, that kind of errors are related to IPv6

But the problem is not to update httpBL or StopSpammer mods.

The problem is that both databases from Project Honey Pot and Stop Forum Spam only have the IPv4 data.

The only solution will be to update first both projects or to create new ones with both IPv4 and IPv6 in mind from the start.

And then change our mods or create new ones.

I don't think this mod has been updated for php 7.2

but, then again, SMF itself does not currently support php 7.2


I should make a version for 2.1 one day.

The problem is I'm still using 2.0.17 in all my forums.

As soon as I update one of them to 2.1 it would be urgent for me to have these mods updated, but I don't know when that could be.

I tried testing my forum on my phone but I get an error and can't log in

Too few arguments to function httpBL_look_for_empty_ip(), 0 passed in /sources/httpBL_Subs.php on line 680 and exactly 1 expected
on line 680
Code: [Select]
$ip = httpBL_look_for_empty_ip();


Believe the fix to this was changing that line to

Code: [Select]
$ip = httpBL_look_for_empty_ip($ip);

The mod was never updated to fix this and I think maybe the other issue that has existed for a bit in the 2.0 line

thank you that seems to have fixed the issue

That's another thing I should have sorted ages ago and keep forgetting.

The problem is, with IPv6 spreading all over the world, all the programs based only in IPv4 are going to be obsolete soon, so I don't seem to really look after them as I should.
El verdadero sabio es aquel que lo ve todo, lo estudia todo, lo analiza todo y molesta poco.
A true wise man is he who sees everything, studies everything, analyses everything and hardly ever annoys.

Offline SugarD-x

  • Jr. Member
  • **
  • Posts: 381
  • Gender: Male
  • SMF and PHPBB Fan
    • SugarDx on Facebook
    • SugarD-x on GitHub
    • sugardx on LinkedIn
    • @SugarDx on Twitter
    • Clan Xperience
Re: httpBL
« Reply #1349 on: March 01, 2020, 11:39:08 AM »
Glad to see you're back!

I agree on IPv6 being the future, however I wouldn't quite hold my breathe yet on it. While support for it has been widespread in the last several years, very few places put it as the priority in their web applications and software. Likewise, ISP's are relying heavily on IPv4 addresses being constantly reused, (dynamic IP's are very common now on residential internet services), so they will probably fight to the death on keeping IPv4 as the main standard until it simply cannot handle the amount of devices anymore. (Think of it like the Y2K panic where everyone waited until the last minute to update their systems to support the new millennium rollover. I see something similar happening with the IPv6 takeover).

That being said, I personally welcome the idea of IPv6 support being added, but I completely understand your reasoning behind why this has been held back. (Project Honeypot and Stop Forum Spam need to get on this!)


As for SMF 2.1, I'd absolutely LOVE it if httpBL and StopSpammer supported it. Right now I'm running my 2.1 forum without any anti-spam mods simply because none exist. Your mods are hands down the best I've seen, and definitely the most effective. On my old 2.0.x forums elsewhere, I used to couple them with a group of other miscellaneous anti-spam mods that queried smaller databases just so I could catch the few rare ones that slipped through, (and boy were they rare). If 2.1 versions existed, I would install them right now. These mods are absolutely incredible. Please, please, please add 2.1 support!


On a side note, your mods are so effective that even my PHPBB 3.1 forums use similar mods to query the same databases, that's how much I believe in them. Your SMF versions still blow the PHPBB equivalents out of the water too, and I've been using both forum softwares for a very long time.