• Welcome to Simple Machines Community Forum. Please login or sign up.
December 08, 2021, 09:33:29 AM

News:

Bored?  Looking to kill some time?  Want to chat with other SMF users?  Join us in IRC chat or Discord


Issues after RC3 upgrade

Started by amkrisis, April 11, 2010, 12:56:34 PM

Previous topic - Next topic

amkrisis

Hello

I've recently upgrade my forum from RC2 to RC3 and have had some complaints since I did so.

Mainly IE ( 8 ) users that get blank pages (page cannot be displayed) and can't start new topics.
One of my uses things it might be a cookie issue?

I'm using Firefox and have only had some blank (pages) every once in a while...

Any idea what might cause this?

The forum is located over at http://www.vespaclubleuven.be/forum [nofollow]

Chas Large

Well have just spent a few minutes wandering round your forum with no problems using IE8. All pages loaded and very quickly too with the exception of the home page where the shoutbox took a while to load. That makes a lot of calls server side and may be the cause if your members have slow connections.

The only other problem I could see is your Help file is pretty much blank. This may be due to the language file not being up to date.

Check the Error log for missing files.
My Modifications :)  My Forum

Please DO NOT PM me with support requests. Post the problem in the appropriate Support Board so everyone can benefit from the advice given.

amkrisis

April 11, 2010, 03:36:52 PM #2 Last Edit: April 11, 2010, 03:45:40 PM by amkrisis
Language files have been updated.

Here is a screenshot of the error a user gets.
He doesn't have the error with Chrome

He deleted his temp files and cookies



Maybe it's server related? I just find it strange that this started to happen right after I upgraded to RC3...

amkrisis

I also notice that SSI.PHP in /sources is still v.RC2, and that there isn't an SSI.PHP in the RC3 download?

Chas Large

Maybe that's the problem. SSI.php should be in the forum root folder not sources and it definitely does get upgraded in SP3.

/**********************************************************************************
* SSI.php                                                                         *
***********************************************************************************
* SMF: Simple Machines Forum                                                      *
* Open-Source Project Inspired by Zef Hemel (zef@zefhemel.com)                    *
* =============================================================================== *
* Software Version:           SMF 2.0 RC3                                         *
* Software by:                Simple Machines (http://www.simplemachines.org)     *
* Copyright 2006-2010 by:     Simple Machines LLC (http://www.simplemachines.org) *
*           2001-2006 by:     Lewis Media (http://www.lewismedia.com)             *
* Support, News, Updates at:  http://www.simplemachines.org         


Try uploading the one from the upgrade pack straight to the forum root and then renaming the one in sources to SSI.php.old
That way you can restore it if needed.
My Modifications :)  My Forum

Please DO NOT PM me with support requests. Post the problem in the appropriate Support Board so everyone can benefit from the advice given.

amkrisis

there allready was a ssi file in the main folder, I've overwritten it just in case and renamed the one in the sources folder.

The one.com [nofollow] hosting panel is down at the moment, so it might be server related ... I'll wait and see when I get a reply on my ticket.

Keep the tips comin in the meanwhile and thanks for all the help so far!

Chas Large

You could suggest that the IE8 users use Compatability Mode, this sometimes helps with certain sites.
My Modifications :)  My Forum

Please DO NOT PM me with support requests. Post the problem in the appropriate Support Board so everyone can benefit from the advice given.

amkrisis

I could suggest not to use IE at all as there are plenty good free alternatives ;)

But some people are stubborn...

I tested IE8 at work, no issues here, very very strange ...

It seems to have issues in Vista, not in Win2k

Chas Large

Well I'm on Xp here and in IE8 without compatibility mode, it shows the problem so it's not an OS thing. Btw you can't get IE8 for Win2K can you? IE8 is a very different beast to IE6 & 7, so that may be what's working on Win2K?

If you look at the core code of SMF you'll see all the fixes the dev's had to put in to overcome IE's poor rendering ability.
My Modifications :)  My Forum

Please DO NOT PM me with support requests. Post the problem in the appropriate Support Board so everyone can benefit from the advice given.

amkrisis

I think you're right

And the <meta http-equiv="X-UA-Compatible" content="IE=EmulateIE7" />    fix doesn't work anymore right?

I guess i'll have to get those stubborn people to push that button :D

Advertisement: