• Welcome to Simple Machines Community Forum. Please login or sign up.
November 27, 2021, 01:42:26 AM

News:

Want to get involved in developing SMF, then why not lend a hand on our github!


Simple ImageShack (latest release: v3.1.3)

Started by Rik©, June 03, 2005, 02:50:34 PM

Previous topic - Next topic

aw06

My site was moved onto a new server ... ImageShack mod is now giving this error ... DO i need to reinstall it ? or do i just wait some more, maybe the name-servers have not completely updated as yet ?

See image
:: ShopinJA.com Powered by SMF 1.1.19 | Ig-Oh Theme by Koni | 70 Rock Solid Error Free Mods | Many Custom Edits & Tweaks ::
- Host Unlimited Websites - Free Website Builder & Templates - Unlimited Disk Space & Bandwidth

Rik©

Quote from: aw06 on August 14, 2010, 11:08:45 PM
My site was moved onto a new server ... ImageShack mod is now giving this error ... DO i need to reinstall it ? or do i just wait some more, maybe the name-servers have not completely updated as yet ?

See image
Did you check the permissions of the SIS folder and subfolders? (755)
What's the error in the server error-log?

-Rik©

aw06

Quote from: Rik© on August 15, 2010, 05:04:30 AM
Quote from: aw06 on August 14, 2010, 11:08:45 PM
My site was moved onto a new server ... ImageShack mod is now giving this error ... DO i need to reinstall it ? or do i just wait some more, maybe the name-servers have not completely updated as yet ?

See image
Did you check the permissions of the SIS folder and subfolders? (755)
What's the error in the server error-log?

-Rik©

The sis folder is set to 755 ... the files inside are set to 644..

This is a message from my host ...
QuoteThis server uses suPHP, which means that file permissions needn't (and
shouldn't) be above 644; directories needn't (and shouldn't) be above
755. These accounts had incorrect permissions, which we had to
properly set in order to get those sites back up online.

Have you tried setting the permissions to 755 instead of 777?

Setting permissions to 777 is usually a bad idea in terms of security anyhow.

Ric .. can you tell me which files need to be set to 755 ?? is it all those files in the sis folder ?
:: ShopinJA.com Powered by SMF 1.1.19 | Ig-Oh Theme by Koni | 70 Rock Solid Error Free Mods | Many Custom Edits & Tweaks ::
- Host Unlimited Websites - Free Website Builder & Templates - Unlimited Disk Space & Bandwidth

Rik©

755(folder) and 644(files) should be ok.
It's probably an ownership issue....

Can you uninstall without errors?
Then i suggest you uninstall SIS and install the latest version.

-Rik©

ps when SIS4RC2 is ready for release i can mail you a copy if you want...


winky100

I tried to install on a 1.1.11 smf platform and got the message that sis was not compatible with this version of smf.

aw06

:: ShopinJA.com Powered by SMF 1.1.19 | Ig-Oh Theme by Koni | 70 Rock Solid Error Free Mods | Many Custom Edits & Tweaks ::
- Host Unlimited Websites - Free Website Builder & Templates - Unlimited Disk Space & Bandwidth

Rik©

Quote from: winky100 on August 16, 2010, 07:42:49 AM
I tried to install on a 1.1.11 smf platform and got the message that sis was not compatible with this version of smf.
Try SIS 3.0.5

Quote from: SMF Mod Site/mod descriptionVersion Information
SIS v3.0.x ⇒ SMF 1.1.11
SIS v3.1.x ⇒ SMF 2.0 RC3


Quote from: aw06 on August 16, 2010, 07:45:46 AM
Explain ownership issue please ?
Maybe you have a user account that lets you upload(ftp) files to the server, but the server itself may be using another user, e.g nobody.
Try uninstalling and then install again with the package manager...

-Rik©

aw06

:: ShopinJA.com Powered by SMF 1.1.19 | Ig-Oh Theme by Koni | 70 Rock Solid Error Free Mods | Many Custom Edits & Tweaks ::
- Host Unlimited Websites - Free Website Builder & Templates - Unlimited Disk Space & Bandwidth

aw06

August 16, 2010, 10:31:38 AM #848 Last Edit: August 16, 2010, 10:44:39 AM by aw06
Seems to be an issue with permissions ... I removed the mod without errors, re-installed it without errors, but it did not work, there was no control panel for it, and it does not show up, All the files uploaded show the owner as 99 .. in the past it use to show me as the owner .. now when i try to uninstall it i get errors on every file..

Error in logs comes up to all associating files....

2: unlink(/home/xxxx/public_html/forum/sis/img/images.png) [<a href='function.unlink'>function.unlink</a>]: Permission denied
:: ShopinJA.com Powered by SMF 1.1.19 | Ig-Oh Theme by Koni | 70 Rock Solid Error Free Mods | Many Custom Edits & Tweaks ::
- Host Unlimited Websites - Free Website Builder & Templates - Unlimited Disk Space & Bandwidth

vroum

Quotethere was no control panel for it

Are you using a supported language ? try to change admin's account language to english & you should be able to see the admin's panel.

Vroum.

aw06

English is set to english-utf8 .. I think its a permission issue, I can't modify any files in the sis folder, says permission denied...
:: ShopinJA.com Powered by SMF 1.1.19 | Ig-Oh Theme by Koni | 70 Rock Solid Error Free Mods | Many Custom Edits & Tweaks ::
- Host Unlimited Websites - Free Website Builder & Templates - Unlimited Disk Space & Bandwidth

vroum

I don't think it's a permission issue, I already had the SIS forlder & files owned by 99 & I couldn't edit'em but the mod was working fine I just had a curl problem at the time but it had nothing to do with the 99

Vroum.

aw06

Hmm... I can edit the files from my other forum on 1.1.11 ... But it's just acting weird on SMF 2.0 ... Now I can't even remove the mod
:: ShopinJA.com Powered by SMF 1.1.19 | Ig-Oh Theme by Koni | 70 Rock Solid Error Free Mods | Many Custom Edits & Tweaks ::
- Host Unlimited Websites - Free Website Builder & Templates - Unlimited Disk Space & Bandwidth

vroum

Can you write a piece of PHP code & call a script with exec() to delete the mod files ?
You are on UNIX/Linux hosting right ?

Vroum.

aw06

I can remove it manually.. I'm gonna wait a while to see if the host can resolve it...
:: ShopinJA.com Powered by SMF 1.1.19 | Ig-Oh Theme by Koni | 70 Rock Solid Error Free Mods | Many Custom Edits & Tweaks ::
- Host Unlimited Websites - Free Website Builder & Templates - Unlimited Disk Space & Bandwidth

aw06

:: ShopinJA.com Powered by SMF 1.1.19 | Ig-Oh Theme by Koni | 70 Rock Solid Error Free Mods | Many Custom Edits & Tweaks ::
- Host Unlimited Websites - Free Website Builder & Templates - Unlimited Disk Space & Bandwidth

telles0808

I downloaded the latest version and tried to install it in my SMF 1.1.11 forum, but when I upload the package and click to apply the MOD it say there have no information about installation inside the package and when I get back to the first page of my mod manager it's there with only one option, the option is "delete".. So, how I can install it?

Rik©

Quote from: aw06 on August 27, 2010, 12:37:41 PM
ok, all is working again  8)
Great  ;)

Quote from: telles0808 on August 28, 2010, 08:27:37 PM
I downloaded the latest version and tried to install it in my SMF 1.1.11 forum, but when I upload the package and click to apply the MOD it say there have no information about installation inside the package and when I get back to the first page of my mod manager it's there with only one option, the option is "delete".. So, how I can install it?
Which SIS version did you try to install? (SIS v3.0.x is for SMF 1.1.11)

-Rik©

DjScrappy

I Keep Getting This On My Forum just when you hit New Topic Or Reply

Thanx DjScrappy aka MaddSmokerz

Rik©

Quote from: DjScrappy on September 19, 2010, 06:18:23 PM
I Keep Getting This On My Forum just when you hit New Topic Or Reply

Thanx DjScrappy aka MaddSmokerz
Which version of Simple ImageShack?

-Rik©

Advertisement: